Is the FBW A32NX still having issues?

Hey everybody, I was just curious is the A32NX still CTD for some of you all. Every time I try to do a full IFR flight, loading in my flight plan, putting in all the numbers and calculations, and so on, the sim crashed to the desktop at random times. I can not pinpoint exactly what is causing it. It happened during my loading of the FlyPad, other it happens after I finish loading up everything and I am about to pushback, and it occasionally happens when loading up the flight plan.

Please tell me I am not the only one?

I think so. I saw people, even FBW said use the dev version. I tried turning on the efb, it crashed. So i just put the stable version back in.

1 Like

In the dev version, i cannot put the throttles in the CLB detent.

in the marketplace version, it does not follow the flight plan and all the buttons on the pedestal continuously flicker.

i guess they will fix it soon.

Even after two hotfixes, I still don´t get perfect stability.

CTDs are now rare, so the sim is usable, but yesterday during my first flight of the day I had a CTD without error message while climbing with the A32NX (using latest developement version).

Aparently, this CTD was caused by the A32NX, since when I tried to update it, FlyByWire´s tool said It was not installed. So, aparently, some kind of corruption happened with the plane.

I deleted it, reinstalled it, and aparently, it is working fine.

Fingers crossed…

1 Like

I’ve used the A32NX for the very first time. Have managed 2 almost 2 hour flights with no issues. Am using the lasted Dev version.

Only mod I have is the EasyJet livery and pay ware airports.

Have you calibrated the detends in the EFB? If not, doing that should solve the issue.

1 Like

Thanks, I’ll have a look.

I had to do this as my idle was full reverse. Wondered what all that noise was when I started the engines :face_with_hand_over_mouth:

Yeah, they pulled the marketplace version. Their website has an updated version I think 6.2?

FBW a320 NX DEV CTD when pressing PRINT in the MCDU.

Latest stable version which is supposedly compatible now with SU5 crashes for me.

The dev version is hit and miss. So until they return the stable version in the marketplace, I would say it’s not completely issue-free just yet.


I have just updated my FBW to the latest version as of today for the development. Managed to get the aircraft running and was able to takeoff however once passing FL190, my sim crashed again. At least I was able to get the aircraft to fly a bit but was not able to complete my flight.

They just released 0.6.3 for the stable build. Supposedly is supposed to address the CTD situation, even the dev version was updated. However still experienced a crash today. Was finally able to get the plane up there but was not able to finish the flight.

You will have informations about FBW Airbus here →