Joystick settings not saved any longer!

Hi. Not sure whats going on but since I got info from FS that there was different savings in cloud and locally (cant remember really), my joystick settings are not saved.

Anything to try before uninstall / reinstall (or repair whatever that is).

What could be the problem? I really, really do not want to make all settings with gfx, joystick and other settings etc again (it was not very long ago I had to do this).

Are you saving them as a new profile?

Hi. I think Ive done both, actually. Is it important to save as new profile? I first thought the game was downloading old settings from the cloud, applying over the one Ive selected in the game (over and over).

I have made an own profile, so Im not using default (Ithats not even possible, right?)

Does it have to be a new name everytime I change sometning?

It constantly after quitting and restarting goes back to this:

I actually thought I had gone crazy. “Didn’t I change that?”

I still get the feeling that the game is fetching something online, and not using or svaing (yeah, the spinning thing is spinning / savging). But then its like gone…

I found this…

Moved to Peripherals.

My apologies, when you said settings, I assumed you meant assignment settings, not sensitivity!! :upside_down_face:

Np. I think the assignments are fine, and saved as they should. I have not changed them for a while though… But would it be possible that they are both saved in same file, and if so - which file? Or is this a quations of a corrupt cloud save (and how to solve that?)

Are you using MS Store or Steam?

Via MS Store

Do you remember if this was the dialog you received?


What you could try is this:

  1. Assure all your settings and controllers are correct in MSFS
  2. Save them then exit MSFS (this should sync to the cloud)
  3. If that dialog pops up, that means it didn’t sync - so choose the one saved on Device

Yes it showed up once. More than a week ago I guess. Since then my settings are not saved. It could also be that I duplicated My settings and removed the older joystick profile that i’ve made. But No such window showing up now.

Are there any ways to Force loading the settings locally? From my computer? Not even sure that this is the problem

There isn’t. By default, it should always use the local settings (when both local and cloud match).

What you could try is to adjust your sensitivity settings again. Apply & Save. Then exit MSFS. Relaunch and see if the settings are still there. You wouldn’t have to adjust everything for this test. Just one item. If it does save, then you know it’s working.

I have tried this several times and no, it is back to how it looks on the screen shot in the link above.

This was noticed by a few others, myself included.
See Bug Report Here also.

Could this be a permissions issue?

Thank you. =) Let’s hope peple are upvoting it.

That’s what I was thinking… however, if it was, wouldn’t MSFS then give an error or CTD trying to write?

Is odd that it is only two of the settings are not being retained after a fresh startup.
Maybe This is related?

Workaround for now is to reset both Extremity & Reactivity after msfs start. It does retain this until shutdown.

No errors or ctd happening.