Just a heads up for 4090 owners, if you notice your GPU not returning to idle after running the sim

As the title says, if you notice that your fans won’t return to whatever idle setting you have enabled (mine are set to 0%) but are stuck at 30% and that your GPU clock is stuck at 2Mz after you close the sim, despite nothing obvious using the GPU, there is a simple fix.

This only happens for me with MSFS and it was doing my head in, as only a PC restart would fix it. The solution is to make sure you don’t set power management mode to Performance in the NVCP, either global or specifically for MSFS. With that setting on normal the problem goes away.


Thanks for that. I`ll try that now.

For me it was following someone else’s settings without understanding what power management: performance mode really did. A trap for young players (or old ones in my case). Live and learn I guess.

How many years old is 422.25?

You’re best trying the 526.61 hot fix, which corrects this issue.


The latest hot fix driver also fixes this issue.



Thanks for that. Just installed it.

1 Like

This wasnt just for the 4090. I think the latest driver also effected the 3080 in my case. I had the same experience, roughly around the time after the driver update. DDU fixed it, but that reset the power management back to normal, like said above.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.