Microsoft finally fixed game controllers not letting a computer turn on it's screen saver or sleep

I’ve had this issue on Win 11 for awhile where having my flight control gear connected, my PC would never turn on it’s screen saver or go to sleep. I resorted to buying a powered USB hub so I could turn my controllers off when I was done flying. So many times, I would go fly in MSFS, finish up and walk away and come back later, to find my PC, still sitting at the desktop…no screen saver kicked in and it wouldn’t sleep…

Anyways, it appears to be fixed now after the latest update released this week.
The last line of updates listed…
" * This update addresses an issue that affects some game controllers. When the game controller is connected to the computer, the computer might not go to Sleep mode."

So, make sure Windows 11 is fully updated…


Amazing! About 3 months ago, my flight sim computer (Windows 11) lost the ability to sleep or automatically blank the screen when using the “balanced” power plan. It seemed to happen about the same time I updated my NVidia video driver, so I thought that might be the reason.

I installed the new Windows update this afternoon, and sleep mode is working again! I do, of course, have several gaming controllers hooked up to my FS computer, so I assume one or more of them was causing the problem.

Thanks for the heads-up.

1 Like

Finally!! This has been an issue since windows 10-1909! Only took MS about 2 years to solve :laughing:


Did this actually solve the problem? I have had the same problem and bought a USB hub to work around it. With the latest Windows update, the display turns off as expected, but the PC never goes to sleep. Even if my joystick is unplugged.

On my PC the update resolved both the display off and sleep issue.

If you PC is not going to sleep, you may like to check what is keeping it awake:

Open command prompt from your start menu as admin and type the following to see what is currently keeping your PC awake:

powercfg -requests

On my system, this command has never showed me anything :). But happy now as my Alienware OLED get some well needed rest in between my flights :slight_smile:


I find the command helpful, but it does not find every cause for sleep issues.

A lot of applications and service can prevent sleep but especially at scale; it is important that Microsoft continues to address sleep issues; to prevent wasting resources.

With multiple monitor setups the amount of energy saved just having the displays turned off after a few minutes of inactivity is more than just a few watts. There is no need to leave it running unused.

1 Like

I know, right?

I actually upgraded to Win 11 because of this.

Works like a charm.

Also makes me a little mad that I spent 2 years trying to figure out why it was happening when it actually had nothing to do with my system… :face_with_raised_eyebrow:

Have been running both win10 and win11 earlier. Kept with win10 due to the startmenu is easier to configure. This fix made me upgrade as well :slight_smile:

1 Like

My CH Products Pro Pedals still keeps my screen saver from coming on. Win 10 - 19045.2546

Try again I guess Asobo?

Asobo has nothing to do with it. It was a Microsoft Windows update that fixed the problem.

If your pedals are generating any noise due to dirty potentiometers (and CH pedals are very prone to this), it will prevent your computer from sleeping. My controllers all use Hall effect sensors which are noise-free. Before the Windows update my computer would never sleep no matter how long I waited. After the update, sleep mode works correctly 100 percent of the time.


True I misspoke, it is a MS issue, not Asobo.

I have 0 data change on my USB bus from the pedals (ya i know how to do that). Just them being plugged in stops screen blanking.

It’s super odd, cause powercfg shows absolutely no wakelocks or anything either.

You mentioned in your earlier post, you were on Windows 10, correct? I’m not sure if the update MS pushed out to fix the controller > no screensaver > no sleep issue, was for Windows 11 only or both…It may be that they haven’t released the same update for Windows 10 yet…

Well day-um.

it seems the new NVIDIA driver broke it again.

No more sleep….

1 Like

In my case, recent windows update fixed it and new Nvidia Driver 528.49 did not break it.
Did you check that “In Game Overlay” is still disabled in Geforce Experience after driver update ?

Yup, it’s disabled.

Rolled it back and now it sleeps again.

go figger

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.