MSFS 2020 not opening

Would anyone be able to help me with a problem I’m having with MSFS 2020. When I try to launch MSFS2020 it doesn’t open and microsoft store opens telling me to install Gaming services when its already installed on my system.

MY PC SPECS
i9 9900k
RTX 2080 Super
16GB RAM 3000MHz
MSI Z390 Gaming Edge Motherboard

Hi @SlimUmbrella65,
There are some topics regarding this. Here is a search of “gaming services” in the #bugs-and-issues subcategories:
Search results for ‘gaming services category:200’ - Microsoft Flight Simulator Forums

These 2 topics have a solution:
https://forums.flightsimulator.com/t/i-cant-start-msfs-gaming-services-keep-opening/385670

MSFS Launches MS Store for Gaming Services - Bugs & Issues / Performance, Graphics & CTDs - Microsoft Flight Simulator Forums

Hope this helps!

Hi, unfortunately for me the only way to fix this was to uninstall and reinstall completely.

Hi @tchitkom,
Thank you for helping this user.

I have a question, before you did the reinstall, did you try repairing the app through Windows 10 apps? I wonder if that would force the gaming services? Another one I’m thinking that may force it is uninstalling the Xbox app and reinstalling? I’m thinking outloud. :wink:

I’ve had to uninstall my game and now I’m trying to reinstall but Microsoft store wont let me install it. I press install, then select the drive I want it installed on but when I press install nothing happens.

I tried absolutely everything possible before deciding to reinstall :slight_smile:

1 Like

I’m wandering if there are FS-simmers using the same AMD Radeon RX580 [ 8GB] who are able to get FS running. Since update UK I cann’t load FS . Before that no problems.

Hello!

My computer has a RX580, Ryzen5 2600 and 16GB ram and I can run MSFS without any problem. Yesterday I made a flight from KDFW to KDEN with the FBW A320 and I had no problems at all. Im running the sim with medium settings, only clouds in ultra.

What kind of processor do you have in your computer?

I’ve created a new thread as I uninstalled the game and it won’t let me install it again

Intel 17-3820 CPU-3.60 GHZ

1 Like

I’ve uninstalled my game and now I’m installing again.

You shouldt have problem to start the sim. Im almost sure that the problem its not the graphic card or the processor, but maybe a conflict with the addons or the instalation.

I tell you what I did.
I bought a new SSD [1TB] and installed a clean Win10 and Installed a new clean MSFS2020 without any extra’s.
I called Microsoft and with Quick Assist walked through the system. A check with DISM and SFC
had also no result.Nothing strange was found.He thought it could be the graphic-card but it worked fine till the update of UK.
In my opinion there should be a log-file in which this error should be mentioned.
So where to look for? I still have P3D v5 and FSX SE on this pc and they work fine. I use LG-Ultrawide and changed the resolution to 1024 x 768 but no result.

Same here regardless of what I try it will not download

In Windows 10, go to Settings > Apps and scroll down until you find Gaming Services. If it’s grayed out, click on it, select Advanced Options and then click on Reset. No guarantees so if it doesn’t work for you you don’t have to mention it. But it’s something that has worked for me and others so it’s worth a try.