MSFS Application Error - memory could not be read

I did wonder whether this CTD might be causing the ntdll.dll file to become corrupt, but i’m sure the devs will get to a fix pretty quickly.

1 Like

Idk know anymore

image

PMDG, on approach to UK, all online systems on.

I had it twice again this evening during flights on VATSIM after a complete preparation and checklists…
I’m really starting to look at Xplane11 and I think I’ll go on it definitely soon, no matter the addons I already paid on MSFS2020. This sim isn’t ready and isn’t really joyful.
Crashes come more from your computer than your planes.
With MSFS2020, you don’t become a virtual pilot, but a computer engineer.

The people who are upset that they can’t fly for 3 days without CTD should put themselves in the position of the users who have had this error for months.
After the release of SU9 I had at the beginning constantly the error that the memory can not be read. Somehow I managed it that the error for some time disappeared, the error is again on Saturday morning with me for 1 time appeared and then I had 3 CTD without error message since Sunday I can fly normally without CTD why and why no idea

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

After weeks of no CTD’s today changed all that, and nothing changed this end at all. Even the past weekend was fine.
First CTD LGRK setting up for flight with the PMDG 737. Second attempt now using the Fenix A320 (Got a bit further this time, managed to reach the italian Alps before, yup you guessed it Picture freezes and boom to desk top.
Third and final attempt EDDM - EGPH, again the Fenix A320, got as far as the NE coast of England… Out of memory crash… Jeeezzz this takes the biscuit!

Provide Screenshot(s)/video(s) of the issue encountered:

No chance, have you tried capturing a CTD?
Detailed steps to reproduce the issue encountered:

Just use the sim in either SU9 guise or Beta 10
PC specs and/or peripheral set up if relevant:

AMD Ryzen 7 5800x3d, 32gb DDR4 ram. Radeon 680015gb GPU, MSI pro570x M/Board 2x Nvme 1 TB drives

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Are you using DX12?

Yes, No issues till today though

Are you using DLSS?

No


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

I’ve just done what should have been a relatively short flight, from KOLM to KHLN, in the Fenix A320. I say “should have been”, because RL called so I had to pause/freeze the sim via the MCDU maintenance menu. I did both, because i didn’t have time to read the manual, to find out what each did, before she who shall be obeyed got a bit crotchety. The aircraft seemed to accept both, so i went with that.

Anyway, before starting the flight, i had turned off weather, live traffic and multiplayer, via the data menu, as I had been suffering from these ■■■■■■ CTD.

As luck, or some other force of nature, would have it, MSFS didn’t crash in the 2 hours or so that I had left the house and i was able to land it without too much fuss. There was a major stutter about 2-3 miles out from the runway, but that recovered after a couple of seconds or so.

I’ve read enough posts on this thread and the ntdll.dll thread to know that this doesn’t mean this is a guaranteed workaround and i’m fairly sure that it isn’t, but disabling at least some of the online services might be worth a try if you’re getting desperate to complete a flight, like i was.

I hope a permanent fix is found soon, to both CTD types.

3 Likes

It definetly worth a try, also i have a copy of weatherforce so i can still fly eith real weather without using the sim one, did you also turn off bing data and photogrammetry?

In reply to the topic of the ctd whithout message i have found this

https://answers.microsoft.com/en-us/windows/forum/all/microsoft-flight-simulator-2020-ntdlldll-crash/c5845dd8-2f06-43f9-90a6-9b35eee10f66

Maybe it is related also tu us, i want to try to create exceptions for msfs and gaming services in win defender

I left the scenery on, which i found interesting, as others had turned off the scenery services and left multiplayer, live traffic and live weather on, so maybe it’s the total amount of interaction with the server(s) that “breaks the camel’s back” as it were??

Hey there fellow MSFS community,
I’m fairly new to this gathering so please be understanding if I missed out on any information.
I’ve been getting the random (but still at every flight) “memory could not be read” error as well. Apparently setting up the manual page file settings has proven to be working for some of you; did not work for me unfortunately. I run the Sim on DX12 and every setting maxed out with Vsync limiting the FPS to 30 and the Data cache size set to 32 Gb.
As most of you, I don’t want to wait either until Asobo comes up with a solution (no offence), so again the question if anyone has had other working ideas to at least temporarily fix this issue.
I love flying for my virtual airline and really do not enjoy these frequent CTDs…the Sim has become unflyable for me. Also for the ACARS system I need to use in order to track my flights, I’m using FSUIPC, so maybe that could also cause these issues?
Anyhow, I’m most grateful for your feedback!

PC Specs:
Windows 11 Home 64-Bit
Intel Core I9-11900K
32 Gb Ram at 3000 MHz
MSI RTX 3080 Ventus 3x OC
ASUS TUF Gaming Board Z590
SSD 2.0 with 1 Tb hard space

Although it’s not a guaranteed workaround, disabling live weather, live traffic and multiplayer, in the Data menu of the general options at least allowed me to complete a flight.

I’d do that via the options menu on the main page by the way and not after starting a flight

1 Like

Thanks for the help! Will try it out right away!

Received the memory error yesterday evening also on SU10 beta, everything set to live re wx and live traffic and all players, but 0 mods installed, just the world updates from marketplace, I also did a clean install of windows 11 on Sunday.

image

Good morning, next CTD. I flew with the Reno Default Mustang from LFLB (FranceVFR via orbx) via Grenoble to Marseille, than eastward to Nice, up to Genoa and than northward over the Mountains and after that straight to LIMZ (SaviArt via orbx). I did see huge Terrain-Spikes in Torino and after Approach and Landing in LIMZ with Fuelstop and Start in LIMZ heading north to Torino i get a Memory read Error at Location Carmagnola. Flighttime 2 hrs.

Settings
Location South Bavaria, Server Western Europe
all Online-Services ON
Graphics Ultra Terrain 300
no Rolling Cache
Pagefile custom Startsize 5000 MB max 50000 MB
All Software up to date
sfc /scannow no Problems
AMD 5900X, AMD 6900XT, 32 GB RAM
no Freeware
no GSX
only Airports from MP, Aerosoft and orbx

Event Log no Entry

I don’t have this error, but it’s infuriating to read how many people do have it, and it has been persisting for a long time. Has there been any official communication about it, or are they staying mute as per usual?

The forum staff are active, but it would be better if there would be a sticky note on the forum front page.

3 Likes

The forum staff are fantastic. It’s people at Asobo that concern me. They don’t seem to be able to see the woods for the trees sometimes. They focus on the wrong things, frequently.

I get 3 erros yesterday evening at departure from LFPG. First I thought it was due to the Fenix A320 on which I flight the most and regarding the fact it is a bit more laggy than other aircraft. I tried with the FBWA320 which is lighter but I get the same issue.Then, I decided to change my area and start a flight from Japan to Korea with the B747. I didn’t have any troubles the whole flight.

So my question is : Do you think the memory problem is linked with the location we flight over ?

Indeed, I flight mostly over Europe but Ihave the feeling that this problem always occured when I am flying over France. Because I don’t really think this memory problem is really linked with a memory management. I have a good set up, (RTX 3080 10 GB, i5 12600k, 32 GB RAM, no xmp activated, no memetest86 errors, no sfc scan errors etc.)

I’ve been having CTD’s since Sunday morning - Prior to that no issues at all with MSFS.

This morning I tried a 737-700 flight out of Chicago Midway (KMDW) and shortly after reaching FL240, received the memory error. First time I’ve seen it.

Welcome in the club, here’s your member card.