MSFS Application Error - memory could not be read

Glad to hear, keep us updated!
I’m currently back on the official release (no SU10 beta, every WU installed) and underclocking the video memory still seems to do the trick. I had one crash after 5 minutes in the menu and went “Oh no” only to realise that the underclock wasn’t active. Reactivated, no crash.
I did some short tests yesterday and just finished a flight from OMDB to VIDP (FBW A32NX experimental), again without issues.
I do get like one hiccup every hour where it drops some frames, but I’d rather have that than cardiac arrest :saluting_face:

1 Like

Hey if it works the first time you came to Italy you have got a lunch paid :smile: :smile:

1 Like

Just had the error again on the exact touchdown instant

For those experiencing this issue on PC, are you able to see a Fault Bucket ID? The devs are working on this issue and it would be very valuable:

Thanks!

6 Likes

My issue is That with this Memory cant be found error it doesn’t leave any error or info in the viewer.

1 Like

Something for you guys to try as a workaround provided by Microsoft themself :wink:

It could be that you run into the page file issue described above in which files are requested by a program (MSFS) which are not yet available as the dynamic page file size was not yet properly reserved by the OS (aka Windows) so this/these files cannot be read (as they are not there).

The solution is to manually set the page files size according to the article linked:

Workaround

To work around this issue, manually configure the size of the page file. To do this, follow these steps:

  1. Press the Windows logo key + the Pause/Break key to open System Properties.
  2. Select Advanced system settings and then select Settings in the Performance section on the Advanced tab.
  3. Select the Advanced tab, and then select Change in the Virtual memory section.
  4. Clear the Automatically manage paging file size for all drives check box.
  5. Select Custom size, and then set the “Initial size” and “Maximum size” values for the paging file. We recommend that you set the initial size to 1.5 times the amount of RAM in the system.
  6. Select OK to apply the settings, and then restart the system. If you continue to receive “out-of-memory” error messages, increase the “initial size” of the page file.

This will basically reserve a portion of your (fastest!) drive to act like RAM (nuff said) of a fixed size - the OS does not have to predict the size needed so files can just move in and stay there, ready to be collected by your CPU/GPU :slight_smile:

PS: set both (initial and maximum size) to the same value! If you got 8GB of RAM set both to 12288 MB, if you got 16GB of RAM try 24576 MB and so on (GB of RAM x 1024 x 1.5) :wink:

1 Like

Understood, thank you for trying though!

This article refers to an “out of memory” error.

FS2020 has been having memory “read” errors.

1 Like

If you’d read the article you’d know it’s not just about that:

Cause

Memory allocation failures can occur due to latencies that are associated with growing the size of a page file to support additional memory requirements in the system. A potential cause of these failures is when the page file size is configured as “automatic.” Automatic page-file size starts with a small page file and grows automatically as needed.

The IO system consists of many components, including file system filters, file systems, volume filters, storage filters, and so on. The specific components on a given system can cause variability in page file growth.

Again, the error is “the memory could not be read”, so the (physical) address associated to a pointer does not contain the information MSFS is looking for. It basically finds nothing (likely not even a sector for the task asked for).

The quote above can lead to this issue:

MSFS asks for a file → file cannot be loaded to RAM → Windows steps in and starts to allocate a small bit of disk/SSD space → valid address is submitted to MSFS → file gets transferred there → file is processed (best case)

After some time the already allocated space isn’t enough anymore:

MSFS asks for a file → file still cannot be loaded to RAM → Windows allocates more space, but everything has to stay consistent so it allocates another section with double the size and starts moving the content still needed of the first run into this new place → MSFS is in hurry and somehow takes an old address or NULL (like in some screenshots above [Address 0x00000000] → Invalid entry or something different → memory could not be read exception.

At least that’s my guess and there is nothing wrong at all to test it with a fixed page file size as a temporary solution.

1 Like

I’ve just completed a flight from KSAF to KDEN, as part of a tour of the mainland state capitals, having had a fair few CTD on some of the earlier flights in the tour.

I had tried your fix before this latest leg and I am hopeful, although not certain, that i will continue to avoid further CTD.

Time will tell i guess. :slight_smile:

Thanks for sharing the potential fix, either way.

1 Like

So this Page File Size will fix the problem.
Good to know.

No guarantees but that’s what MS suggests :wink:

1 Like

You’d think that rather than just allowing the OS memory calls to fail disastrously, they’d have been better sticking a longish timeout or a few repeated tries on it.

Surely a bit of a wait would be better than a CTD?

Basically longer waiting times are accepted in such situations (at least that’s better than letting the system crash because of a pointer exception :wink: ) - loading from page in general is slower than from RAM :slight_smile:

With plenty of RAM (like 64GB) this shall not happen anyway as usually unused RAM is freed by the program consuming (“garbage collecting”) but something seems to be wrong over here regarding this somehow.

Yup. Virtually debugging code on a forum is way easier than doing it for real. :stuck_out_tongue:

Never as effective though. :slight_smile:

2 Likes

Hey, here is a screenshot of my most recent crash.

1 Like

Just gonna add that the page file workaround did nothing for me, did try that before. Also 16Gb RAM seems to be fine if you’re not running hundreds of mods, never came close to maxing out. Needing 64Gb memory because of a programming error is not a solution

1 Like

:laughing:

I agree, except this is PC gaming, where hardware is almost never used to its full potential. That’s why our CPUs sit mostly idle.

1 Like

Something I have been doing on Flight Sim PC for literally DECADES !!
Good Advice
Also, “does not hurt” to set the relevant Registry values, to CLEAR the Page file on shutdown.
Then next time you start the PC, its clear and not full of old, irrelevant data.

1 Like

Again, overwriting the page file upon every shutdown hurts your SSD with unnecessary write degradation. It doesn’t help anything.

Windows does not reuse old contents of a page file, nor should any page table entries point to erroneous data unless your hardware or software is unstable (which is not the fault of the memory manager nor the paging file).

4 Likes