MSFS barely any GPU usage/ extreme stuttering

Info: PC, Steam version

Dev mode or not doesn’t change the issue.

Basically since a year now (with the MSFS updates between a year and now too) I’ve had unplayable FPS with barely any GPU usage (GPU-Z confirms). Updating drivers, reinstalling MSFS, etc. all doesn’t work. I’ve done a completely fresh re-install of drivers using DDU too. The stuttering in the video also occurs in any of the MSFS menus. Sorry for the awful video quality, the lag on-screen is so extreme I had to record it with my phone.

Specs are i7 10700KF, RTX 3080, 32GB RAM and sim installed on an SSD (not a faulty SSD either, I have reinstalled on separate disks). Also I have no integrated graphics so the sim is using the RTX 3080.

Any ideas on how to fix it?

Best wishes,

You may want to check out this informative post that has benefited many.

What does Windows Task manager show is happening? Are there any CPU processes stealing all the resources? Also, try unplugging any USB devices to see if one of them is taking down your system.

All of this looks good, i.e. no resources stealing any CPU usage (only the small things like spotify and browser). As for unplugging USB devices I definitely will try once I come back from holiday, and I always have traffic off iirc (I’ll also check once I get back) :wink: Thanks for the help already AthenaGrey1 and ResetXPDR!


This is the nature of MSFS which still doesn’t distribute the process load properly to all CPU cores.

The only ways for me to reduce stutters are:

  • Set terrain and object LOD to 100 (default) or lower
  • Lock your FPS at max 30FPS
  • Disable Photogrametery

That’s true

You should be getting a much better experience with the hardware you have. Have you ran hwinfo in the background to show any throttling that maybe going on ?
This is my layout which helps me a lot for diagnosing stuff.

1 Like

What are yur specs?

Hi. I have i7 9700k, 32GB 3600Hz RAM, RTX 3070

MSFS mostly uses the last core on my CPU, leaving the other 7 cores with only 20% to 30% usage. I suppose it’s where the MSFS mainthread assigned.

1 Like

YEESS exactly I have I7-9700 rtx 3070 same useage as use that cause stutters

You probably just have to put more load on that GPU; so much that it becomes the FPS-limiting factor. This will give your CPU time to do other stuff between each frame, which reduces or eliminates stuttering.

You don’t mention your screen resolution, but an easy way to exercise you GPU is to increase render scaling. As a bonus this is likely to improve image quality. You can also choose to simply limit the FPS from within the nVidia Control Panel.

If you need to reduce your CPU-load, the LOD sliders are the primary ones to go to, but things like traffic density may also be worth trying.

But it’s important that you not aim for too high an FPS! With you rig, I’d say around 40 would be a good place to start. And use the developer mode FPS-counter to check that you stay GPU-limited under all circumstances.


Check if your SIM is using RTX 3080 correctly.
How to Customize Graphics Performance Preference on Windows 10

1 Like

tools like shadowplay use normaly hardware-recording and this mean different/concrete chips on your gpu, so you can exactly record what happens. In case your system is not able to record in parallel with shadowplay, there is definitivly a system issue.

Stutters can have so many reasons… worst internet connection , wrong settings ( system and in-game ), system issue, monitor sync, usb devices, some kind of “mods” / “ext. applicaitons” , whats ever… you just must give more infos. Related to MSFS you can simple start with LOW pre-profiles and check what happens. Related to your system you can let run some performance-measeurement tools. In case you done some systems settings manually, like some users disabled windows virtual memory, you may revert that… etc.

Hi there,
The issue is still there with any settings (even with low settings). I think it’s important to note that I was able to run MSFS on these exact specs with the exact same machine at a consistent 60FPS a year ago. Also I checked the hardware using a benchmark and everything is performing even better than it should (above the mean score achieved with other the same hardware on other machines).

this is not so relevant, because there are a lot of updates in meanwhile… Related to In-Game/Flight-FPS I would recommend to try to set the LOD to 100 or 200 and try again, the most users have all settings at Ultra and we have topics where the LOD setting have a high impact. This will of course not explain issues in menu, so may be there is another kind of issue… but we need more informations to can tell something ( e.g. have you Geforce Exp. Auto-Optimze running, etc… )


Hi! I have no auto-optimize running. The only setting I do is “prefer maximum performance” in the Nvidia panel.

1 Like

Hi did you found any solution?
I’ve the same probem here since WU8…
5800X, 3090FE and 32GB Ram @3600
Nearly independet of my settings

Well not a solution, just a clean windows 11 reinstall is what fixed it for me. Not even “repairing” windows worked, it had to be a clean reinstall for me.
Good luck!

1 Like

Haha, that’s funny, I looked at that post after I did a complete newinstall (even format my SSD)…
What I found out today:
Stuttering occurs, when the Sim uses more than 10GB of RAM (and about 14/15 GB the complete System) and it gets massive, when the Sim uses 15 GB of RAM (and about 20 to 25 the complete System).

It’s so strange, I can fly with nearly smooth 60 FPS above NYC, if the Sim uses less than 10GB of RAM, but I get massive stuttering, if the Sim needs more, even if I fly in complete remote areas above the alps…

somewhat with the pagefile ? how is you setting related to windows virtual memory ?