Msfs update avionics not working?

Hey Monkeynuts, thanks for the welcome. :slight_smile:
I have now resolved the issue thanks to user SamuraiSax

Bug Reports / Aircraft & Systems / PC / Aircraft / MS-Store / Avionics not working

Not sure if it applies to you but it was suggested that an add-on PMS50 GTN750 was conflicting with my avionics. So I deleted it from the community folder -

Filename - pms50-instrument-gtn750

Directory - C:\Users\YourName\AppData\Roaming\Microsoft Flight Simulator\Packages\Community

If you can’t find it there, then you might also try -

C:\Users\YourName\AppData\Local\Packages\Microsoft.FlightDashboard_8wekyb3d8bbwe\LocalCache\Packages\

Otherwise it might be worth running the sim in safe mode to see if any add-ons are conflicting.

Hope this helps. I’ll check back to see.

Sorry, I should have mentioned that I am on Xbox and not pc. I am working on uninstalling all add ons and re installing one at a time to isolate the cause. Happy that you found a solution.

1 Like

My fault for assuming you were on PC. Best of luck. o7

Hello @Sniperpig5 ,

I am on PC and This solution has worked 100% for me. For me, I deleted pms50-gtn750 from community folder, downloaded new version, and placed it back, and now it appears to have fixed it for me.
Just done night fly and all seems ok sop far.

cheers

It was panic stations there for a while. :rofl:
Glad you got it sorted.

I have the problem on PC. Everything worked before Update 9.
But a sulution is not in sight. I have to deinstall MSFS and install new.

For me the problem affects some MFDs on some aircraft. I have the sim on windows 10 with the X-Box app.
Not tried all aircraft but cubs & things with old clock style instruments - OK, Cessna 208 caravan - all MFds OK, A320 - all inop (XXXX or blank.) Same with TBM and Extra 330 now has 2 MFDs - both with flight instruments where one is XXXX and the same one beside it works???
Nothing in Community folder to clash (but tried with/without), small G1000 update applied - not helped. Used Content Manager to uninstall then reinstall affected aircraft - not helped. I guess it needs a patch.
(Weirdly though when in my Content Manager I saw a microlight that I haven’t bought - but one paint job for it only, plus a T6 Texan - also not ordered/paid for but incomplete. Deleting these ‘stubs’ results in the sim reinstalling them next startup!!!
I also had sim startup probs at first last week - the usual X-box app comms failure. (Cured as usual by uninstall app, shut down, reinstall (quicker than finding the duff component).
really really weird all of thsi.

I wouldn’t. There will have to be a fix. And 99 percent other sim problems are outside the sim (PC X-box app fails etc).

same here c172 stock all instruments went dark after standing 3 minutes on the airfield with engines on

Same here. The first time I opened the 747, all displays were blank and the center ones in the 787 were blank. Now the 787 displays are blank. This is on a PC.

The most recent of this topic is from Feb, 2022.

After I updated with AAU2, I have several aero planes with blank avionic screens. The 787, the airbus’s, the little jets and some of the props.

I have removed the community folder, checked panel brightness controls, tried popping them out and a bunch of other stuff, then just removed and reinstalled FS, which took nearly all day. After the fresh install and no add ons loaded, same thing, although some panels of some aero planes came back others went away.

I don’t get it. A clean sheet, base install and I have issues.

May rig is a i9 12900, RTX3090ti, 64GB ram and a lighting fast m.2 running Win11. I run the TSH peddles, the TCA yoke and the Beta quad. I am about ready to wipe the machine and try again, but somehow I am not sure that will even work.

Anyone?

1 Like

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

2 tags are required: One for platform, and one for aircraft.

Are you using Developer Mode or made changes in it?

No
Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

Yes
Which aircraft are you reporting an issue about? (Please also add the proper tag for it)

787

Brief description of the issue:

Lank screens an no avionics when on ground or airborne
Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Just load the asobo 787
PC specs and/or peripheral set up if relevant:

NA
Build Version # when you first started experiencing this issue:

AAU2

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Sorry for the delay, I’ve been on a work trip when I should be retired. In any case, I fired up my sim where I was presented with two updates. I forgot but can look later this evening. When I got into the -10, I now have full instrumentation, however I do not with the Longitude. I’ve not had time to run through all, but I will later this evening. I will also figure out which update was available and report back.

1 Like

After a day of running through all the default aircraft, the only issue I have is with the MD-11, which won’t load because the “fly!” button is not enabled when this aircraft is selected. Anyway, all other planes work just fine. I don’t recall what the update was, but it fixed my issues. Now on to the 3rd party a/c. Thanks for the update!

1 Like

After the recent update every airplane that uses avionic screens will black out at some point, every single time. I’ve tried all the fixes mentioned in the forum and they still black out. This happens with the downloaded MSFS and the cloud version from the Xbox game pass. I’m using an Xbox Series S. Before this last update I never had one issue.

2 Likes

I’m Having the exact same issue. My avionics are out on my 787-9 and 10 Airbus 310,318 and 320neo and when I load the the flight plan and press ready to fly the entire game crashes and goes back to Xbox Home Screen.

So I’ve noticed if I delete all third-party mods and liveries and use the previous AIRAC the screens will generally stay on the whole flight. That works for me, I don’t know if it would work for everyone, I’m playing on a Xbox series S.

Thanks I’ll try if this problem continues.

I’ve went through every thread i can find regarding Avionics that had suddenly decided not to show on every single plane. What have i done wrong here? It was working yesterday.

I have updated my graphic card + windows.
I have installed the free Garmin from marketplace, it worked for a week. Decided to remove this and try, still black screen avionics.
It shows NOT INSTALLED but says I still OWNED it. I have remove any remaining folders from that download.
I’ve not put anything in the Community Folder.
I’ve also un-installed and reinstalled the game from Steam. Still nothing.

What else could this be? I’m desperate AF and its frustrating wanting to play the ■■■■ game but I cant find a proper fix for this. Who can help me? Pleaseeee…on top of all this. Waiting for a reply here.

You mean the displays going black after a specially time? When yes i habe the same problem.