NTDLL.DLL CTD x2

I’ve just tried the same flight twice, orbx’s EPKK to FT EKCH in the FBW A32NX. and had 2 CTDs in the exact same location, the event log is as follows

Faulting application name: FlightSimulator.exe, version: 1.17.3.0, time stamp: 0x00000000
Faulting module name: ntdll.dll, version: 10.0.19041.1023, time stamp: 0x7977b9de
Exception code: 0xc0000005
Fault offset: 0x0000000000063416
Faulting process ID: 0x378
Faulting application start time: 0x01d76f24e6974ac6
Faulting application path: D:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report ID: 24110ea1-7677-4c78-a038-8d07ccb8a5ce
Faulting package full name:
Faulting package-relative application ID:

It seems to be the ntdll.dll? If so what causes this/how can I fix it?

Thanks

I had exactly the same type of crash shortly after take-off on Monday evening, from a location in Japan.

I logged a ticket with Zendesk, and they came back with a few things that didn’t apply to me, like running at least Windows 10 2004, and I’m on 21H1.

Regarding the DLL, the last thing they suggest was to go into safe mode, unregister the ntdll.dll, then re-register it, then boot normally.

I had already relaunched the flight afterwards, exactly the same route, and was able to fly for 2 hours with no crash.

They never explained how re-registering that DLL was supposed to help, only that I should do it, but since the relaunch I was able to finish the flight, and the CTD was not repeatable, I have not done that yet.

Ok thanks, I am going to try a different flight and see if that works, but if not I’ll try the safe mode thing but I’ll have to find some info on how to do that

This was their exact wording, but do this at your own risk:

If the issue persists, reinstall the DLL

  1. Type cmd in the search box, and then right click Command prompt select Run as Administrator.
  2. Type this in command prompt:
  • regsvr32.exe /u ntdll.dll and press Enter key (this will uninstall the file)
  • regsvr32.exe ntdll.dll and press Enter key (this will reinstall the file).

Launch Microsoft Flight Simulator again.

Now that I read it again, it makes no mention of Safe Mode at all, so I think I made that up in my head.

This is the message I get when I try to unregister that DLL on one of my work machines:

image

I will report this back to the help desk ticket also.

1 Like

Thank you, I shall see how it goes

I think they have rather simplistically looked at the DLL, and suggested a de/re-register the DLL was teh way to go, without actually trying this themselves.

Some of the other suggestions were sensible, like re-trying without mods, to the somewhat clutching at straws use of SFC to scan for file system errors, and a link to an article on how to perform a “Clean Boot” in Spanish! :slight_smile:

Yeah I was going to try without mods next but it’s kinda hard when you have spend so much on stuff not to use them

1 Like

Update - just done 2 flights (away from EKCH), full withs mods/scenery etc, 0 issues, tried loading in at EKCH, ctd on loading screen, must be an FT EKCH issue, thinking about it i’ve not flown into ekch since wu5, so might be a compatibility issue

Edit : Low and behold it’s a known issue and I missed the update to fix it…I beg FT brought out a manager like orbx or contrail…or sell all their scenery through orbx and not just sydney

1 Like

Having similar issues when loading flight from EFHK or any neighbourhood, i have tried to load the sim without Finnish addons in the community-folder, sim just ctd’s to a desktop
Error log shows like this:

Viallisen sovelluksen nimi: FlightSimulator.exe, versio: 0.0.0.0, aikaleima: 0x60c0b1e3
Viallisen moduulin nimi: ntdll.dll, versio: 10.0.19041.1110, aikaleima: 0xe7a22463
Poikkeuskoodi: 0xc0000005
Virhepoikkeama: 0x0000000000063416
Viallisen prosessin tunnus: 0x39c8
Viallisen sovelluksen käynnistysaika: 0x01d77f0431edb5b6
Viallisen sovelluksen polku: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.17.3.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Viallisen moduulin polku: C:\Windows\SYSTEM32\ntdll.dll
Raportin tunnus: 7acbd0fd-0cd6-46ee-9e56-0f17c8c4e10b
Viallisen paketin koko nimi: Microsoft.FlightSimulator_1.17.3.0_x64__8wekyb3d8bbwe
Viallisen paketin suhteellinen sovellustunnus: App

I’ve seen this rarely reported, and I think I have had it once only myself. No idea what triggered it, but it was not repeatable, sadly. Or perhaps fortunately, depending on your outlook on life.

1 Like

maybe just something as simple as it took the server too long to get connected…

1 Like

I managed to get rid of ctd’s :smiley: Simply removed everything from community-folder, started sim up, everything works fine and started adding addons again, testing that sim works after adding few addons. So far no problems. Maybe some addon was causing it, haven’t yet find out which one :rofl:

1 Like

I would imagine the vast majority of CTD causes are conflicts with addons. Others I’ve seen are issues with terrain, and a particular location but they are quite rare.

1 Like

I my case CTD started out of the blue after the last Win10 update. Empying the community folder did not help.

What helped was to throw out all kinds of audio apps that apparently installed themselves during the Win10 update. In particular 2 Asus apps: Sonic Radar and Sonic something. I deleted them from my system. On top, I had to disable them in sound settings, where the loudspeakers and headphone still had an entry with “Sonic”. Since then, my system runs flawlessly again.
(Fingers x-ed)

and may be open the windows “services” page and disable “nahimic”.
( start type “disabled” )

Thanks, I will definitely try that!
How do I get to the Win Services?

you can click on windows “icon” , then type “services” ( I assume it works well in all languages, at least for german windows “services” and “Dienste” works ).

But you can find it within the windows menu too:

Found it!
I stopped the service and set start to „manual“.

Thanks a lot for the hint. Will report on outcome…

Run a shell admin command prompt (sfc /scannow) and let Windows fix any corruption it finds. Then restart PC.