Oculus Quest 2 - Flickering black rectangle and jumpiness

How do you link it in Oculus if one launched the game through the Xbox App ?

having a similar issue with the rift… cant get past the press spacebar to center screen

It will say, can’t find headset

You have to bind a key to the camera reset before entering VR. As for the black box, I’ve got it too on the rift s.

1 Like

Same here with rectangles on Rift. If you are getting the Can’t find headset message, read the Known Issues post for Oculus instructions.

FIXED IT WITH THIS :slight_smile:

2 Likes

Just added this to the Known Issues:

When seeing black stencils in your Oculus view:

Update to the latest version of the Oculus software. It will be the Beta Version. If that doesn’t work:

  1. Go to the Oculus Debug tool (Default folder should be C:\Program Files\Oculus\Support\oculus-diagnostics)
  2. Open the Oculus Debug Tool
  3. Turn the option “Use FOV Stencil” to Off
  4. Disable/enable VR in MSFS

If you see yellow, try to recenter the view.

7 Likes

Turning FOV Stencil OFF and restarting the service (and oculus app and fs2020) did not solve the black rectangle for me :frowning:

Any other ideas ?

It looks amazing otherwise, I’m quite astonished how well it runs on my 2070 :slight_smile:

Have you updated to the latest version of Oculus Software, their Beta version? After that, Enable “Public Test Channel” in Settings>Beta>Public Test Channel

1 Like

Thank you for the fast replys! It now work like a charm with my 2080s

1 Like

I too have the floating black picture frame On Quest 2 so am trying the Oculus test channel fix.

I’m running medium settings on I7-7700 GTX1080 with 32GB Ram and getting 28-30fps and some stutters - need that 3080 badly!

Also my main monitor is showing double views side by side which no other game does in vr - anybody else getting this?

Birdseed007

Right! Updating the windows oculus app to the public test beta solves the issue with the black square. Should be added in the FAQ.

Thank you! :slight_smile:

It certainly fixed it for me thankfully!

Running around 38fps now with medium settings on i7-7700 and GTX1080 Using Quest 2. It’s a truly fantastic experience to fly the sim in VR, even if I want to turn things up a bit more to gain more clarity. I’m having to only render at 70% in VR, pushing that to 100% gets me down in the low 20’s fps with some micro stutters. Now if I could only get my hands on an RTX3080 (approaching double the frame rates of my GTX1080 then I would really be in business!

Birdseed008

Thank you very much ! I had this problem. Now fixed with your solution.

What about jumpiness? I’ve already been at Beta channel so stensil is not a problem, but picture still has “jumpiness”, micro-stutters and “Hot air” effects like picture is going through hot air. Tried different settings - no matter what jumpiness persist. And yes, I have 3080 with Quest 2.

And let me answer that, as I found the reason for this “Jumpiness” - just disable ASW and everything will be fine! yay!

This will fix the persistent stutter in Quest 2. Make sure to restart the app after you change the setting. Also it won’t fix graphics settings that are too demanding – it just fixes the frame sync bug that is affecting Oculus Link/Quest. PSA: Fix Found for Oculus Link/Quest Frame Sync Stutters and ASW Issues

1 Like

PSA: Fix Found for Oculus Link/Quest Frame Sync Stutters and ASW Issues You don’t need to disable ASW if you do this.

1 Like

No, that didn’t work for me (and yes, I clicked Apply too :). So I’ll keep setting ASW disabled till some working solution found. Guess it works for some configurations, but not with my (RTX 3080, Quest 2).

Odd. It’s worked on every system I’ve tested so far. Did you restart the sim after the change? And you’re using the Oculus openXR runtime, not the steamVR one?