Ok, Thrustmaster Hotas One.......What Am I doing Wrong? (XB1X)

I’ve spent several evenings in MSFS, trying to program my TM Hotas One, to work with my XB1X, and it is just not happening. A simple flight involves my Hotas One stick, my XB1X controller and a USB mouse. There has to be a better way than this. As a side note, I’ve got countless hours with the stick in Elite Dangerous, and I’ve managed to program many more required controls to the stick, that are needed in that sim. A flight to the center of the galaxy can be done with the one stick and throttle. MSFS on the other hand, I need 3 different controllers just to get off the ground.

In MSFS, I started with the trim, which by default was programmed to the paddle control on the throttle, and on every flight attempt, the trim randomly jumps to either +100 or -100. (autotrim is disabled,btw) during the flight.

Also, when I attempt to program any of the buttons on the stick in MSFS, “F2” immediately overrides whatever key combination I want to assign.

If there is a trick to setting up the Hotas One to work with MSFS, please send me the link or instructions. I have scoured the web and You Tube, and nothing so far has hepled.

1 Like

Hi there,
I moved your post to the Peripherals section. This is where discussion on HOTAS, yokes, rudder pedals, etc. goes.

Also try this thread…
Xbox Series X- HOTAS One Issues - Self-Service / Peripherals - Microsoft Flight Simulator Forums

Please vote for hotas mapping issue here:

If you’re brand new, you earn votes by reading posts while logged in. Specifically, you need to:

  • Enter 5 topics
  • Read 5 posts
  • Spend at least 15 minutes reading posts

I was able to map the buttons fine on my Hotas one. This video shows you quite clearly how to do that and how to fix the sensativity on that trim paddle, too. You’ll have to adjust the sensativity Everytime you fire up the game… But it literally took me 45 seconds to do it. Lol. The buttons I mapped and the free look on the hat button on the joystick stay there. Just watch this… https://youtu.be/Lf4y_Ke_iKo

The problem appears to be something else, at least for me. I’ve watched that video, and it makes perfect sense. Fwiw, I have years of experience with flightsims, on nearly every platform. As mentioned, I’ve spent the last few years playing Elite Dangerous on Xbox, which has far more detailed mappings on the Hotas One, than MSFS, including multi button bindings. It works flawlessly.

No worries, I’m sure they’ll get it resolved eventually. Waited this long, I can wait a little longer.

Ugh. I didn’t see that you already tried the video… It worked for me… What’s your exact issues?