PART 1 - Huge OpenXR Update! Way better performance and a very smooth experience

BIG NEWS!! The OPENXR Developer Tool has just been updated and now allows for much better motion projection. You will experience much smoother flying with this latest update, even at lower framerates using the developer tool.

This video is a step by step tutorial of how to set up the latest OPENXR Developer Tool for Microsoft Flight Simulator 2020. I hope it helps you improve your system’s VR performance using the HP Reverb G2. Could be a gamechanger for VR!


Is the new version (from About on the Settings Tab ) = 106.2104.15001.0

Was the Windows Media Portal updated as well ? I wonder if it really does the Motion Smoothing??
Where is the OpenXR dll kept?

Also, what Nvidia driver do you use?


Yea that is the new version. Yes, the portal was also updated but this does not relate to the sim/vr performance. I don’t know where the dll is kept. It definitely is smoother now for me!

I use NVIDIA 466.11.


This affect rift s?

1 Like

If I may ask a noob question: I notice many Reverb G2 users are also using the OXR developers tool, even though the G2 setup (which I’ve just gone through for the first time) doesn’t prescribe it. Why install it? Does it actually provide access to parameters that WMR, the NVidia driver, and the sim itself don’t provide?

Thanks, Ron

That’s exactly what it does :slight_smile:
It lets you select a fixed render scale (rather than auto) and whether you want motion reprojection always on/auto/off.
Most people look to find a balance between the ‘Customised render scale’ in the tool with the render scale in the game itself.
Also gives you the ability to establish and act on how you feel about motion reprojection - do you need the simulated 90fps or are you comfortable with say 30? Reprojection comes at a fairly hefty cost so if you’re lucky you don’t ‘need’ it.

Lots more info here:

1 Like

This update makes a huge difference for me. Motion Projection down to 22.5 FPS. VR is MUCH better as I can run higher settings now as I don’t have to maintain 30fps in Motion projection. Nice work MS.

1 Like

Its because the flight sim uses OpenXR as its VR API

How do you set the fps to 22.5, or does that happen automatically with the updated OpenXR?

It happens automatically if you set it to automatic.

It’s funny to me because to me using motion reprojection makes my entire picture jittery. Everything wiggles. The same doesn’t happen when I use motion reprojection with steamvr’s openxr runtime. The problem with steam’s version is it doesn’t perform very well. But I don’t know how anybody can stand WMR’s motion reprojection. It baffles me.


You must be right but I had a 2070 super card and now a 6900 xt and have always had a jittery picture. So 2 vastly different cards but same result. Maybe it’s not the graphics card?

I am not sure what it is to be honest!

PonicFarmer, can you please look in the “System Status” tab on the OpenXR dev tools and tell me what “Runtime Version” shows there? Trying to troubleshoot why my system isn’t doing Motion Projection at 22.5fps even though I show the new version in “About”. Thanks!

… makes it worse. Stuttering and all it like watercolours if you move.

Although the flying is somewhat smooth for me the wobble I see through the propeller ruins the immersion so it’s not worth it. I’m having a really great smooth experience with motion projection disabled. Currently running on 466.11 with the only changes to the default cpl settings being the pre rendered frames is set to 2 (not 4 as others have used). HAGS enabled, game mode disabled.
System specs: 5800X, X570, 32GB 3200, RTX 3070

1 Like

Consider to reduce propeller artifacts:


Thanks for the links. I’ll check them out.

heres mine

I’m having this problem as well… under “About” I see, but under System Status / Runtime Version I have 105.2102.11004. Motion reprojection works at 30fps for me but not under that.

I had windows updates that were stuck, and required me to uninstall WMR Portal and OpenXR to get them to install. I was sure that was going to be the problem, but it’s the same after reinstalling. Starting to wonder if its a hardware support problem maybe? I have a 2070S…