Please solve the problem of low GPU occupancy

In addition, I want to know which non English operating system players have encountered the same problem

I’am on german and I can not reproduce a relation “system language” <-> “gpu load”.

Would be good if you share more informations like screenshots of taskmanager before/after ( e.g. CPU core diagramm, gpu load ). I big guess may be that somewhat cause a high single-core load in your case, and so you are cpu limited… how ever this can depend on language setting.




It is obvious from the picture that when I am on the home page, the GPU works normally, and when I start flying, the utilization rate of GPU is very low.

When I set the flight plan on earth, the displayed route is normal. When I start flying, open the VFR map and you can see that the route points to the unknown direction.

The culprit of all this is the system language. Although it sounds inexplicable, it is true.

I didn’t try to modify the voice to solve this problem, because every time I modify the language, I will restart the computer. When I am in the English system, I can’t use my other applications, such as the League of heroes, and sometimes my system text will be garbled. I have reinstalled the operating system for this. So now, I choose to endure.

Every time I wait for the update of the game with great expectation, and I look forward to whether this problem can be solved, because the game experience of about 10 frames is really difficult for me to persist in the game for more than 1 hour. So I can only wait for the next update every time, again, again

When I don’t execute any flight plan, fly low in Manhattan and have no destination, the GPU works normally, and the frame number is stable at about 30. If I fly higher and leave Manhattan for 10 nautical miles, I have 40 frames, because I turn on vertical synchronization and set 30 frames.

It can be seen that the problem of GPU utilization is caused by the flight plan, and the problem of flight plan is caused by the system language.

I don’t want to solve this problem by modifying the language in an abnormal way, because weighing the pros and cons, it will cause a lot of trouble for me to use the computer. I urge developers to pay attention to this problem and hope to solve these problems caused by voice before the Chinese version of IX is launched.

Users in non English regions are also welcome to vote for those who encounter the same problems, which has attracted the attention of developers.

https://flightsimulator.zendesk.com/hc/en-us/requests/new

You are limited by the main CPU thread.
Your GPU is waiting for the CPU toi finish the frame.
This is a known issue, MSFS is very heavy on the CPU.

1 Like

thanks for sharing…

Important are these views of Taskmanager:

Then you might see an image like this in which one Core is at 100% and these is the limiting factor:

https://forums.flightsimulator.com/uploads/default/original/4X/0/6/9/0691469f948a09699f6b1eb715cc6fe9f142f26d.jpeg

( topic )

( edit: I forgot to clarify… if you see one core in 100% and your gpu is not in 100% , then your LOD is currently to high for your single-core-cpu-power. In the linked picture you see a optimal situation with a tuned LOD setting for my CPU ( 220 ) ) )

Why in your case the language have an effect, still not sure.

The low GPU makes two of us…I recently upgraded from a GTX1650S to an RTX2060, on paper it should be able to run FS2020 but I’m getting single digits FPS when I’m at cruising altitude. My CPU is a Ryzen 5 3600, and enabling DX12 helped it to run a little smoother during take-off and landing but it’s no help during cruising. I used Nvidia Experience to optimize and limited at 30fps. Really don’t know what else is going on at this point…and hopefully I don’t have to upgrade my CPU/GPU

sure that you already tried to reduce the LOD setting ?

dont do that… reset optimize and use the in-game settings only.

How do I change the LOD setting?

in-game settings → graphics → details of terrain… start with 50, 100, … etc…

have only a german screenshot:

Note: my 220 setting is allready a high value! start your tests with a much lower value.
And be carefull with DX12, its beta.

If that will not help, you run may be in photogrammetry issue which some users reported.

( I assume you have NO mods installed for initial testing )

1 Like

In fact, I already knew how to solve this problem two days ago, but in order to make developers better optimize the game, I chose to shut up. This is because there is a check-8 in the language setting. I don’t quite understand its function, but I heard that it is to be more compatible with something. Because the game needs to allow languages all over the world, it will become stupid (incompatible) in the flight plan. Therefore, after I check-8, the GPU utilization rate will no longer be lower than 30% when executing the flight plan, The number of frames can be around 30, but the utilization rate is still less than 70%. And the Chinese system can also use the flight plan normally.

Obviously, when someone asks the same question again, the developer will say, look, he has found a solution and you should do it like him, but the utilization rate is still unable to reach more than 60%, which is still the problem they need to solve. Fortunately, I can start to experience the game normally.

I don’t expect the frame count to get higher, but I pray you don’t break it again when you update it next time.

In addition, please continue to optimize the game performance. Not everyone uses aw’s computer and 3080. My computer has good system compatibility, but still can’t enjoy the game. Besides, others. Please come on.

unicode utf-8

I not understand… UTF8 is necessary charset and most common used to support most world languages. Where you see a issue with that ? Did you mean you made somewhere a specific setting related to UTF-8 ?

In case you mean the Windows UTF-8 Beta check, it is just related to Windows and not MSFS .

image

As per Default this setting is OFF in Windows ( just Beta ).

PS: you can not force the developers in this way to do anything… you discuss here with us , the community and we are always happy if users find new tricks for optimization ( and if it works for lots of users and is relevant for development, I assume it will back-reflected to the developers ).

1 Like

I don’t quite understand, but check beta. If you have the same problem as me, congratulations. Your problem has been solved.

I’m sorry, I’m using Google translate to have a conversation. I can’t express the problem clearly, but I know it can solve the problem.

So if a brother with the same problem as me has adopted my method and has been solved, please help me submit this bug to the developer.

no, I only want to understand what’s your solution, because it sounds a bit strange that utf-8 setting affects the GPU load

Your solution is to Enable the Setting , right ?:
Windows Settings → Time and Language → Options in Admin area → "Beta: use Unicode UTF-8 …

The only guess I have is, that under specific conditions the CPU have more load on one core because of this and so it can not drive the GPU to full-load. May be there is any kind of optimization with enabled setting.

But dont forget, this is a Windows setting… may be devs can nothing fix here.

YES
Windows Settings → Time and Language → Options in Admin area → "Beta: use Unicode UTF-8

1 Like