Random CTDs due to WwiseLibPCx64P.dll | 0xc0000005 error (Fixed)

to be sure ( because d3d11.dll ) : you not use the “DX12 (Beta)” setting ? in case you do, switch back to DX11.

Mostly this d3d11.dll points to driver or hardware issue ( and yes, mostly is not allways :wink: ). But you already tried to limit the fps ( do you lower it into a realy safe area where your gpu is not under high load ? ).

and try without this… we have not less cases where these tool ( more exact the Riva tuner ) ( and also check running riva background servivce ) cause issues. The fans of a GPU does not need manualy regulated.

Thanks for your answer @MichaMMA

  • I’m not using DX12. Only DX11.
  • About FPS limit, I put 30FPS and the GPU is in very confortable area.
  • CTD even without Afterburner. Riva Tuner is uninstalled.

Post and list updated.

1 Like

Error log (without Afterburner)

Nom de l’application défaillante FlightSimulator.exe, version : 0.0.0.0, horodatage : 0x00000000
Nom du module défaillant : WwiseLibPCx64P.dll, version : 0.0.0.0, horodatage : 0x60a67fd2
Code d’exception : 0xc0000005
Décalage d’erreur : 0x00000000001a91b3
ID du processus défaillant : 0x554
Heure de début de l’application défaillante : 0x01d7fff8c6bdecaf
Chemin d’accès de l’application défaillante : C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Chemin d’accès du module défaillant: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\WwiseLibPCx64P.dll
ID de rapport : ed93744d-da11-4fc9-a7e5-50cc217b0e45
Nom complet du package défaillant : Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe
ID de l’application relative au package défaillant : APP

a different result, this means possible that MSI have an impact.

I have something in mind about these dll… I do a “quick shot” and have the question: do you have Nahimic service enabled ?

But may be I remember wrong… we should search a bit in forum : Search results for 'WwiseLibPCx64P.dll' - Microsoft Flight Simulator Forums

EDIT: ah… there was also the old Process Lasso issue… => seems still an issue in case you have installed this tool: I'm puzzled by Windows 11 not letting me play FS - #5 by AjarTarantula14

  • Nahimic Service is actived in my task managment
    Update: Turned off → still CTD
  • Process Lasso is uninstalled

these Nahimic service cause very often issues. You can deactivate it ( I have it deactivated since ages ). These kind of issues are cause often from older sound-drivers.

But I’am not 100% sure whether we got this Wwis…dll error in that case ( it’s a while a ago we had different issues related this dll ).

I deactivated it but still CTD

Error log when it’s deactivated + with afterburner + normal mode

Nom de l’application défaillante FlightSimulator.exe, version : 0.0.0.0, horodatage : 0x00000000
Nom du module défaillant : FlightSimulator.exe, version : 0.0.0.0, horodatage : 0x00000000
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0000000000a51db6
ID du processus défaillant : 0x4cf4
Heure de début de l’application défaillante : 0x01d7fffd34df8ed9
Chemin d’accès de l’application défaillante : C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Chemin d’accès du module défaillant: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
ID de rapport : 70e9027f-a959-4103-8dea-43f0d47a9bb1
Nom complet du package défaillant : Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe
ID de l’application relative au package défaillant : APP

Error log when it’s deactivated + without afterburner + normal/safe mode

Nom de l’application défaillante FlightSimulator.exe, version : 0.0.0.0, horodatage : 0x00000000
Nom du module défaillant : WwiseLibPCx64P.dll, version : 0.0.0.0, horodatage : 0x60a67fd2
Code d’exception : 0xc0000005
Décalage d’erreur : 0x00000000001a91b3
ID du processus défaillant : 0x36bc
Heure de début de l’application défaillante : 0x01d7fffe4e704fc2
Chemin d’accès de l’application défaillante : C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Chemin d’accès du module défaillant: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe\WwiseLibPCx64P.dll
ID de rapport : e82b2113-d9ad-4b56-a81a-dcd34ad60cb2
Nom complet du package défaillant : Microsoft.FlightSimulator_1.21.13.0_x64__8wekyb3d8bbwe
ID de l’application relative au package défaillant : APP

this is now the worst error message, because we have no more a more detailed start-point ( e.g. no dll ).

I assume you realy fixed some problems with MSI and Nahimic. These …0005 while game start is allways “not nice” and can have many reasons ( login issue, invalid cloud-data, issues because connected devices, and on ).

Does this also happen in Safe-Mode ?

  • Tested in safe mod → still CTD after 1-2 minutes in game (freeze then CTD).
  • Error log → still WwiseLibPCx64P.dll

It seems that Afterburner does something … but there is another thing to still have CTD.

hmmm… you can additional do a test-case with deactivated “windows audio service” ( of course only a test :slight_smile: ) , then we can realy be sure no issue comes from sound-drivers.

Otherwise… hmmm… I think have to re-read some older topics about the WwiseLibPCx64P.dll. Hopefull we are still on the correct “issue path / track” with that.

Also try a different airport / airplane , not that issues comes from this.

And do other high-perf games running fine ? Just to be sure there is realy nothing with the hardware.

ah… and dont forget current issue with the live weather… Not sure whether it is relavant for your case, but is may be a check worth:

I try with different airport / airplane each time :wink:. Every other high-perf games (Warzone, BF2042) run perfectly.

  • Windows Audio service on + real time weather off + afterburner off → CTD
  • Windows Audio service off + real time weather off + afterburner off → No CTD (10 minutes flight) but I have to make a real flight to make sure it is Windows Audio service the problem :thinking: I’ll test it next week.
4 Likes

After a couple of days with ctd:s and trying everything, i switched to DX12, and no more crashes so far, been up in the air for several hours, im also in devmode, but i dont know if that would impact anything.

have to leave yesterday…

so, we can possible assume for the moment no hardware issue and because with Windows Audio service off it seems no ctd, it may be still sound-driver related.

In case you have tools installed like these asus sonic radar, etc. there is a high change for issues. We recommend to uninstall these tools because they are responsible for so many issue. Also best would be to check whether you have realy the latest sound-driver installed ( e.g mainboard page or direct at “sound-card” page )… ( nahimic service is only one piece of the puzzle ).

Let us know what happens :slight_smile:

1 Like

Dev mode is known to cause CTD’s right now.

As always I would suggest trying the nVidia “studio drivers” rather than the newest.

That would be 472.84

1 Like

Thank you for all your messages !

Currently, I don’t have the time to test these potential solutions but I keep you posted ! :slightly_smiling_face:

1 Like

To fix it :

  • Disable Nahimic Service and uninstall Realtek audio drivers.
  • Update your drivers (I recommend Avast Driver Updater, it’ll check ALL your drivers).

Solution tried !

4 Likes

Thank you for all of you who helped me to find a solution.
I updated the post with the fix.

Closing topic as OP marked a post as solution.