Request help: How to get msfs2020 VR setup on a Oculus Quest 2?

I’ve never connected my Quest 2 to my PC before and curious on the steps needed to get msfs2020 working?

So far I’ve:

  1. Updated MSFS202
  2. Installed Oculus Link
  3. Started MSFS2020
  4. With the Quest 2 on I’ve allowed linking
  5. In Oculus Link I’ve allowed unknown sources

However, when I’m on my desktop in the game - no VR options show up (except the toggle one that doesn’t work). It seems like the game doesn’t recognize that the VR headset is connected to the PC.

2 Likes

So there is a VR category that would help you a lot. I’m gonna share one of the articles that should get you going. It helped me, but I’m on a G2.

1 Like

I have moved this thread out of the bugs-VR category to where there is more likelihood of getting assistance.

You haven’t enabled Oculus OpenXR?

Check out the getting started guide in this forum and how to modify the registry in Windows correctly.

Step by step, it’s all explained.

1 Like

I looked at the registry and there was no entry for OpenXR to change. I’m trying to use Quest 1 and I have installed and ran the oculus app.

Keys mapping are also vital.

I’m not sure you’re quite following the guidance. Confirm you’ve checked the “Getting Started” guide in the VR section of this forum.

i correctly setup openXR, switch oculus on beta, but my game crash when i switch on my quest 2 only when i’m in flight, it’s work good on the menu but when i go fly after lading my game crash …

Orange image in the oculus quest 2 helmet
Hello, I use Oculus Quest 2 in VR and it is impossible to have the image in the helmet. I have instead, an orange color image and nothing else. My helmet is well recognized by the PC. The cable rate is 2.1 Gb/s. Oculus debug tool is open as administrator and oculus developer openxr is open and points to the file oculus_openxr_64.json in the registry. My cinfig PC is Intel core I7 8700 K, 32 GB ram, Nvidia Geforce RTX 2060 ventus 6GB graphics card. Anyone have any idea what my problem is? Thank you

what is oculus developer openxr ? have you installed any openxr from microsoft ? if yes u should remove it, it should not be installed

edit : anyway you should follow precisely this post and all steps at the start of the post and it should work fine Quest 2 + 2080Ti + Link + FS2020 set in ULTRA : Best performance simple setup guide

Yes, it is well openxr from microsoft. What should I install instead, thank you. I will follow again all the steps in this post.

hmm, i think u just have to remove the windows openxr, then check if the registry is on the oculus openxr runtime and it should work

I removed the openxr window, checked the registry with the oculus_json link but it still doesn’t work. I do have the two separate views on the PC screen and all yellow in the helmet. Thanks for your help.

i see windows mixed reality on your 1st screen shot, that what u must remove : windows mixed reality

u just have to install MSFS and Oculus and change the registry, that’s all

as here :

Okay, thank you, I’ll try like that and come back to give news. Good flights

Did this fix your issue?

Not yet. I had to leave for several days, so I have to get back to it, thank you again. See you soon.

Just disable HDR on your desktop display and try to enable VR again.

Hello guys, thanks for all your advice, it works now. The VR quality is not very good, it must come from my RTX 2060 Ventus. But it works!!! See you next time…

This is what happens to me when i look through my oculus 2, and brand new 3k alien ware rig… been trying to get it to go to full vr for 3 days now…