Route Line Not showing up on GPS

I downloaded a bunch of flight plans from this site: worldtour.flights

Had no issue with them before. They are PLN files and I’ve compared them to ones I’ve saved and can’t see any significant differences. I could load them - and the plan shows up in the world map area where you plot your route. I click on Fly and the game would load and I can see the flight plan (if I click on FLP in the GPS) and the line displaying the route shows up on the GPS without issue.

But after the last update - everything works the same (I.e. I load the plan as usual) - however once I’m in the game - the actual line that shows the route - doesn’t show up on the GPS anymore. If I click on flight plan it shows me all the waypoints and in fact if I zoom out - I can see the way points on the GPS - but the actual line (white or magenta) that shows me the route - just doesn’t show up anymore.

But the weird thing - if I create a new plan and plot a route - run the game - the route and line shows up on the GPS. It only gives me an issue when I try to load a flight plan from this site. And yes I’ve tried multiple plans - same issue.

I’ve confirmed that this issue happens on two different machines. I tried it on my friends machine. It also happens on multiple planes

It use to work - I’m just not sure what has changed and if I did something wrong to get it to do this. It all seemed to happen after the last update I really like this flights and would like to use them. I’ve attached one screen shot (site won’t let me add multiple) - but the site won’t let me upload the PLN files. Maybe something wrong with the files? I can’t see anything wrong with the XML data as I said and I’ve compared them other PLN files I’ve created. Like I said - the plan is there - just the line doesn’t show up…

Also I’ve submitted a ticket to zend desk AND I don’t have any mods installed nor do I have developer mode enabled. Pure vanilla install running on a I7 with 32GB of Ram and a Nvidia 3080 video card.

Hoping someone else is having the same issue and can tell me how to fix it!

Thanks!

I will look for it, but there is a known bug in waypoints that have over 6 characters. I complained about the same thing about three weeks ago and someone told me about it being a known problem.

I guess long names use to work, but it broke a few updates ago.

You can go in with an editor and shorten those name for now until the problem is fixed. The flight plan is a plain text XML file.

But the AP will still follow the flight plan even when it doesn’t show on the map.

Here you go, this was the same problem I reported and there’s where i was told that it is a known problem.

1 Like

There also seems to be a thing where the first leg does not display but once you pass the first waypoint and commence the second leg the flight plan will suddenly appear.

this is exactly what I see.

I think it’s all related to having long names on waypoints, which broke in SU3. But there may be some other issues.

Try preparing a flight plan that doesn’t have waypoint names longer than six characters and let us know if you still have the problem.

Thank you! I’ll try changing the Waypoints name length and see if that fixes it - it would be crazy if that is all it is! Will let you know how I make out!

I’ve tried flying the full plan (i.e. towards the way points) and that had no effect - but thanks for the feedback!

Thank you again for your help - your solution was bang on and worked. Can’t believe that Waypoint ID’s have to be 6 characters or less. Hopefully it gets fixed soon - but at least I know this works!

Happy flying!

1 Like