Serious Help needed : How to run Flight Simulator VR Mode with Oculus

Hi All,

First of all, Happy Holidays to everyone, hope you’re all well and safe.

I am so excited for the VR mode of this but at the same time, I am incredibly overwhelmed with the amount of elements I need to figure out. Quite frankly I don’t know where to look as there’s so many posts but they don’t seem to be covering exactly what I’m looking for.

My current set up is I have MFS installed from the Microsoft Game Store. I also have an Oculus Rift (first generation I think).

When I put the headset on, Oculus automatically loads the Oculus store, so I am not sure if I am supposed to force it to load MSF ? I don’t seem to see it within the VR store/library section.

So I then launch MSFS and bind the VR keys (i.e. enable VR mode to F9 and some other VR keys etc) . I am having to take my headset off to do the Flight Sim bindings as its not launching within VR headset. I then launch a flight and try to activate VR mode but nothing happens. When the Headset is on, its just showing the Oculus VR store mode.

Am I missing something? are there any vital steps I should be doing?

Would appreciate the help as I can’t seem to see any user friendly instructions on this - the added Oculus VR screen adds to the confusion as I am not sure if I’m supposed to be getting out of that and doing something else.

Help please :slight_smile:

Have you checked out this post: VR Welcome Guide!?

Particularly the known issues where it talks about having to modify registry for oculus rift.

I have the same headset as you and it is absolutely possible to get VR to run with this headset…but that registry setting must be changed.

Hope you get it sorted. (You can ignore everything to do with OpenXR for WMR and downloads from the MS Store- Windows Mixed reality stuff has no affect on Oculus headset and are not needed for your enjoyment of VR with your Rift)

Thanks so much tamalien, I was so overwhelmed I didn’t know where to look (sometimes my eyes see all the posts available and always miss the step of which one to look at first haha). Let me have a look at that one now :slight_smile: and will confirm how it goes

Hi there, is it this section I need to focus on?

Known Issues (launching the sim – no updates):

  • [Oculus] Before using VR in Flight Simulator with an Oculus headset, the computer needs to know the location of the OpenXR runtime to use. Please follow the steps below to set this location in the registry:
    1. Right-click on your Start menu and select Run.
    2. Type in “regedit” (without quotations) and hit Enter. This will launch the Registry Editor.
    3. Locate the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1
    4. For ActiveRuntime change its value to the one that matches your platform (note: default path is shown below):
      C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json
    5. Close the Registry Editor. You are now ready to enter VR with your Oculus headset.

If so, I noticed that STEP 3 doesn’t show “OpenXR” under Khronos, I only see a subfolder in that called ‘Vulkan’ so perhaps I need to install OpenXR? - you mentioend I should ignore anything to do with it so I’m a little puzzled (so easy for me to get confused these days haha) :smiley:

Hmm that is strange as I had it on my system.

Open your Oculus app and on the left hand side click Settings.
In the right hand window click on Beta and then enable the “Public Test Channel”

Now check your registry settings again as that entry should be there and ensure it is as shown below, assuming your Oculus app is installed to C drive

If it isn’t there I guess you could create the relevant entry by creating the directorys “OpenXR” and “1” and then create a new String Value named ActiveRuntime and modify its value to C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json

Check in windows explorer, also, that the file exists in that location.

There is one other setting in oculus app I forgot to mention, under settings on the left hand side, go to general on the right hand side and enable ‘unknown sources’ to permit MSFS to run. (This also may be a requirement to have the app create the registry entry, but who knows on that one!)

Hi macca82.

I experienced something similar to what you describe.

If you are already in MSFS and when changing to VR mode you find yourself in the oculus store, look down for the oculus control panel thing (console?) and you should see an icon with a set of black and white lines on the panel (Mine was between the “Home” and “Virtual Desktop” icons. Click this and it puts you in the cockpit in the sim.

Unfortunately sometimes it unceremoniously dumps you on the floor of the cockpit jammed up against the rudder pedals, or even facing backwards :confused:

This is where the next important task comes in… Binding the re-centre view in VR key. Do this BEFORE you even try getting in VR mode. That way, you can re-orient yourself immediately when you enter the VR mode.

Good luck! It is worth it! The Rift is working much better than I thought it would after rolling back Nvidia drivers and tweaking the settings a bit.

What you have tomdo is downlod v24 when you turn on beta and everything will work.
Dont touch OPEN XR and the register

Can you please post a picture of the icon because all I can see is the virtual flat screen but never takes me to VR reality cockpit. No matter how I try cannot switch from the big flat screen to VR. Please help. Already have software beta 24. Thanks

Sorry but I dont know how to take screenshots in VR bit I see simply a white square with two zig zag black lines (upside down “w” shapes that look like a mountain skyline).

You could also try a long press on the oculus hand controller menu button … it may bring up a menu where you also see this icon to click to switch to the Sim.

It may be something completely different causing your issue… fingers crossed… hope ot works for you.

Thanks so much, will try that. Regards

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.