So will this work with my Valve Index?

And if so, how do I fire it up? (I’ve clicked on the ‘start VR’ button in the SIM but it has an error about openxr being needed?

Here are instructions on how to install OpenXR for either a WMR or non-WMR headset:

https://flightsimulator.zendesk.com/hc/en-us/articles/360018555179-How-to-install-OpenXR-

1 Like

OK - so it helps to have the headset actually switched on (that clears the OpenXR message).

I’m now stuck on a screen asking me to recenter by hitting a ‘recenter VR button’, but I don’t know which key that is… any ideas?

Once you’re all good to go with the Valve Index, you might want to read this:

My 2070 SUPER VR settings and suggestions (Valve Index)

1 Like

These instructions provide no way to use the Index if you purchased it through the Microsoft store. Has anyone been able to use VR on the Index if it wasn’t purchased through Steam?

1 Like

The method is supposedly:
Start Steam VR
Start FS
Ctrl-Tab to switch to VR mode
When I do this, I get a display that looks like binocular video on my main display. The VR tracks head motion and sends audio, but the display is yellow in the VR view and headset.

Nope… No joy. Although I have bound the SPACE key for VR recenter, it doesn’t actually do anything at all.

Also, the instructions on how to set up the SteamVR Beta seem to be obsolete. I don’t have a ‘tools’ menu option anywhere in Steam, and the SteamVR properties panel doesn’t have a ‘betas’ tab as stated in the instructions…

Steam Client yesterday’s update is showing per-app settings a little differently, yet you can still display SteamVR properties and find the “BETAS” tab to the left now, and select whether you prefer the latest beta or release versions of SteamVR.

Make sure to run SteamVR first then:

  • SteamVR Settings > Developer is displaying the current OXR driver
  • Press the “Set SteamVR as OpenXR Runtime” button to use SteamVR the OpenXR driver.

Once done you won’t have to do it again:

  • launch FS2020
  • launch Steam Client only (because of HAGS/NVidia bug in VR - see “My VR Settings” for details)
  • setup your flight and once ready switch to VR: CTRL+TAB
  • this will launch SteamVR automatically
  • click the FS2020 window to make it active and in front of SteamVR window (you might want to also configure SteamVR not to stay on top - there is a setting for this)
1 Like

Never mind. Got it to work. I was in too much of a rush to read carefully. Even if you bought in the Microsoft Store, just turn on Steam VR Beta (right click on Steam VR -> Properties -> Betas, then choose SteamVR Beta Update). Also needed to choose an option to make OpenXR the default. After that it works. Might not be worth it though. Can’t believe the performance–and even the graphics (!) are actually substantially worse than X-Plane 11.5 VR with level 19 Orthos. And its really just partial VR support since there’s no motion controller support. Granted, I’ve done no optimization yet, so there’s still hope, but not a good first impression.

1 Like

Please follow my link for the Index. Make sure to also not use the WMR for SteamVR beta otherwise it fails on XP11 (and maybe is causing issues with FS2020 but I doubt).

Sure enough, I don’t know whether FS2020 is using some specific WMR OXR frame timing that would be different than Steam OXR driver is expecting, but I can push the G2 with more pixels and graphics settings than the Index and keep same fps, and the former is stutter free whereas the later is more sensible. I’ve sent technical details and frame timing to the devs (Zendesk) during the beta for them to investigate this.

NB: yesterday in looking the entrails of the WMR OXR driver v104 I did find a specific code detecting whether the client is FS2020… They could have implemented specific tuning for FS2020, or it might just be a left over for debugging only.

1 Like

So the question is, is openxr on by default? I have Index And was playing VR and having a terrible time Getty FPS even with a gtx3080. I never checked this setting. VR works just not good!

And I’m at work so can’t check!! and have always played with steam betaVr But never changed anything in dev mode!!

Also have steam version of MSFS.

Well I tried the settings in the article and unfortunately there were no meaningful improvements. It took XP a few years to finally get VR performance up to a level where one could use it for serious simming; so I suspect that will be the case for this sim as well. I’ll keep checking updates and kicking the VR tires in FS2020 in the background, but otherwise its back to XP for me.

I have the exact same problem, did you ever end up finding a solution?

I followed the VR FAQ and various steps recommended here, but get the same binocular view on the MSFS main screen, a yellow screens in the Index HMD (SteamVR’s display preview window just shows a black screen).

I ended up having to turn off HDR and REBOOT after. Then gtg.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.