Stuck on Flight Loading Screen About %80

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

Hello, I was using MSFS normally, But one day when I was slewing the aircraft, sim crashed and never load after clicking the fly button in the map screen. It always stucked about %80 percent. It is not crashing but not loading. When I look task manager It seems to be working but very few source usage. Music always playing also.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

I7 4770K @4.2GHZ // RTX2060 // DDR3 16GB RAM // ASUS ROG MAXIMUS XII RANGER MB// 240SSD just for msfs //

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Build Version # when you first started experiencing this issue:

1.26.5.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

After this issue, did you restart and shut down your PC and then try to reproduce this issue?

this problem continues for last 5 days. I completely uninstall and installed the new ssd. So, not just restarting

1 Like

I found the solution here : Game freezes while loading a flight - Bug Reports / Install, Performance & Graphics - Microsoft Flight Simulator Forums

may, also if it is already known, because lots of search results points to it, I would ask whether you have/had the google-maps-addon installed ?

If so, remove the C:\Windows\System32\drivers\etc\hosts file :slight_smile:

This addon had changed host file in system32 so msfs couldnt load map and freezes.

BE CAREFUL WHEN USING GOOGLE MAP ENHANCEMENT MOD!

1 Like

Just another reminder folks that this map addon is not supported by MSFS, and therefore it is not to be discussed in these forums!

Oh…sorry! I didn’t know.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Same problem on PC with more than enough operating requirements met (Ryzen 9 5900, Radeon 6800XT 12G, 32 G RAM, Win 11 completely updated, fiber internet +40Mb/s WITHOUT PROBLEMS in any other program or circumstance except for FS2020). Everything up to date, SIM version 1.26.50. Load the program, it takes longer than usual, the menu appears and from there any operation you do (Maverick Missions, flight school, world map, etc) with any plane and circumstance starts loading and with a little less than 10% left it freezes and I see in the task manager “NOT RESPONDING” the FS2020 thread. It seems that the creators are making fun of us by giving us instructions like “reinstall” (as if it’s so simple and fast) or making us waste our time again and again until they find the solution and release an update. They are looking at us foolishly. Today we have this problem, tomorrow another group will have another problem and it will continue like this until in two years the simulator is fairly mature and we can use it when we sit down in a free moment -which are few- It makes me very angry to have to go through this over and over again. Each update is a new door of problems to which we will be thrown by groups that will spend hours, days or weeks without being able to use the program we paid for…because it hasn’t been free. Sorry for the hard words, but i´m very frustrated :rage:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

no fault ID. No errors. Just loads up to 80% for EVERY SINGLE FLIGHT. I’ve done everything: uninstalled and reinstalled Windows, removed MSFS 2020 COMPLETELY, deleted all local files, installed again. Removed/Reinstalled GPU drivers, chipsets, etc., logged out/in/updated Steam/Microsoft Store/Xbox, etc., completed every “bring to vanilla” step available across this forum. SIM simply won’t load ANY FLIGHT PAST 80%.

Have you tried these: