SU5 1.18.13.0 & 1.18.14.0 Game will not load

I think that might be the case! I just deleted everything that was not developed by ASOBO or Microsoft and I was able to get passed the stuck loading bar issue.
EDIT: However, I did install the new market place WTG1000 add on so technically I do have 3rd party mod installed within the content manager

Reinstalled the complete game. It then worked.
Then I tried to use addons EGLC London City Airport and the Landmarks London City pack, both by Orbx. These seem to be the culprits. As the game froze again at the 50% mark.
The EGMC London Southend Airport sold by Orbx but developed by Pilot Plus works OK!

1 Like

Yep, emptying the Community folder solves the problem. Actually, for some reason, known only to Micro$oft, I get an error message if I try to remove a file from it. My workaround was to rename the Community folder to Community_X and then create a new empty folder named Community. The sim loaded my flight with no problem. Now I am going to start moving my addons back one at a time (assuming the system doesn’t block me). I’ll update this when I know the result.

EDIT: I get these messages every time I try to move a file. Does anyone know a workaround?

These were not addons in the Community Folder, these two Orbx addons were purchased from the MSFS marketplace!

1 Like

Yes, I have purchased items in there, too. I still call them addons.

Hmm…well I guess I will try uninstalling as much as I can from the content manager and if that doesn’t work I will try the full uninstall. Thanks for the info.

I finally fixed the issue for me. There was an addon from the official store that was causing the problem. I removed all addons from my community folder then deleted all non microsoft or asobo addons in the content manager. My game worked after that and I was able to add back in my 3rd party addons to the community folder and some of the store addons back in through the content manager. It might be an orbx airport or caranado plane. Not sure.

Yes, it appears that some scenery packs purchased from the MSFS marketplace will cause the flight to freeze on the loading screen. I am experiencing this with the Hong Kong City Times scenery made by Sam Scene 3D that I purchased in the MSFS marketplace. Others that purchased the Hong Kong City Times scenery from an external website and then placed it in their Community folder do not have any freezing problem at the loading screen.

Yes , I am back flying again as well. I emptied the communities folder and uninstalled the simulator in Windows then reinstalled from the MS Store. I have added back in the world updates but will hold on others for a couple of weeks to see what settles. Pleased to see that my flight log and saved flight plans are all still there.

This is exactly what I’m experiencing. Ryzen 3950x + nvidia 3090.

I can’t for the life of me figure out what’s going on. I tried uninstalling anything non-Microsoft and non-Asobo, no change. I really don’t want to reinstall the whole sim again, takes several hours.

I posted my own thread before I seen this one so I will add my similar problem.
After updating MSFS 2020 Aug 2nd now it closes/crashes at around 50% load at start of app.

i7-10700F Comet Lake 2.9GHz (4.8GHz Turbo) 8-Core 16-Thread
GeForce RTX 3060 12GB
16GB DDR4 3000MHz
1TB Intel 660P M.2 NVMe SSD
Windows 10 Home 64-bit (with latest updates)

The MSFS 2020 update completed ok and shut down MSFS but did not restart MSFS on it’s own so I tried to start from MSFS 2020 app icon. It would start to load, past the checking for updates screen and would close the app at about 50% at the Rhinoceros picture.

Clean new PC. Only MSFS installed on PC at this time.
GPU and Windows updated. Fast internet service.
Tried:
Shutdown and restart of PC several times.
Ran repair on MSFS App under apps Advance settings and shutdown and restart.
Tried running as Administrator.
Ran MSFS through NVidia with LOW settings.
All with same problem of closing at start at 50% of load.

After trying a lot of things, I tried running “Reset” on MSFS App under Apps Advance Settings deleting MSFS Apps Data. When I reopened MSFS (after shutdown and restart) it is now reinstalling Standard+Deluxe+Premium Updates (120GB+)

Update:
Managed to fix it by doing a “Reset” under Apps > Settings. Note: the MSFS Apps Data will be deleted.
Tried various fixes from other posts but they didn’t work.
Restarted PC and after starting MSFS it reinstalled MSFS Standard (over 100GB), Premium and Deluxe. About 125GB in total. Everything worked smoothly after reinstalls.
Installed all of the Free Add-ons and the ones I purchased before, and everything still tested ok.
Restarted MSFS several time and tried several different flights and must say the new update for me with my mid-range PC is working a lot smoother and loading a lot faster, no freezing or glitches even at mostly ULTRA settings. So on my pc the updates did make a lot of improvements.

Happens to me when starting a flight from Dubai with the Orbx Dubai Landmarks installed.

Same with me. I click fly and the load screen stops halfway.

1 Like

Same issue here…London City pack and Cape city in South africa scenery from Orbx freeze in loading…They are buyed in marketplace…If they were buyed from orbx central in community folder they work…I have written to orbx…Thei said that are investigating…Ther’s a workaround…from London I start from heathrow…Once loaded i can restart i flight from london city airport and in flight near london(for example the walkie talkie).Same from the scenery of cape (south africa).If i start on flight near the port the load freeze…If i start from a near runway it load. After that i can load in flight near the port of City of cape…I have about twelve scenarios and the problem is for London City and City of cape

Update: Orbx said the London City pack is on the way to be updated…No news For City of Cape

may be we should bring the topics together that we not lost votes ?

These

is the add-on issue since SU5 and more deeply discussed ( and more votes ) here:


Same can anyone help me?

Im using PC W10 ver 21H1 19043-1165

Microsoft Store version?` 1.18.14.0

Do you have any add-ons in your Community folder? Yes -removed and still not loading past "Check Mandatory Update" to find nothing..

Are you using Developer Mode or made changes in it? Cant access Sim anymore to find out

Brief description of the issue: Been submitting the issue to Zendesk for 2 weeks now with no response.

Finally, I had a response from Zendesk, the day after checking out the Forum for every conceivable cause through Powershell etc and installing Gaming Services to then have the sim unable to be launched.
Uninstalled it and 127Gb later and 8 hours for download, hopefully it’s now stable.
Downloaded an update that appeared in the Store, only to have the same issue again. Stuck after launching with the Update now Available in Store pop up. Here we go again.

Can’t get past the loading screen either anymore. At 80% it freezes the whole PC, RGB stops changing and I have to do a hard reset. No events logged in event manager during the freeze
I’ve tried:

repair
reset
complete deinstallation and reinstallation in different path
logging out of store
starting via powershell
etc etc, basically everything listed anywhere

Hardware: 5800X, 3080TI, 32gb Ram.