TBM Oil pressure warning and engine cut out

OK, so experimented with this a bit and now understand what is going on.

Can anyone confirm for me that there is no mixture control on the TBM?

The issue arises when I have a throttle quadrant axis mapped to the mixture control, even though the TBM has no mixture control as far as I know.

If this mixture control is moved to below 50%, the engine cuts out. It can then be restarted, even if the mixture control is left where it is, i.e. below 50%. If the control is moved AT ALL when below 50%, the engine cuts out (for clarity, that is moving the control up or down). Again, regardless of where the control is, the engine can be restarted. So, for example, moving the control from 60% to zero will cut the engine. After restarting, moving the control from zero to 100% will still cut the engine. It seems tied to moving the control at all when below 50%. Moving the control from 60% to 100% does nothing. Moving the control from 100% to 60% does nothing.

Obviosuly the fix is easy - unmap the mixture control! However, I will zendesk anyway.

I think the culprit for my engine failures is then my cat :cat: He likes to rub his cheeks on the quadrant levers…and if he does that on the mixture control, the engine cuts out :crazy_face:


:rofl: evil :kissing_cat:

You’re totally right, the TBM does not have a Pilot mixture control. Anyway, the FADEC must reduce the fuel injection level during climb. But it’s automatic like a jet engine. So you found the backdoor to the programming of TBMs FADEC. :crazy_face:

That’s because it is, you know, a jet engine :smiley:

Yeah, you’re right, actually it is a jet engine. :innocent:

Thanks - I had to google FADEC! Mixture ON/OFF toggle is definitely Digital though!

1 Like

I had this happen. I was using my default throttle config with both mixture and prop rpm controls. I just left them at the maximum setting and didn’t use them.

Turns out the slightest - and I mean SLIGHTEST - movement of either of those will cause the engine to shut down. This also occurred for me in the Citation. I suspect it could also have an effect in other planes that don’t use mixture and prop controls.

What I ended up doing was saving out a separate controller config for my throttle where those 2 unneeded options are disabled. I switch throttle control layouts based on what plane I’m flying.

I haven’t had the problem since.

I discovered what the issue was, but won’t take credit for the solution. Someone else had recommended I save out a separate config for my throttle. Sounded like a hassle at the time, but turns out it was dead simple and only takes a few seconds to switch when I switch aircraft.


Hi All!
I have this same problem in the 930 but I checked all my bindings and they are all fine. I also turned on auto mixture and unlimited fuel and this did nothing. Shortly after takeoff, I notice the oil pressure begins to drop to 1, and then the engine proceeds to cut off. The only fix I have found to this is placing the AI in charge of the airplane when I first notice a pressure drop as they normally can correct it. If anyone has any ideas on how to fix this I would be very grateful. Thanks.

Just set any mixture control you have to 100% and don’t touch it afterwards… The TBM doesn’t have pilot controlled mixture.

I do not have a mixture or prop control only throttle

I just flew in a Bonanza and had the same problem occur


The post right above your first. That’s the solution.

The mixture is likely bound somewhere and being set to 0 causing the issue. That’s the only thing that would affect both the TBM and Bonanza.

1 Like

This reminds me of the time I didn’t notice that elevator trim was also mapped to my rudder peddles. It made taking off incredibly difficult.

Had exactly the same issue. Solution was to create a new profile with mixture not mapped to any axis.


I do the same. I find that when you have it mapped and flying a plane that doesn’t use mixture (TBM or jets), if you so much as nudge the mixture control accidentally, it will shut down the engine. It’s just easier to create a separate profile for my throttle that doesn’t include mixture and RPM when flying planes that don’t need it. It takes only a few seconds to hop into controller configuration and switch it and avoids accidental shutdowns.

It would be nice if we could permanently attach controller configs to specific planes though.

There is a wishlist for that:

I also a wishlist for the control mappings screen to only show controls relevant to the selected plane - so that it wouldn’t allow you to map things not in use.

Thanks for pointing those out. Voted on both.

Cheers mate!

1 Like

This just happened to me over the Gulf of Mexico and gave me a heart attack. Thanks for a quick answer to how to correct it!

Thanks, this solved my issue, I had second from left on mu-y honeycomb Bravo mapped to mixture. Unmapped it and all good.

This happens to me with various planes like King air or Bonanza. After I hit ctrl+e again in the mid-air, the problem goes away.

Yes, that will restart the engine, but didn’t fix the root cause. Also only works if you are there at the time - and haven’t left the AP in charge whilst having dinner :grinning: