TF-104 sim skunk works

The patch alone won’t fix the issue, you need to set an extremity dead zone of about +4%. This combined with the patch has given me a functional AB at any altitude.

Yea I’ve done that. No it doesn’t work. Even though the pretty flame appears the ■■■■■■ thing won’t accelerate past mach .9. As I said, broken piece of ■■■■. Like so many other add-ons on this “”GAME”” (fokker f.viia amongst the others)… it’s only pretty pictures but doesn’t qualify as a sim in my book.

I’ve on the other hand I’ve never EVER had any such issues on xplane or with any third party add-ons there. Firstly the devs are aviators as much as programmers, they love their product and best of all, what’s not to your liking can be modified by the user.

After this rant I’m going to unsubscribe, I’ve long uninstalled msfs already and I don’t miss the heartache it has given me.

So good bye and fair seas.

Well it works for me, pity you can’t figure it out. Good luck finding a 104 in XP though.

May I ask what you did to fix the issue? I’m having a similar problem.

With the afterburner? All I did was make sure I was on the latest version and set a small extremity dead zone on my throttle axis. Personally I had to use +4% but it may vary depending on your hardware. Using values of 3 and 5 produced odd behavior for me so you may have to experiment. That’s all I had to do.

Yes, I discovered the Afterburner bug, it seems that if the throttle goes to the end of the axis the AB kicks out so you have to keep it at about 99% or so in the Axis and setting a dead-zone extremity around 4% does the job.
My problem now is that doing the “energy management” once the plane goes beyond Mach 1.2 it tends to accelerate in an uncontrolled way, yesterday in a test I reached Mach 6 and 90000ft (disabling failures) which is of course not very realistic. I wonder if you are supossed to toggle AB off after some speed or altitude.
It is a very buggy plane and unfortunately the devs are completely silent and won’t respon to support.

2 Likes

Aho, that explains what’s going on I think. I’ve been wondering what this dead zone was supposed to do exactly, and how it’s supposed to map to controls in spad.next or other external input management tools that don’t offer the same exact terms in axis control.

Thanks, I’ll try limiting the max output value for the axis when I’m back at my gaming PC and see if that helps for me.

It should if you have F2 and F3 mapped to decrease-increase throttle (default) you will see that when you are at full power and the AB kicks out a touch of F2 brings the AB back, so the bug is that AB does not like the axis at 100% and a positive extremity dead zone value prevents that from happening. If you go too far you can’t enable AB at all that’s why the value has to be very precise, usually 3%,4% or 5%.

If you (or anyone) make a test can you please check if the acceleration is uncontrolled like I found? What I’m doing is:

  • AB on the whole time.
  • Climb mantaining about MACH 0.89 up to 35000ft.
  • Point the plane down, let it accelerate to about MACH 1.2 it will descend to around 20.000ft or so.
  • Once it passes the transonic barrier you will notice the plane will start to accelerate more.
  • Let it reach the “SLOW” message.
  • Point it up trying to get rid of the “SLOW” message.

And now it comes my problem where I have to climb too much, reduce throttle or use the speedbrakes because the plane behaves like a rocket, it IS a rocket but I think the acceleration is out of the way.

Yeah I reached Mach 3 the other day so I know what you mean. It does accelerate rapidly once it gets supersonic but unfortunately killing the AB in some situations causes the plane to buck forward and backward due to the dev incorporating the T2 reset on the engine, however the implementation isn’t great and a bit inaccurate based on what I’ve read.

Both the trainer and single seat variants do need an update. SU9 introduced this AB issue, and it’s still present after SU10 which would indicate to me that Asobo don’t see whatever is causing this as an issue, and since SU9 we’ve been having to use this workaround version. Meanwhile I don’t have this AB cutout issue with any other plane I own that has an AB.

If you compare the current versions of the planes engines and flight model cfgs vs the pre SU9 versions you’ll see the dev had to alter the engine values to overcome whatever SU9 broke and I think that gives the plane a bit too much power. For instance the takeoff roll is way shorter than it used to be.

Yes killing the AB makes the plane unstable so I’m using the speedbrakes to control the plane from going above MACH 2 while keeping the altitude, I really don’t think that’s the proper way to operate the plane and unfortunately the devs are silent about this.

other issues I’ve found with the Marketplace version are not having the manual (I have all the pdfs but the manual in the Docs folder) and the Radar is not working at all. INS does work very nicely if you code the waypoints in a FP.

The radar relies on an external application to function. Recently the marketplace stopped allowing executables to be packaged with addons, so I think you need to download the file from the website maybe? I can say the radar does work, I was using it last night, so my guess is you need the exe. The dev is active on here, he answered a question I had about two weeks ago, though I did email the help desk a week or so ago with no reply, so it can be hit or miss. The 104 is my all time favorite plane so hopefully some of these small issues can get ironed out.

I would love a way to get to the .exe for the radar or the manual, my purchase from the marketplace is incomplete.

Maybe try posting in this thread, the dev seems to reply there pretty reliably.

https://forums.flightsimulator.com/t/development-of-sim-skunk-works-lockheed-tf-frf-104-g

I will try, thanks!