Throttle doesn't work for some planes

Ok, i have tested it and it works. I made a screenshot of my Power management settings to show what i have, maybe it helps you.

1 Like

Thank you, but it didn¨t help. I also tried to remap throttle to axis Z which is in my case rudder control and it worked through this channel. So I think it might be a problem reading slider axis values. What’s weird is that I flew normally for at least one day after the last sim update. Even though it might leads to the idea that the last update is behind it, it doesn’t make much sense. Maybe I should contact addon producers.

Since it works with all others, this does look like an addon problem.
I think your idea to contact the addon producers is the solution here.
There may be some help in their forums as well.

VR or flat screen?

At least in VR, there seems to be a bug: if the mouse pointer is over a window (ATC, VR map, etc.) the input from throttles is ignored by the sim.

TBM has the same issue.

1 Like

A new update just posted on Flightsimto for the TBM.

1 Like

same on my thurstmaster hotas. four planes so far. tried creating a second thrust axis but not joy. mouse wont move the control lever in cockpit. left with keyboard commands F3&F4

So now I have to change it back again… :smiley:

1 Like

NEW to MSFS - compulsory upgrade and now the ‘Thrustmaster Airbus’ slide throttle doesn’t work, especially on the F35. MSFS is not really convincing me that it was worth the $$ ATM.
Suggestions please ?

Did you read about changing the control binding to Throttle 1?

Same here, it’s frustating…

No.
I’m new and still learning set ups - MSFS also crashes a lot as well (PC)

Hi Folks. It’s related to this problem, so feel free to participate here and vote if you see fit.

I’m running into the same issue in VR. But not sure if it happens on flat screen. Seems like throttles become non reponsive on final, argh. If I place mouse cursor over throttle, they work again.

As a temporary solution I settled the "X slider" as “Throttle 1 (0 to 100%)” and unchecked “reverse axis”. After this setting the throttle reacts only after 30 -ish% of the X slider forward movement, so it is not so presice, but at least it works.

Any solution to the unstable throttle problem? I see suggestions but no solutions. I am running the latest versions of the flight simulator on a pc with windows 10, not developer mode. Throttle and throttle1 both set to sytek slider Z. The pilotus with floats (recently added to MSFS) starts okay but after a few minutes the throttle command and engine readout display arcs are erratic. Landing is quite a challenge when after touchdown the engine jumps to full power even though the throttle control is at idle. The pilatus accelerates down the runway and then takes off with throttle control still at idle. I really like the pilotus with floats and it flew fine until a few weeks ago.

Download DIView calibration tool and calibrate your throttle with it.

https://heusinkveld.com/download-diview/

And after calibration, only use throttle 1 axis, not throttle.

1 Like

Your suggestion worked! The “Pilatus PC-6 Porter Floats” using only throttle 1 for the Saitek z axis gives full control. Previous suggestions to set the z axis to both throttle and throttle 1 does not work. Something changed a few weeks ago so that binding only to throttle (expected for a single-engine plane) no longer works. Thanks for giving me control of my favorite bush plane.

Now also bind throttle 2 axis to your lever, or you’ll be in a merry go round when flying a twin engine plane :wink: