Thrustmaster TFRP rudder pedals disconnecting

I have a set of Thrustmaster TFRP rudder pedals (directly connected to USB with the adapter, powered USB hub or no hub makes no difference). Almost everytime I start MSFS2020 they disconnect and I have to unplug/replug them, sometimes more than once. Sometimes they also disconnect during gameplay, which is really frustating. I cant say I have this problem in other sims. Anyone else having this issue?

1 Like

No. Mine stay connected 100%. Clean all the connectors especially the little phone jack type plug.

The problem I have is when the pedals are plugged in to the USB port my PC will not go to sleep. I have to remember to unplug them each night.

I have exactly the same problem with CH yoke and CH pedals. Every time I start to play, they are “dead”. I finally got tired of pulling out and re-plugging the USB cables, so I bought a USB hub with individual on-off switches. I still have the problem, but it’s easier to manage with the switches. So far, I have never had a problem of them stopping in the middle of a flight.

I am not sure if this will help but it can’t hurt.

Have you found a solution? My TPR begun disconnecting and reconnecting, every flight! I have changed ports, cables, used USB hubs, disabled the allow computer to turn off etc. Something funky is happening and I can`t figure it out.

No, not really. I’ve started to suspect that my pedals are broken. But the sim usually doesn’t recognise my VirtualFly TPM either before I disconnect and reconnect it (though Windows does) so fs2020 is a suspect too.

This is very frustrating and confusing.

I have no idea either, been troubleshooting for 3 days and it is driving me insane. I have a 5 mo old TPR rudder, and it worked flawlessly for that time. After moving I probably ended up using a different USB port than before and the problems started. It disconnects/reconnects randomly (seconds to minutes), some times it will be mislabeled when reconnecting and MSFS will crash and even the controller panel will freeze. Tried different ports, hubs/no hubs, cables and I am not testing on another pc.

PlaneDig - thanks for the link. I’ll know tomorrow if this works for my joystick! I’ve been having the same problem. I’ll post here how I make out.

Just sent my TPR to Canada for RMA. I have tried everything and its the only peripheral constantly disconnecting/reconnecting. Although another suspicion is AMD and x570 MB.

I had the same problem in sleep mode. I’m not sure if you installed Neflix app for Windows 10 but, in my case after uninstalling the Nexflix app and rebooting soved the problem. I don’t understand the reason but AFAIK the Nextlex app has the function for screensaver, and, this function might cause the problem with the sleep mode when USB controllers are connected.


I don’t have the netflix app installed, I only use it through browser. I also don’t think it would be my issue, since I have all sleep functions and usb power off disabled, plus it disconnected several times within seconds and then nothing for days. My first guess is a defect in the rudder module, since its the only peripheral doing this. My second is my x570 mb and its usb handling, that is abysmal and problematic. Anyway, its in Canada for repairs.

I uninstalled the Netflix app, which I never used, and my PC slept like a baby last night with the pedals still plugged in. I would never have figure that out by myself. :beers:

1 Like

Happening to me too. I don’t have Netflix. They just randomly disconnect, and have to be unplugged/plugged back in. It’s frustrating as expensive as these were.

and you hit the bullseye with this months old statement as you probably heard already AMD is now investigating the connectivity issue with 500 series motherboards

1 Like

I have the same issue with my TPR Pedals and had the same props with the T-Flight pedals before. I had an Intel-only system and now a AMD 570X and it happend with both plattforms no matter what hub I use. It has defenitively to do with the Pedals itself (and its USB hardware), because I have zero issues with my TM Warthog and the TX Driving Wheel. The only solution is to replug, wich is not a solution at all. Anybody using them with Windows only drivers and not the last TM ones?

1 Like

This is too weird as I used them with the same x570 system for 6 months without any issues, now I can’t get them to stay connected for 5 minutes! I have received my unit back from Canada with a new board and the problem persists. Tried another cable (probably the 5th). Disabled pcie gen 4. Not sure what else to do besides a lawsuit or selling it to someone.

I have tried differend USB ports, and found one that makes them stay connected. The funny thing is that the ones that didnt work so well, were directly on the computer, while the one that works is through a USB hub (with its own power supply). So, using this specific USB port the pedals now stay connected all the time.

No such luck with a powered usb hub. Which one you are using?

Well, its a Plexgear Desktop 710 USB 3.0-hub.
The thing is that I have had trouble with my VirtualFly TPM+ too. Everytime I started MSFS2020 I had to disconnect and then reconnect the TPM for MSFS2020 to recognize it. Since I started to plug it into these hubs (not the same as for the pedal, I have two of them), it is always identified in MSFS2020 without any fuzz.

I really dont know what conclusion to draw from this. Ive started to suspect my MB is funky, but then again, I dont seem to be the only one having had this kind of problems. Its all very stange.

I had this problem after a recent AMD Driver update. Turns out fTPM was turned on in my BIOS automatically (i think Microsoft has been doing this to show Windows 11 compatibility).

Turned off fTPM in the BIOS and everything is working again.

I guess another workaround would be to install the latest Ryzen related BIOS update that fixes the TPM stutter issues. I have the X570 Aorus though and Gigabyte has yet to release that fix outside of BETA.