Track IR Workaround

Sorry if this has been posted but didn’t see it. I was told when Track IR freezes to use the F12 key but that didn’t do anything for me. But I did find a fix. On your keyboard profile, search for toggle head tracking and set a key to it. Voila, when Track IR locks up, it unlocks it.

I just found that about 30 mins ago myself. Seems like they took control of the TrackIR in MSFS. However, they neglected to make an option to centre the view. It now no longer accepts inputs from a joystick (used to have centre to one of my yoke buttons). I have to assign a keyboard key. I’d much rather have all my TrackIR controls on my yoke…

1 Like

You can use Joy2Key (or a similar app) to translate any joystick button in a key.
This will solve the issue waiting they repair it (you’ll use it for a long time…)

Tried it. THat’s what I had since I started using TrackIR. I had one button to centre my view and another to toggle tracking. Neither of those work any more. I tried re-bindng it to my yoke, but no dice. Had to remap to a button on my keyboard. That works. Not from the yoke though

Strange. I didnt’ try with TrackIR, but my others bindings in Joy2Key still working in MSFS (MSFS = Microsoft Simulator F… Surprises !).
Hope it wont be too long to be solved…

lol Yeah, I wouldn’t count on it. Minimum 2 months. Bare minimum. I’d be willing to wager this problem will still exist this time next year.

One step forward, two steps back, Asobo have work guaranteed for years :upside_down_face:

If you now have to use your keyboard to toggle TrackIR on and off and to centre your view that really sucks.
I have a TrackIR profile I have used for years in XP11, DCS and now FS2020 which binds those functions to buttons on the throttle quadrant of my X52 Pro FCS. Its so natural I don’t even need to think about using them due to muscle memory. Changing it all will ruin the ‘immersion’ in the sim and seems completely unnnecessary to me. Why are they messing with something that didn’t need improving?

There have been lots of TrackIR posts (including in general, unless the mods moved them) so not sure how hard you looked/searched? (Not meaning to be rude, just surprised you couldn’t find anything.)

There’s a popular bug thread (already ~350 votes) for it where various fixes were suggested, including the one you mentioned in post 23:

Please add your vote for the bug while you’re there :+1:


Well, 3 flights, 3 CTDs. I couldn’t set my keys in TrackIR even with MSFS off. Just rebooted, and now it’s letting me. Hoping it was just a weird anomaly. Will see in a sec if it works this time as I load into another attempted flight.

Well after a computer reboot, that seems to have fixed it. Hopefully it stays fixed.

I am probably going to regret I said this but since my first flight after update I have not had a IR lockup since.

I’m sure it has been waiting for me to post something about it but maybe it wont recognize me with my new disguise :sunglasses:

BTW, If anyone asks, I was never here.

Thank goodness I finally found this tread.
I mapped a key to the toggle head tracking command and now track ir works again.
But I have a problem: if e.g. I have to type something into an instrument, I used to point the view to the instrument and then block the tracking to write. Now, when I use the new command, the position is reset. Does anyone know how to maintain the position? This is also useful in the external view, because the default view keeps the plane too low in the screen, so it is very convenient to move the view up with track ir and fix the plane in the middle of the screen.

I often pause the activity of my TrackIR. I will often select an outside view and position the view to my liking with TrackIR, then pause TrackIR. It would stay in this view whenever I switched to outside view.

I can’t do this now, as when TrackIR looses connection (by pausing TrackIR) the sim repositions the diaplay.

Not a biggie but I’ll be happier when they return the previous functionality.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.