Ucrtbase 409 + outage of online services

Please tag your post with #pc and/or #xbox.


Are you on Steam or Microsoft Store version?


I have the ucrtbase 409 error which usually causes a CTD on the loading screen when connected to the internet.

Yesterday, i tried to fix the problem with the most recent version of the VC++ redistributables and the game started (with online functionality set to on), but I got the “Online services are unreachable …” warning. Today, with the online service working, I get the CTD again.

I am wondering now why the game is starting when the “MS-side” is not working but crashing when the online services are available?

we have in meanwhile lot of these " can play only offline " and " 000409 ucrtbase " topics.

The latest topic I have in mind is:

Beside of the other mentioned possible solutions, the user mentioned to create a new xbox account. But I’am not sure how this can work in point of licensing.

This bug Is really making me upset. This is definitely a game bug that has prevented me from playing for almost half a year. A new profile lets me play online, but my profile is my identity. Changing profiles to play one game is like saying I need to change my name on my drivers license to drive one particular car. This is definitely a game bug, not a system setting because if also crashes the game one an Xbox One X. The support ticket system just marks my ticket as ‘solved’ even though nothing is solved. This is a blocking bug and should be high priority, but I feel blown off. I WANT to work with them so they can figure out what’s causing the issue, but it feels like I’m just marked as a statistic and stuck without the ability to play. After the new year I’m going to have to just ask for them for a refund, but I bet they won’t give me my money back for any of my purchased content. I WANT to use their software, but it’s like they just don’t care.

They need to either
a) acknowledge the bug, give us an explanation of why it’s happening, and a goal for when they’re fixing it,
b) add a logging mechanism so we can help them track down what is causing the bug,
or c) because this option has something to do with the xbox live profile, give us the option to reset the game data on xbox live to a clean state so we can actually use it again.

may be try to reset your cloud data manualy, e.g.

I tried deleting my profile information through the Xbox one x. The steps looks different though, so will try that once I get home

is only an idea, but we have lot of case where manual removal of cloud data was helpfull ( there are also other topics about in forum with slighly different steps - is just not so easy for MS cloud, compared with e.g. Steam ).

Sometime I also wonder whether more users which switch from PC <-> Xbox run into these kind of trouble.

PS: but yes… these removal should be a bit easier for gamers ( or better not necessary )

Confirmed, still crashes as soon as i turn online functionality back on.

Same Problem. ucrtbase-409- online and also offline :frowning:
Have buyed a new PC. Only W10, without any other software, no virusscanner, no msfs mods.
Only the os and the msfs2020 (naturally latest drivers and firmwares)
My ctd happens when i´m click on the “general options” - otherwise the game is running (longest test-2,5h without problems)
Have installled the eng language package and latest visualC++
De-and reinstall msfs -same problem

i despair :frowning:

not “same”, because OP reported the case “online”.

But anyway, you have surely installed the English Language Pack US , not a different one ?
There are other resons possible, you may find some of it in forum. I remeber about >10 usb devices, anti-virus protection, sound-drivers, etc… usually the sitution you describe is the lang pack US.

my ctd are offline and/or online.
i´m only crash at click on “general option” (allgemeine optionen)
otherwise the sim is running normaly. bevor this post writing i make a 1h flight without problems.
but when i click on the options picture - ctd
OS is W10 (german) with english language pack installed.

yep… as mentioned, search in forum about “ctd options” :slight_smile:

We have two common issues with that ( at least what I have in my mind )… the lang pack US and more than 10 usb devices connected. May be you find an additional topic I havent in mind at the moment.

this one:

i have read all topics and all tricks done, without success…
every click in “Gerneral options” is an CTD