Unable to launch FS2020 ---> Store

[win] + [R] >> “regedit” [enter]

But i think, if you dont know these basics, you should not mess with the registry at all… be aware of what you are doing

It’s OK. I did delete both directories with all the keys and still have the problem. When I run FS2020 it sends me back to the store and it doesn’t install. It drives you crazy

Windows Gaming Services does not reinstall… pffffffff

Did you reboot ?

Yes and I am totally stuck. Cannot reset the game service (normal, I deleted the keys …) I uninstalled FS2020 but the installation does not restart. It is incomprehensible.

Same issue here. A bit more context that I found:

  • It stopped working after (without my intervention) “Gaming Services” completed an update. It is now on version 2.5.3.17002.0 according to the MS Store.
  • In the Windows event log I can see an error log happening 2-3 times every second:

‘“Gaming Services” service was terminated with the following error: device specified which doesn’t exist.’ [English translation of the original error message on my German system]

  • I have not changed anything on my system; most certainly I have not “specified” any device that “does not exist”.

Clearly, Gaming Services has been broken through an update so that it is now stuck in a loop in which it can never start and, since this is a prerequisite for MSFS, that app cannot start anymore either.

Any help would be appreciated from my side, also.

1 Like

edit: Saw that HC4Lif3 posted essentially the same solution before (Unable to launch FS2020 ---> Store - #4 by HC4Lif3). Anyways, for documentation purposes:

Fly, can you please check first whether your problem is the same as the one I describe in my post above (Unable to launch FS2020 ---> Store - #12 by QuickNiq)? If so, the following solution may help for you, too:

  1. Stop Gaming Services:
    1. Open the registry editor (Windows Start > regedit.exe) as system admin.
    2. Navigate to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\GamingServices. Double-click the “Start” REG_DWORD entry and enter 3, then press OK. This puts GamingServices to manual start mode rather than automatic start mode.
    3. Navigate to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\GamingServicesNet. Double-click the “Start” REG_DWORD entry and enter 3, then press OK. This puts GamingServicesNet to manual start mode rather than automatic start mode.
  2. Restart your computer. After the restart, the system should no longer try to startup Gaming Services (you can verify this in the system events log).
  3. Open the MS Store and finish the downloads of whatever updates were still pending. The downloads should work now. Wait for all updates to be completed.
  4. Launch MSFS. It should now startup and work properly.
1 Like

Hi,

does that mean your problem is solved now?
If not, send me a private message,with discord and teamviewer I nearly solved
all problems people have had.I do speak german as well.

Scott

1 Like

i am seeing the same issues today. something screwed up after the windows update…

The solution with the registry editor @QuickNiq wrote worked vor me.
Even the window says the gaming service is still installing, MSFS is launching again

I ended up giving up. This kind of dysfunction is unacceptable. To be able to enjoy a game, I spent 24 hours reinstalling my entire pc. It really is absurd.

2 Likes

same here… trying all solutions since last few hours…

1 Like

the idiocy of windows is it doesnt give user friendly message of why this thing failed… event logs are always cryptic error codes

1 Like

I deleted these two entries and it works! I can launch MSFS!!!

Thank you very much for your support!

I suffered the same issue this morning, so I was very happy to quickly find this very efficient fix ! Thanks much for your support !

Thank you HC4Lif3

it worked and FS2020 is starting finally.
Thank you for your help.

Thanks Scott. The issue is closed for me. The OP, however, seems to have given up (Unable to launch FS2020 ---> Store - #17 by Fly83130).

It doesn´t work for me. Does anybody have another idea?

1 Like

Thank you very much. This also helped me a lot.
But strange enough how such an error occurs all by a sudden.

Hello
I did the manipulation without success over fs 2020 for 2 days

1 Like