Undocking ATC with VSync HALVES fps (?)

Holy ■■■■ that worked!
This is what i tried following your hint:

1 Open ATC
2 Undock it and Move it to the second monitor, double click the window title to maximize ATC
3 Click on the ATC area and Alt+enter. ATC will go full screen on second monitor
4 Alt+enetr again

Now you get 60 FPS!

Absolute strange thing is that if you try to resize it to make it smaller… boom 30 FPS again.
Definetely a bug.

1 Like

Unfortunately, this did not work for me. Tried to follow your steps as closely as possible, but I’m still seeing halved framerates with an undocked window. I also tried restoring my Nvidia settings. I was looking forward to actually using the ATC panel on the second monitor for once too.

I’m also suffering a loss of 15 fps when I undock any window with vsync off.

The fix seemed plausible to me too. I’m rusty on Direct3D, but in D3D9 you need to reset the swap chains when there’s a window size event, and the events are handled differently if you’re doing a continuous resize where you wait until the window is done sizing before you reset everything, or just a one time size event like going to full screen. So it’s possible the one is coded wrong with the bug, and the other properly resets the swap chains for drawing in multiple windows.

Awesome! Glad it worked for you, too! Now we’re slowly getting somewhere!

BTW, if you resize the window before undocking, you can avoid the loss of frames again.

Hope Asobo is reading this and this helps them figure this one out!

Also try restarting the sim after “resetting” the toolbar windows.

Still a no go for me. The inconsistency in this game’s behavior from one user to the next is maddening. I just updated by drivers from 457.5something to the latest 465.89 so maybe that has something to do with it.

unfortunatley i’ve found out that it is only the fps counter showing 60. actually it is running @ 30 :frowning:

Really odd! How did you discover that? I actually considered maybe that’s what was going on, but I dismissed the idea because it seems so obviously better when it doesnt say 30fps. That’s actually how I first noticed something was different - the framerate didnt feel as high, and when I checked I saw it said 30.

I just caused it to fail again on purpose to test, and at least to my eye, it seems like the framerate counter is accurate. When it says 50fps with the ATC window undocked, it appears much smoother than when it says 30.

Not doubting what you’re saying, but maybe theres less microstutter or something?


neh, microstutter is ALWAYS there, there is nothing can be done for that.
I noticed that simply looking with more attention.
I can easly say if something is running 30 or 60 naked eye, i don’t need a counter to feel the difference. maybe it is because of my job, i can say if a movie is 29 or 45 fps. same for videogames.
So fraps was showing 60, but moving camera in cockpit was definetely NOT 60 to my eyes. so i checked with internal MSFS counter, and it says actually 30. fraps says 60, internal 30.
And internal is right.

Tried the posted fix and no change. Goes from 100% GPU usage to 60-70% when the act or pfd/mfd is opened.

Prior to the VR update, undocking panels / instruments had minimal impact on performance. You’d get a 3-5 fps hit from the first, and 1-2 for any subsequent window undocked. With the VR update, it would cause about a 10 fps hit for the first window, and 3-5 for any subsequent ones.

And it’s only gotten worse since.


same here. 10 fps lost also after resizing, alt+enter…

I wonder if this has something to do with Windows scaling…and whether the impact is lesser/greater if the 2nd monitor is of a different resolution if the pop out is then not resized in the resolution environment.

Aren’t there options in OS and GPU regarding where scaling happens?

I was really hoping this was going to be fixed with the graphics optimisations of SU 5, but no luck.

Don’t think it’s anything to do with different resolutions, I recently upgraded my main monitor from 1080 to 4K, running two other 1080 monitors and it does exactly the same thing before and after.

To get back the nearly 1/4 of the screen I lose to ATC I could sort of live with the 30fps if it was a smooth 30, but unfortunately it’s a janky, stuttery mess.