Update keeps restarting download

A few months ago an update came out that, when downloading, the progress will make it to some point, generally a large file such as pc-fs-base-bigfiles-01-101-fspackage, but then the update will restart and enter an indefinite loop. I have tried restarting it, uninstalling, reinstalling, deleting all local files, everything I can think of and I still cannot play the game months later. Looking online shows others having this issue and Microsoft basically ignoring them.
I would like to play the game I paid for however even through multiple major updates I cannot play the game.

Have you looked here?

I do not have any third party software or mods installed. I fully deleted all local files and reinstalled a few times and no luck

My sympathies for what they are worth. I hear you but then I’m a nobody.
But the whole download / install system is broken. It takes me 14 hours to download this thing on a 1gb fiber connection but at least it works to the extent that I can get 10fps and an unplayable stutter at the end of it.

Is there any fix on this, I get 4-20% and then it resets the download and enters the infinite loop.

Try

If you manage to get the download completed, shut down MSFS and reboot before reconnecting USB devices. Make sure you wait for them to initialize before attempting to restart MSFS.

It may not be this but may be worth a look

Brief description of the issue:

When trying to update the game, the update goes smoothly until it progresses to downloading the “fs-base-cgl-0.1.31.fspatch” file. Once it gets here, it keeps looping over and over again, attempting to download the file, but never does. This also means I cannot play the game.

Detail steps to reproduce the issue encountered:

  1. Start up game
  2. Attempt to update

Hi @Iceman41933,
I’ve moved your topic in Performance, Graphics & CTD as this category is also for installation issues.

Any solution for this yet? I have opened 4 tickets and no solution.

Hello,

I recently reinstalled Windows 10 and upgraded to a bigger MVNE hard drive. 2tb.

I re installed MS FS2020 from steam but the patch download keeps looping.

I’ve tried looking at msfs file folders and deleting the patch, steam files, etc. It keeps looping at a certain point.

This is actually not uncommon.
This is a link to an existing thread.

FYI, the moderators are a bit strict on posting in the Bugs & Issues section, as per the site rules, so you should search all the other sections of the forum that may pertain to your issue before you post here.
This section of the forum is for proven bugs that you can’t find a solution elsewhere on the forum.

So, having said that, give the above a try, if this solves it, please mark this thread as solved.
If it doesn’t just let us know.

2 Likes

Yea still nothing, gets stuck in the resting loop, 6 tickets now. ISP has checked everything and nothing it wrong, bypassed the router, still same issue. Not on my end and helpdesk is zero help.

Did you try this one?

I purchased it thru the MS store and not thru Steam so I don’t think that is an option for me.

No indeed, it isn’t.
The original poster had a steam application, I assumed you did as well.
Have you followed all the steps in the “Support” article on this issue?

yea a few times including uninstalling and re-installing

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.