Virtual Desktop issue

same here… do you run it from ms store ?

same here. i can’t get my oculus rift s or the valve index to be found by the game. any help out there?

I am using it just fine, I bought it in the store of the own Quest 2. Sometimes the button to activate VR does not appear, what I do is close the app and restart it again (without closing the game) and the button reapears in the main menu.

I think you also need to have Steam VR opened

You’ll need OpenXR installed and the registry key set to use whichever version you’re using - see the pinned getting started topic on these forums.

SteamVR was open. But the same error.

I connected the quest with Oculus link and then it all fine, but not on Virtual Desktop.
The OpenXr is also fine.

Use regedit, change the value of openXR ActiveRuntime* from the default path
( C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json )
C:\Program Files (x86)\Steam\steamapps\common\SteamVR\steamxr_win64.json

It works for me to play Flight Simulator vis Virtual desktop.


This works for me too, but I also have to first start FS in flat mode, then start VD on the Quest and open SteamVR, and after that, hit Ctrl-Tab in the FS to get it to work. Otherwise, I only get a gray screen in VR.

with steam vr I have 10 FPS Oculus link or virtual decktop are ok
With openXR i Have 30 FPS Oculus link is ok but virtual descktop NOT working

bonjour j’utilise un quest 2 oculus beta ok open xr ok regedit C: \ Program Files \ Oculus \ Support \ oculus-runtime \ oculus_openxr_64.json ok mais quand je veux lancer le fsx en vr rien ne se passe ???

Tout fonctionnait bien jusqu’au moment où j’ai installé open XR.
Je pense qu’il ne faut pas l’installer.
Il faut juste que configurer dans la base de registre.
Du coup je ne sais pas comment activer la reproduction

That worked great, thanks! And performance is much better wirelessly with VD than with a Link cable :joy:

I have a quest 2. With Link cable it works quite well.
I wanted to try the “Virtual Desktop”

I have purchased it and installed it on my Quest 2. Installed the Stream Progrramm on my PC.
Then I sideloaded and installed the Virtual Desktop VR Patch.

I can see my desktop now. But when I try to enable VR FS2020 says no headset detected.
I want to use it with Oculus XMR and not steam VR.

Is there something else I have to do?

@nils8107 Follow the procedures described by dtwang2007 and Windfisch81, 6 posts above yours. Is the same I follow and it works flawlessly.

Thank you. But do i really have to use SteamVR?

Today, yes. Because you can’t launch MSFS straight from library inside Virtual Desktop. But it’s better for the graphics, too. Oculus’ implementation of OpenXR is not doing well with this sim yet.

1 Like

Thank you. It works now. Still I have a lot of performance issues. have to figure out some settings.
With the Cable it was working much better.

1 Like

You probably know because you are doing your own research, but I recommend you to start with these threads:

1 Like

Please take a step back and share how to … "[quote=“dtwang2007, post:7, topic:338663”]
change the value of openXR ActiveRuntime* from the default path
( C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json )
[/quote] ". I don’t recognize openXR and don’t think I am running any programs made by them. Thank you!

Before you change the default path, you have to install the openXR runtime as below post: (I can’t post the link, please google it)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.