VR mode no longer works after the last update

I read in the update notes that you need to asign “reset position” (dont remember the acurate writing) to a button/key to be able to start VR :slight_smile:

Well, you are right but it is supposed to prompt you to assign a key to switch to VR if none of the commands are assigned.

Since the latest update VR is completely broken for me. It was working, jerkily, before the patch, but now in VR, the menu is fine, plan a flight, click fly, it just hangs on the Vive home screen, whilst displaying the supposed VR aerial view of the air field you are departing from (on screen, not in goggles) and after about 20 seconds crashes MSFS to desktop. Real shame as this could be an amazing sim if VR worked (preferably not stuttering every time you move your head).
For comparison, every other VR title I’ve tried, including DCS, plays in VR perfectly.

There’s really two issues I’ve listed here, right now I’d be happy if VR just worked as before… and yes a reset VR is assigned.

MS Store version of MSFS
RTX 2080Ti
Windows 10 Pro
Vive Cosmos Elite

1, Assign new VR toggle on, off switch

2, Steam, little VR button top right of page,
open vr. settings, Developer, currunt openXR runtime
windows mixed reality.

3, or set as openXR runtime.

It was crashing in openXR runtime for me
I have it at windows runtime and now
it doesn’t crash.

Good luck with the stuttering, unless you have
a 3090 card the only way to stop the stuttering
is turn everything down to min…

1 Like

Same problem here. VR doesn´t work. I created a new switch key: same result, only flickering an after 20 seconds CTD.
Any idea? Got a RTX 3070 and the 457.30 Nvidia driver installed
Please help

same problem - see my recent post:

I see what you’re saying, unfortunately my steam VR settings (under developer) only say steamVR as the current openXR runtime. I can’t find any way to change it to windows runtime. Tried setting up windows mixed reality but doesn’t seem to recognise Cosmos Elite, it’s set to steamVR with no option to change it :confused:

I have a HP reverb and my steam VR is like this.

Ahh that will be why then, the HP is a WMR compatible device, seems like the Vive Cosmos Elite is not.

How do you find the HP Reverb G2? I was thinking of changing to it but have heard mixed reviews of the tracking, although I do play most VR games sitting, and I have heard the Reverb is good for that. The Cosmos is very very ‘jumpy’ when moving my head in MSFS and I’ve tried all sorts to fix it to no avail and of course, now doesn’t work at all since update 3. It’s fine in every other software title I own though, Elite Dangerous, VTOL VR, DCS, all fine, which makes me wonder if the MSFS VR implementation was written with WMR in mind rather than Steam.

Guys I am facing the same issue, my Reverb G2 is no longer working after the latest patch (Steam Version).

Intel I9 9900k, Z390 Aorus Pro, MSI RTX 3090 Gaming Trio, 32G Corsair Dominator Platinum 32000Mhz, Samsung 970 evo plus 1Tb nvme

After I load a flight, as soon as I enable VR the game CTD with no error message.
The game works just fine when the VR is not enabled.
The reverb G2 works perfectly with any VR compatible title: DCS World, iRacing, and more then 30 games on steam I have tried so far!

Windows Event Log
Faulting application name: FlightSimulator.exe, version:, time stamp: 0x6040b612
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x6040b612
Exception code: 0x80000003
Fault offset: 0x0000000001a3f932
Faulting process id: 0x4e64
Faulting application start time: 0x01d71b7e55be560c
Faulting application path: E:\SteamLibrary\steamapps\common\Chucky\FlightSimulator.exe
Faulting module path: E:\SteamLibrary\steamapps\common\Chucky\FlightSimulator.exe
Report Id: 01113730-462e-4c70-a311-86eb948a3d35
Faulting package full name:
Faulting package-relative application ID:

What I have tried so far

  1. Disabled Overclock for CPU and GPU
  2. Reset Nvidia control panel to default settings
  3. Clean reinstall of the latest Nvidia driver 461.72
  4. Switched back to 457.30 (clean install)
  5. Deleted Community folder content
  6. Updated Windows 10
  7. Changed OpenXR from Windows Mixed Reality to Steam
  8. Connected Reverb G2 to different USB port
  9. Disabled power management for every USB port
  10. Reinstalled FS2020 from the scratch (Steam Version)

Remaining things to try
Reinstall Xplane :rofl:

This is weird. Technically, this is a break point exception.

There were some post before with people solving this with an enlarged virtual memory setting. Likely anecdotal, but still, it fixed it for them.

Thanks a lot for mentioning that, I couldn’t find that post.

Yes you’re right it looks like there is a break point somewhere in the code…

I am having a similar issue. VR was working perfectly for me till IDK this past Monday for me. Now when I switch to VR (either binded key or actually going into settings and switching) I glitch constantly between loading, split screen, and quickly in the pilot seat, just constant switching between the three. I have checked my openxr, it is still assigned to the Oculus 2, I have turned off stenciling in the oculus debug tool, HDR is off, tried all the steps but actually switching to VR is broken. VR works as it should when in the menus and setting up flight, just not at all after clicking ready to fly, just constant glitching between the loading, split screen (that I see in the googles) and pilot seat. My video card is the GeForce RTX 2060. Worked perfectly till about 3 days ago.

For me, this is more then anecdotal. If I set pagefile.sys to the fixed size MS-Windows recommends, I get crash popups of 0x80000003 kind. I have no VR. If I set pagefile.sys to the fixed size of my RAM, that is 16 GByte, I get no crash popups of 0x80000003 kind.

As always, you can believe or not.

Fortunately, I still have X-Plane installed where I do all my VR flying at the moment using my Quest 2 with absolutely no problems at all!

I have the same issue, I have seen several complaints of similar issues. No response from any one with a solution. Come on Asobo sort this.

Just make sure there are now windows from the to top bar open (ATC, VFR mal etc) when you switch to VR. Then it works fine.

Sorry I don’t follow quit what your referring too… I only have msfs open. And switch to vr from a cold dark cockpit.

I believe he is referring to having no extra MSFS2020 windows (docked or not) open than the standard pilot view. If you have any other windows like ATC or Map, then it will hang

Yes Correct