While flying in formation random friends disappear

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
nope
Are you using Developer Mode or made changes in it?
tested it using both dev mode and normal but made no chages, same results

Brief description of the issue:
As far as I know, the sim should render the closest 30 (I think) aircraft but after SU5 it seems like the aircraft randomly get Thanos Snapped out of existing. here is a formation fight the lead faded out for no determinate reason. I know 100% that it is not friends closing the sim or something like that, they just disappear. Also seen in the example video, the pilot to the right in blue still saw the lead the entire time

once the plane disappears, it will not show up again unless a wait for it to randomly pop up 10s of minutes later (on average) or I switch server regions back and forth.

The type of planes do not have any effect on this issue from what I can tell

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
it happens randomly but
Fly in formation on “all players” multiplayer (possibly in crowded airspace)
Wait, 5-20 minutes

PC specs for those who want to assist (if not entered in your profile)
5900x, 3090, 32 GB ram,1GB Fiber network (aka not a network issue)

Build Version # when you first started experiencing this issue:
Right after SU5

Are you on the Steam or Microsoft Store version?
Steam

Did you submit this to Zendesk? If so, what is your ticket #?
no

3 posts were merged into an existing topic: Multiplayer issues (players disappearing or not visible at all)

5 votes have been moved. A vote could not be moved because the user already voted in the other topic.