Why on earth I get 48-50 FPS in Xplane and hardly 20 in MSFS in VR mode?

Do you have any mods installed? The statement “I used to have 35 FPS and now I hardly run 20 with stutter” makes me believe mods are to blame, because the VR implementation didn’t change much, and got a little faster if anything.

Also, definitely try HAGS off, HAGS on has always resulted in a ■■■■■■■■ for me (3080Ti with G2)

But yes, Asobo must definitely work on their VR engine to improve performance.

1 Like

Thanks, I will try HAGS off tonight.

I have MODs like everybody else, but I was trying an MODded airport and a default one in another area and the results where the same. For planes I tried the CRJ700 and then I tried the default DA62, same results. I will try removing all of them but most of them are airports not used in the area that I was testing. The Stutters and bad performance started with the latest Hotfix hence my suspicious was about the pre-rendering option added to VR, but is just a clue.

The Xplane test was just to understand if there was something odd with WMR or OXR , cables , nvidia drivers or other hardware issues with the G2.

Did you check your CPU usage per core, and not the average value which mean nothing?

E.g. you can see 30% CPU global usage, but in reality one or several of your core are running high or are maximized at 100%, when other are idle or less used. It mean CPU bottleneck, and can explain your lower GPU usage as CPU can’t feed your GPU quick enough.

Ok, here are some results with HAGS OFF. All settings in ULTRA, LOD 200 with V-Sync at 60hz. I can see the GPU and CPU underutilize. 50ish FPS in 2D with micro-Stutters. VR similar CPU/GPU utilization but with 17-19 FPS with more stutters.

My machine is not even warming up with these figures.

1 Like

What fps are you expecting fully maxed out in all your settings ?
What settings are you using in wmr ?

Hi, setings OpenXr render scale 200, motion reprojection=disabled, MSFS VR rendering= 50

Looks like the effect i also had. Try this:

Or start VR before the flight completely has loaded, so you see the loading screen in VR. Then you perhaps do not have to do what is mentioned in this post.

and change pre-rendered frames to 1:

Both helped me a lot.
It also could be that you have perhaps dialed in a too high resolution in MSFS, try lowering it in the inGame Render Resolution to lower %. There must be a bug somewhere (or connected to the pre-rendered frames) that if you reach 100% GPU usage, it sometimes breaks down and does not recover for itself. If this happens you can only dial down inGame Resolution, press Ctrl-Alt-Del and immediately after getting a black vr screen pressing ESC. Then it can recover. But after i changed to only 1 pre-rendered Frame i had to do this not very often again.

“OpenXr render scale 200, motion reprojection=disabled, MSFS VR rendering= 50”

I keep reading about this, will try it tomorrow

Because xplane looks like it’s from 2004


And I get 2000 FPS in Pac Man with today’s hardware. Like I said, it must be much better optimized :kissing_heart:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.