XBOX - Balkan Bush Trip Leg 15 LGNX not completing

I received the Sim update update yesterday to fix Balkan Leg 12 so that it completes. Completed legs 13 and 14 with no issues. I landed at LGNX (Leg 15) and nothing happened. I tried coming to a complete stop in various places on and around the runway and airport still nothing happened. I even restarted the leg and tried again …nothing happened after landing. I also submitted a ticket through report a problem app, but haven’t seen any other complaints about it, so now I’m wondering if its just me having the issue.

Anyone else having this issue?

Are you using Developer Mode or made changes in it? - No
Build Version # when you first started experiencing this issue: -

Yes - completed Leg 12 after the update fixed Missolonghi airport.

Finished Leg 14 - the longest leg at 56mins - landed at Syros Island Airport only to have no finish trigger activated. Tried stopping up and down the entire runway as well as in parking - nothing

Very frustrating to waste an hour - would do it again if there was any way of knowing that it will work.


I can’t finish leg 13. Same as like I had on 12. I’m sitting on the runway and nothing. Ive watched videos, I’m in the right spot, so frustrating.

Please all come to this thread and vote:
SU5/SU6 and Bush Trips - Bugs & Issues / Online Services & Activities - Microsoft Flight Simulator Forums

Did you solve? since update i cannot complete any legs anymore.

Yes same here. I’ve done it twice now and no luck both times. Did the same as you and parked all over the place, but never could get a completed page.

no, I’m hoping the fix gets included with the next update!