Xbox Series X- HOTAS One Issues

Can confirm that their listed workaround works. When you go to select the input for an action, click on the button that it has mapped instead of the drop down(recommend using a mouse for this), and then just press the actual button on the Hotas One that you want to map the action to. The button it says you pressed will be incorrect, but just ignore that. The button will work as intended.
Some buttons may be need to be manually unmapped from other commands though, or else it will do both commands.

2 Likes

Anyone know what is “Left Joystick Axis 5” ? on the Hotas? It’s supposed to be to trim the plane.
I don’t know how to trim the plane.

This is my problem too, but being a neophyte to this world, I have no idea what “if you make an assignment through scanning it will be accurate” means.

I’d be v grateful to learn how to ‘make an assignment through scanning’.

I’m watching youtubers go through assignments on peripherals without profiles, but I’m assuming that involves using the drop-downs which is, in this case, not gonna work.

Help please. I wanna fly! (with the HOTAS). bd.

I’m having the same issues. I tried the workaround with several of the buttons as well as the elevator, ailerons and rudder but none of these functions worked at all.

Instead of a work around how about they just fix it??

Will they fix it ??

1 Like

Should be the rocker on the back of the throttle

2 Likes

When you assign a button it give you two options. Scanning is the top one, which basically means it sits and waits (scanning) for your next your button presses to see which one you want to assign. The other option is to select the buttons from the drop down, which is the one Asobo are saying you should avoid ofr now.

I was having the same issues as everyone else, miss matched buttons etc, I figured the work around by myself but it was confusing to say the least, thought a firmware update on the Hotas might help but havnt got around to it.

One thing that helped me was to go into free flight, take off and get some altitude then live pause the game.
You’ll find it in the menu section, just make sure your filter is set from ‘assigned’ to all, that will enable you to scroll down and find it.

I bound the Y+Trigger button on the throttle and stick, that gives me flexibility to jump in and out of the controller bindings without worrying about flying, I’ve adjusted all the sensitivitys to half, and a dead zone of 5, among many others such as the smart Cam, next and previous etc.

If I find some useful binds I’ll post then up.

Exactly the same issues here, glad my stick isn’t faulty.
I tried making a new profile from scratch and using the scanning feature for assigning buttons but I’m really struggling to work it out. All I really want is the normal controls, flaps, trim and hat switch camera to work, nothing fancy but can’t work it out.
I was excited to get home and give MSFS ago, but give up for now and gone to bed.

The trouble is, if another command is mapped to that button you don’t really know because it thinks half of the buttons are the same!
I tried from scratch but there were so many command choices even when setting the filter to essentials that I got lost and gave up for now.
If you have any success mapping yours I’d love to know which commands you mapped to what.

I’d definitely appreciate it, if you could post your bindings. I’m new to flight sims and found the millions of options (especially for the camera) to be totally confusing.

Having issues too. It’s almost like the hotas and the controller are fighting or conflicting with one another.

For example, when I press ‘select’ on the hotas (the button with the three horizontal lines), it pauses and brings up the menu. When I press it again it does nothing - I have to press the same button on the controller for it to work.

I also have a mouse attached which which works to move the arrow around the screen, but neither button works at all? :thinking:

All in all, a bit of a mess. All I really would like is the ability to map the rudder away from the stick and onto the rocker on the back of the throttle, and move trim up and down onto B3 and B4 next to that. Then ideally to have a smooth free look (like right stick on controller) mapped to the hat switch (for example Elite Dangerous uses a combo of hold B1 and move the hat switch around.

Sure I’ll get there eventually, but at present I an well and truly bamboozled…

2 Likes

Is there an option to essentially start with a blank canvas on it with nothing mapped at all to avoid having 2 commands mapped to the same button?

3 Likes

Huddison on YouTube is hoping to do a video soon on the HOTAS One. I’ll try to post a link when he does, he did do a video for the xbox controller a bit earlier today if anyone wants to check that out. Highly recommend.

2 Likes

I thought I was doing something wrong or loosing my mind as the photo showing the button layout on the thrustmaster hotas didn’t seem to match the usage either. But this is all good news that there may be a fix or update for it.

Thrustmaster just posted the following on their Twitter feed.

2 Likes

Here’s the new graphic showing the default mapping

7 Likes

A fix is what we all need, I can map things but it’s mess to get there. The hat switch is only registering 4 ways, elites head look was alright but still clunky. In msfs its even more defined, up down left right. I think its hardware limitations to be honest.

Default binds for me are;

In cockpit mode it gives me; return to pilot view, landing cockpit view, instrument next & previous and 90* look left and right.

In external mode it gives me; left, right, above, Infront and returns to centre to the rear view looking forward.

It’s not perfect, not smooth like the analogue thumbstick, but it’s enough for quickly managing systems and views.

I know alot more viewing angles and zooms can be bound but opted for paring the Hotas in conjunction with the mouse and keyboard. Then you have full fluid control of the camera and ability to navigate the rest of the systems etc with ease. I just don’t use the standard xbox Controller and its working well.

Don’t forget you can bind multiple buttons together, If I hold Y on the throttle it enables the hat 4 new functions, the same goes for almost any other button. I’ll play with this more over the next few sessions.

Obviously saving a profile per Aircraft is the best option so you don’t need to bind functions that are not operating on you current plane. I’ve been using the 152 and its pretty smooth with the simple default binds with only a handful more added.

A big improvement for me was to tune all the axis sensitivities down to 50, and added a little dead zone of 5 as I noticed that when I used the twist to controll rudder I wasn’t always just twisting, or visa versa with yaw.

Hope you find it to be working for you soon.

One last thing, I turned off all assists as far as the plane and systems were concerned that way I had a true representation of the plane and not the ai controlling or adjusting somthing without my input.

Oops I didn’t realise I posted twice, almost the same stuff. Oh well.

3 Likes

Hopefully they get a fix out there soon. I have the same issues, its confusing to say the least and a shame after buying the HOTAS one.

1 Like

It is embarrassing, it is embarrassing for Microsoft that did not check how the only hotas xbox peripheral work with its killer app for Xbox, it is embarrassing for asobo that seem never tried to use it with sim, embarrassing for thrustmaster that post a news saying that the fix is not so immediate, and the workaround doesn’t work so good.

5 Likes