Xbox Series X- HOTAS One Issues

Thanks for this!

Dennis mate I did the exact thing myself, without realizing it too. Delete all your Hotas profiles. Then I turned off the console and loaded it with just the controller, then turned off controller, the finally plugged in the Hotas again. It had to show a prompt ‘new device detected’ prompt before it would show the ‘default’ profile, once I clicked default it loaded the default binds into the controller settings page. If I just plugged it in during an old session it would load an empty profile.

1 Like

That’s unfortunate man, try a local thrift or trading shop for an old wireless 360 controller, back then I remember seeing tones of them connected to controllers.

Thanks v much Drakau for your response. I ended up working that out, but weirdly a lot of the inputs i made - with different buttons/axes - came up as multiples of the same named button - lots of B1s, etc.
THe only axis that showed up as such was the thrust axis on the HOTAS but it was the elevator axis on the settings.
I entered all these changes with the XBox controller - and then when i completed the process - neither HOTAS nor controller worked!
I think I’m just going to have to wait until Thrustmaster has worked out a fix and just stick with the controller for the time being.
Not optimal, but at least i get to see some cool graphics.
Thanks again for taking the time to reply. Much appreciated.
K.

Thank you. Got it back. God, I´m stupid :slight_smile:

I‘m facing the same issues with the Joystick. It is almost impossible to do a custom assignment of keys… On top of that I do have a problem with my mouse sometimes. I can see and move the cursor over the screen but none of the mouse buttons is working. It works perfectly in other games though and I also tried another mouse… Sometimes a reboot of the console helps sometimes it doesn‘t. Does anyone have a solution for this?

Hi all,

Rather than try to remap the mess that is the Hotas support, right now…I’ve accepted the current default.
Is anyone else having trouble saving the sensitivity settings too? The ‘Reactivity’ setting in particular just will not save and reverts back… Making the flying experience a horrid, twitchy mess. Indeed the other settings revert too at random.
I’m so disappointed to have purchased the Hotas and discovered the state it’s in on the Flight Sim side of things. Microsoft need to sort this, given they made such a fuss about how it was supported leading up to the release.

3 Likes

The sensitivity settings won’t save for me either. What I’ve ended up doing each time I load up is change the sensitivity settings on the 3 axis controls used by the stick to -70 (do that for both directions per axis) with a dead zone of 10. Seems to give less twitch and it feels as though you are making the moves if that makes sense? Not sure if -70 is fully needed, but it feels right for me.

Haven’t had much luck with the trim sensitivity though as it seems to bounce around, unless that’s what it’s supposed to do on “Hard” settings? Almost as if it goes to +1 and then -1, never settles on 0.

2 Likes

It’s so frustrating, Birdchrash. Microsoft made such a histrionic fuss about the Hotas being a promoted/supported peripheral then seemingly neglected to test it! I mean, really??! It’s a bit comical. And yet, a Youtuber (who works with MS) with a preview copy of MSFS was warning of this issue several days ago.
It was an effort even getting the Hotas, given the shortage of these kind of peripherals in recent months. I Booked precious days off work to enjoy the launch with my new flight-stick.
I fail to accept that this is nothing more than a minimal effort to have (hot) fixed it by now for such a behemoth of a company, and it’s just basic fundamentals that they should’ve had this sorted before launch, if not avoided this blunder in the first place.
I really can’t be bothered with settings that don’t save, and the ‘Reactivity’ part doesn’t even work at all, not even for a session. It’s just not worth the constant effort because my down-time is so limited.
I’ve no more time to invest in this until it’s fixed. It’s a bit of a joke tbh. Embarrassing.

4 Likes

I have same issues.

3 Likes

My thrustmaster just came in today and I discovered this problem and now I’m on this page with you guys. hopefully there is a fix soon. Disappointed to have discovered this.

2 Likes

Feels like i have a useless joystick at the moment and very disappointed they have yet to put out a hotfix given this is supposedly ‘supported’ by Microsoft. At least give us updates on what is happening.

1 Like

This does work to a degree. I saved a copy of the default map to start with and then worked through the functions/buttons by clearing the inputs then scanning for the new input and validating each one. Although you cannot use all the buttons anyway as several of them scan as the same inputs giving you various conflicts anyway!
It was interesting using the scanning function to see what input was actually recorded for a particular labelled button - only 2 or 3 i think were correct!
We desperately need Thrustmaster and FlightSim to resolve this asap.

2 Likes

Well got my Hotas One today. Glad I did not buy a more expensive one :slight_smile:
I would have thought that since Microsoft has taken SOOOOOO LOOOONG to deliver MS Flight Simulator for XBox they would have taken the time to make sure key peripherals worked.
You now all of us had to buy (not easy) a series x and MS Flight Simulator and the HOTAS.
That is close to a $1000 investment.
World realistic graphics are not that realistic or accurate.
The contols suck (twitching all over the place) with controller or HOTAS.
I have had every version of FS and even the initial Apple Version from BAO and I think there was a rudimentary one for the ZX81.
Ah well we will see what improvements they can make
Good luck everyone.
Will stay tuned

1 Like

Same problem for me, annoying as hell

1 Like

Does anyone have a decent mapping to use for Hotas on XB?

1 Like

Finally got it worling on xbox series x but man what a mess, buttons are not labeled correctly and certain buttons get recognized as the same button. Giant mess but got it working.

1 Like

Any tips or advice?

1 Like

start with the default and look how the keys are labeled, then change them 1 by one to what you want.

1 Like

Honestly I think we just have to live with the default mapping with the errors for a week or two until they can fix it. Two weeks out of the intended nine year life for the game isn’t that bad, annoying though it is not to have the HOTAS One work perfectly from the start.

1 Like