1.12.18.0 - Certain Aircraft Require Throttle 1 instead of Throttle Axis

Tip for developers

Hi, I have just purchased the Just Flight T1 Hawk. It has no working throttle !!! I use Saitek Cyborg 3D Throttle, on all default MSFS aircraft, and no issues with those. However with the new Just Flight Hawk the throttle does not work at all. I cannot change the throttle to any other options. I can use F2 and F3 for thrust as a work around but wondered if anyone else has this issue with Cyborg 3D ? (I do not have a Throttle 1 to change to. It just says Throttle x-axis which it picks up with the scan on the Controls menu) .

You have to select Throttle 1 axis is the MSFS control binding menu.

Isnt it fortunate that this throttle axis problem doesnt effect Asobo aircraft?
Is this how it will now be, using the F3&F4 keys to control throttlefor some third party aircraft from now on?

It actually affected the TBM 930.

Can you post some shots to clarify what you mean ? I dont have anything called Throttle 1. (the throttle gets detected as Joystick slider x)


Ive attached my USB profile. As I said it works fine on all the default aircraft.

At bottom left, change" assigned" to “all” and you’ll have the choice for differents throtlle axis (and many others choices too, it’s always a good idea to set it to “all”)

great thanks. works fine on the Hawk now. Didnt realise so many hidden fields on there. :slight_smile: The only other issue I have is a problem with the FBW Airbus reverse thrust. If I put throttle to idle, it goes to reverse thrust, instead of zero percent.;
Will see if I can fix that now too.

Hadn’t tried many aircraft, before changing my throttle to Throttle axis 1, but the JustFlight Hawk T1 was the one I noticed the issue on.

1 Like

havent flown the TBM930 for a while. Asobo messing up there own aircraft, clever

I’m glad you said that, I thought I was going crazy. Most other aircraft seemed to work ok but I couldn’t get the throttle to work on the Hawk. Thanks! :slight_smile:

Thanks to the Community Management, this bug has been logged with the Dev Team (see tags beneath title). Thanks to everyone for contributing!

3 Likes

Great thread casual click , hopefully this self imposed problem will get sorted soon, or details on refunds for aircraft the first fudgedate of 2022 messed up

I seem not to be able to upvote, but yes, the same issue here. It also seems to have affected the possibility for me to toggle reverse thrust as well on the TCA Airbus stick.

Ok, so I’ve finally run into this.

All the aircraft I’ve flown up to the Grumman G-44A have worked as before.

I’ve got a Thrustmaster Hotas One. I’ve mapped the Throttle 1, 2, 3 & 4 axis to the throttle.

On the G-44A, I cannot get throttle one to move and throttle two will only operate on the forward 50% of throttle’s travel.

I’ve tried reverse axis on/off to no avail.

Anyone have any input on getting this to work?

My TBM930 hotas throttle works fine, five other aircraft don’t all third party

This issue has just appeared after the latest update (reverse throttle fixed). Dual engines do not function properly. TBM 930 never gets out of idle and will reverse on full throttle. F35 throttle does not operate at all. Tried resetting and calibrating and nothing seems to work.
X56 Logitech Hotas

YES - its Frustrating

1 Like

Same problem here. Assigned all 4 throttles to same joystick Axis control so it works for multi-engined aircraft also.

Well done indiafoxtecho for updating there MB 339 giving back control of the throttle on thrustmater hotas.