While everyone is updating to, I got a notification today about update which I already had. So it forced me to update and now nothing works. Cannot even select an airport to fly. Fly button is not active. Nothing works. Why is this happening? Why didn’t I get the latest update?

Same thing. Crazy update, 3.13 GB, then CTD, restart, another update, 1.49 GB. Now nothing works, no fly zone…

Using the ‘repair’ function on the app (add ror remove programs - advanced) fixed it for me

1 Like

First download was from Microsoft store. That broke the sim. I downloaded again from Xbox and now it’s working.

This evening there was an update with about 1 Gigabytes. Since the update my flight simulator is not starting anymore; I can launch the program and go into the main menu but whenever I start a flight the loading bar is going to 3/4 progress and suddenly the iconic flight sim main menu music stops, everything freezes and it crashes back to desktop without any further error message.

Are there any recommendations what I should do? First I thought it was a problem with the newest updated Fly by Wire Airbus compatibility patch for my A321 and A330-200 freighter fleet, but even with complete empty community folder it does not function anymore.

Log in to your xbox and see if you can update from there.
Also try “repair” from add and remove program from control panel.

Ah exquisit now it works again!

It refused to start because it consisted of two updates - one is updated without the running sim with XBox, and the second one is installed in-game after switching on online functionality with the contend manager.
In the options all online functionality of the flight simulator must be switched “on” (my internet is too slow to have photogrammetry and Bing textures on, therefore I have switched all online functionality off most of the time.)

Soon the night flight will continue…


Thank you, this was the only thing that finally fixed it (and allowed the store to find the update)

I got an update through the sim last night about 8pm UK time. About 4GB After that, the sim would load but the ‘Fly’ button never became active.

This morning I loaded the sim and it told me that there was a mandatory 1GB patch through Windows Store. I downloaded this

Upon launching the sim I got notification that the patch had to be downloaded.

I think this was the same patch that initially downloaded last night, it’s the same size. My guess is that MS/Adobo messed up somewhere with the update rollout.

I wish they would be a bit more transparent about these things. Anyhow is now downloading. Fingers crossed. I’ll report back…