1-2 FPS - Game has Broken!

Hey Guys, I am hoping someone can help!

Baically MS Flight Simulator has completely broken. I have:

Intel i910900KF
Nvidia RTX3070
16gb of RAM

I have been playing totally fine for the last week with it on high graphics settings. Beautifully smooth. Then on Thursday I started it up and it’s completely broken. When I load into the world the frame rates are so bad that I literally cannot do anything. (Like 1-2fps). Even going into the menu’s takes forever and is a challenge. I have tried lowering the graphics settings to “Low” and still get the problem.

Basically the game is completely broken, and I dont know why. :frowning:

Please help!

Graphic’s Card’s can Fail so i would start by Checking that first.
Good Luck and we hope that you’re Up and Flying again soon.

HI there Wristy,

Thanks for the reply. When you say Graphics Card’s can fail, do you mean for the game or entirely? It’s only about 2 weeks old, so I certainly hope not.

Also, other games I play work perfectly fine. And when I go into Nvidia control panel it doesn’t report any issues.

Or is there something else I should be looking for?

Have you:-

  • added/updated any mods/liveries to the community folder
  • downloaded/installed new graphics drivers
  • updated windows
  • changed any graphics or traffic settings
  • noticed any possible broadband reliability or speed issues
  • started flying a new aircraft
  • switched to flying out of or into an airport you’ve not previously used
  • made any other changes that I might have forgotten to list.

since the sim worked?

Computers can be very irritating, but barring a hardware failure, they don’t normally change how they work without something changing or something being changed somewhere.

I’ve struggled to remember such changes easily previously, but it’s worth trying as finding something that has changed will certainly help to figure out and reverse the issue.

1 Like

If HawkMoth’s Remedy’s don’t fix the Issue you may have to Restore your PC which will only be possible if there is a recent Restore Point of course.

ps. Your new Graphic’s Card is unlikely to be the cause of the issue but just check the Status in the Device Manager.

pps, If this is a new PC your friendly Provider will surely Give Support and get you sorted.

Thanks again. :slight_smile:

So to try and answer your questions.

  • added/updated any mods/liveries to the community folder - No. Haven’t changed anything
  • downloaded/installed new graphics drivers - Ah, the only one I did add was the Nvidea official one (been using the Motherboard one up till now)
  • updated windows - No
  • changed any graphics or traffic settings - No
  • noticed any possible broadband reliability or speed issues - Not unusual. Living in Australia we do have our challenged, but it’s usual.
  • started flying a new aircraft - No
  • switched to flying out of or into an airport you’ve not previously used - No
  • made any other changes that I might have forgotten to list. - Probably the only things that may have been unusual would have been to update to the latest patch released (cannot remember the one) and to download and install some more of the official content (planes / airports / scenarios).

As for restoring computer, am unable to do that. Maybe thinking that I have to reinstall MS Flight Simulator… Which is a pain in the backside…

When everything’s Up and Running again make sure to Create a Restore Point.
So sorry we couldn’t assist you.

Regards from Thom.

That might appear to narrow things down a bit, to the Graphics driver. Whether it might explain the whole of your issue is another question, but if you search the forum for things like “new nvidia driver”, you will see that people have been experiencing some issues with the latest drivers on their RTX cards.

Maybe check out some of those threads to see if the issues sound familiar and if they do, then maybe revert to a suggested earlier driver and try the sim again. You could always put back the newer driver if it doesn’t solve or improve your issue.

I’d do a clean install by the way, via the check-box on the custom installation option.

1 Like

Some Nvidia owners are reporting their settings were recently reset without their active permission or action. Not sure if it was due to an automated driver update, or something else, but it knocked out people’s custom settings which were driving their high FPS rates.

Geforce Experience will do that, unless you stop it trying to optimise new programs, but that might not be the only way for Nvidia settings to be amended without the user doing the amendment.

It was messing with my anti-aliasing setting until i clipped its wings.

Check your nvidia driver version, some users experienced that the new driver is bad performing or even CDT. Go back to an older verion and also disable the auto installation and update function in your geforce graphics card settings. I’m using 457.30 on my 2070 RTX Super OC, because I had problems with 461.09 and 461.40. Regards Guido

1 Like

Yes, this will cure your issue.
Change your VM page file from system managed to a custom size.
Select 1.5 times your ram size in MB as the minimum, so you should use 24000 MB, use 3 times for your maximum (48000 MB).
I actually went to 4 times.

Thanks for all your help guys. I have actually deleted the Nvidia GeForce Experience and just using the one that came with the GPU.

I have also changed the VM Page file like you guys suggested.

Unfortunately even though I am only using 10% CPU, 30% GPU and 70% RAM, even on low settings the game is still running at like 1-2 frames per second. It makes me think that there must be a problem with the game itself. I dont have any issues at all with any other games I have tried (tried like 7 other games) or programs. It’s only MS Flight Simulator. I guess the only thing left to do is delete it and reinstall it. :frowning:

Considering it literally took me days to install, this is less than ideal.

1 Like

And that probably won’t help.
Your settings are kept in the cloud, and are restored with a new installation.
If this isn’t VM (which surprises me as this is a current issue with MSFS simconnect and smaller rigs.

  • Remove everything from the community folder. (just rename it, MSFS will make a new one if you have a lot there).
    In the sim settings, empty your rolling cache, and if you made a manual cache empty that as well.
    Let’s get the externals eliminated first.

Try the sim.

Not sure why this is labeled as a voting thread?

My guess is you have a bad mod in community folder and/or trying deleting your rolling cache.

If it were a problem with the actual game, I’d suspect way more people would have this issue, but not seeing that at least in the forums.

Hope you get it resolved.

Yes, good point, the thread probably should be in another location in the forum.

1 Like

Sorry about the thread. If I could change it I would (unless you know a way?).

Sorry also for being a complete newbie.

I have deleted cache, and I have renamed the community folder. Still no chance. :frowning: :cry:

EDIT: I will note also that every time I try to then go back to the main menu from the flight the game freezes and I have to cntrl-alt-delete to close it.

1 Like

What is your Internet Connection Status ? Any Changes there ?

Ah no. Running a solid 25-30mbps download and 15mbps upload. So usual (and good for this area).

I will also note that I have turned off all the online updating of weather etc just in case that was an issue. :slight_smile: