10FPS with RTX 3080 in VR with Reverb G2. Solutions?

Not sure what’s going…one thing thought is you don’t need steamvr with the G2. Just run WMR.

1 Like

I tried both ways, several times. With SteamVR I get flicker and blue screens. Seems like 10 FPS too, in the glimpses of the sim. With WMR I just get 10fps… Trying older drivers now…

I have a 3080 and last 2 days have been a nightmare… But I finally have found solutions for me… Thanks to tons of threads from other people, and my work arounds tyring to figure this out.

I’m now running at about 56 FPS average (using FPSVR).
Make sure that your SS (super sampling in SteamBetaVR settings is set lower than your In game Scaler Setting in VR settings… In my case I have SS for both Default AND Custom Resolution Slider For MSFS set to 88% (YES!!) and in Game I have the VR settings for Render Scaling to 120…

You have to mess around with these to get it right… But you want your SS lower than the Render Scaling in game…

Also make sure your running at 120 Refresh rate for the Index!! Because if you run at 90 or lower… there is no way in hell your going to get 90FPS out of this game… In that case your Refresh rate is getting cut in Half by VR (its how it works) so now your limited to max of 40 FPS… Which is terrible. If your running at 120… You can’t even possibly run at that level in a billion years… but 120/2 is 60… So thats 60 FPS MAX… which is a lot better than 40!! And the 3080 can do it!!

My last tip… Is that most of the In Game Settings for VR can be changed on the spot while playing!! So you can dial in the rest of those settings while flying… You can even just start on Low for everything and work your way up!! You can even change your refresh rate if you can manage to alt tab to your SteamVr settings window… (I can’t).

Also a program like FPSVR is like essential!! Because it not only tells you your Actual FPS and the average… But it breaks down you GPU % and info and your CPU % And info. And reading off that can help you see when you make a change the effect it has on your CPU and GPU… I am now maxing out about 80% CPU usage and 80% GPU usage… (GPU is bottlenecked because of CPU)

3 Likes

I got the SteamVR working, and I went in the same direction. Not entirely successful but half-way there maybe. Master slider on 100%, game-specific at 50% (!) and in-game render scaling at 100 got me somewat playable ~20-25 FPS in a Cessna around KJFK/Manhattan. However if I force reprojection I have terrible jumps in my picture, plus artifacts, and if I force it off, it’s not smooth. Even when FPS feels smooth thera are frequent stutters that kill all joy and make me carsick. I’m very tolerant for VR sickness and can play for hours standing (Skyrim VR or Alyx), but when it stutters - it’s a vomit comet.

Reverb G2 has a higher resolution than Index, and max 90Hz refresh, so 120 is not an option. There must be a better way, otherwise pwople wouldn’t be enjoying VR…

Also tried older drivers, and all optimization from recommended posts. It got me from 10 FPS to maybe 20-25 but jumpy and stuttery. SteamVR has many stutters but higher FPS (20+), while WMR is still unplayable.

Also note… That I can only get the 172, 152, and smaller aircraft (basically the ones without massive glass cockpits) to run at anything acceptable… Which is devestating… Because I love the Cj4… And I tried and tried to get that running as good as the 172… But the dam thing just wants to run in Sub 30s to mid 20s most the time…

Running the 172 is fun though… But I need my Cj4.

Hello
What is the SteamBetaVR you are reffering to ?
I have a vive pro and I use steamVR to play. Is there Something to see with openXR ?

I also have a RTX 3080 and this is what worked for me. The resolution slider in the VR options in MSFS has the largest impact on FPS. I would start there. First Try setting the VR options to Default and then sliding the resolution down to 70%.
Also if you are using SteamVR then the Open XR developer tool settings will not do anything since that is for WMR only. You will need to use the StreamVR settings to set your supersampling rate. Set it to 80% global and game specific at first to see if that has an effect. I would also turn oFf SteamVR version of motion reprojection so you can see what your actual FPS is in game before playing with motion repro. You will need to adjust the steam SS slider before launching the game. don’t open steam VR or WMR portal before launching the Sim. Flight simulator will launch what it needs automatically when you enter VR mode (ctrl-tab).
I also purchased the excellent FPSVR app from the steam store. This is a must have IMO for benchmarking in VR. Good luck!

1 Like

Thanks. I adjusted SteamVR SS with MSFS open. Will try prior the game.

I also have a quest2 and it can run pretty smooth and pretty awfull. I discovered that the sequence you start vr makes a big difference. Dont go in vr when you are already in the plane, you ll get a slide show. Make sure your quest link is connected first next start fs2020 the moment you get the fs2020 dashboard to setup the flight options etc go to vr using the keys you assigned. Then you setup your flight and wait until you enter the cockpit. If i do it in this order i get decent framerates. My problem is that I get a quest link disconnect at random times if that happens and i want to reenter vr the pc becomes terribly slow. I have to stop fs2020 and restart the pc as i have the impression vr suffers memory leak or something. This is how I discovered vr startup sequence makes a difference, especially with quest link. I have an i7 k8700 running at 4,9ghz and rtx 2080 32gb ddr4 ram 3000, fs2020 ms store version

I’ve posted a link to “My VR Settings - Index” above, and I’m preparing the article for “My VR Settings - G2” soon. In the meantime, I’ve tried capturing what I do get with the G2 which you might find interesting:

Smooth A320 low level flight over photogrammetry - Through the lens video with the G2 (9700K + 2070S)

Just saw this. I would be so happy if I could reach this smoothness on my 3080 / 3700X / 64Gb RAM. I’m not sue what’s causing all this stuttering mess I’m having. I followed several sets of guidelines, including yours, tried WMR OpenXR and SteamVR OXR and 50% scaling 100% TAA and still it was bad… I’d love to have this smoothness.

Do this first. Go to your Nvidia control panel and set it to default and if you have an option change individual settings for performance or application controlled. set the OpenXR dev tools slider for to 70%, turn off reprojection. Set the ingame VR settings to default. I did this and have very acceptable clarity and framerates. From here you can try turning on/up various options in the VR settings in MSFS. Most of the options can be seen instantly once you hit apply. If you have the devmode FPS counter turned on you can see how it is affecting performance. You will have to look at the counter on the 2D monitor since its not fully visible in the HMD. You can also note if the sim is CPU or GPU bound.

1 Like

Just FYI, when I’ve been hopping in these forums over the last few days, I don’t just start scrolling through the VR section…instead I go right to your profile and look at your activity to get an idea of what I’ve missed.

1 Like

Exactly same story on my side. Pretty much your config except I have 9700k and 2080s. Like you said it’s about this sequence and later on it might randomly disconnect the link and go to 10fps. Though I found after reconnecting without leaving a flight it goes back to good fps (around 35-40 with my settings). Took me several on/ff vr mode within game, I still couldn’t track the reason or good work around. I’m just blaming the link itself. Though I do run it with official facebook overpriced peace of type c wire…

Hi, same here I have a 2080 super. Just reconnecting does not work, it reconnects but with a much worse framerate. A trick that seems to help is exiting VR in FS2020 (without leaving the flight) killing the OVRServer_x64.exe process next reestablish ocolus link and re-enter VR in FS2020, framerates are again ok…until the next link disconnect. I don’t know if its a hardware problem (usb-c), driver problem or wire problem (official link cable), but it happens radomly, not only FS also other programs fail sometimes after a few minutes, sometimes over 1 hour. Just switched from Rift CV1 to Quest 2, although Rift resolution is not that great I never had any issues with stability. Really asking myself if i should keep the quest, it’s brand new but very unstable.

Same thoughts, I think it’s a software issues related to the way they compress and transfer image though the link. Cause I found same complains going half year back where people see same problems in Alyx or project cars (like heave graphic games on PC). There is one solution being offered to assign high priority to OVRServer_x64.exe in your processes. Didn’t work for me.
I’ll probably return my quest if not find a solution to that. Otherwise when it works it’s pretty nice picture and 30 fps seems to be smooth enough on my end.

Hi maybe it’s a good thing to share what you’ve tried so far, so we can eliminate things that don’t work.
This is my list, so far no success with these actions below:
-Make sure the cable is properly connected in HMD - and computer (my graphic card)
-Add a tape over the HMD sensor inside to keep it alive all time
-Power Setting in Quest 2 not to go to sleep after 4 hours
-Kill + restart OVRserver_x64.exe
-set Priority realtime on OVRserver_x64.exe
-Bios disable USB legacy
-Windows EnergyPower settings - maximum performance + USB sleep disabled
-Set Power setings mandatory with group policy / regkey
Specify Default Active Power Plan in Windows 10 | Tutorials (tenforums.com)
-moving my head all the time :slight_smile: (to make sure the quest thinks the HMD is used intensively)
-same with the sticks (as you don’t use them in FS maybe the HMD thinks there’s no activity)

Some observations:
when having the disconnect I always noticed this entry in eventvwr:
Usermodpowerservice (event id 12) Proces C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe (proces-id:8408) restore energy scheme from {8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c} to {8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c}
(made this go away by setting the powerplan + set as group policy)
Thought I found the solution, until another disconnect happened :frowning:

In the eventlog I still have 1 entry that seems to come back when the disconnection occur:
Source: Microsoft-Windows-DistributedCOM
Event ID: 10016
Description: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{C2F03A33-21F5-47FA-B4BB-156362A2F239}
and APPID
{316CDED5-E4AE-4B15-9113-7055D84DCC97}
to the user BLABLA from address LocalHost (using LRPC) running in the application container Microsoft.Windows.ShellExperienceHost_10.0.19041.610_neutral_neutral_BLABLA SID (BLABLA). . This security permission can be modified using the Component Services administrative tool.

Haven’t found a way to solve it, but there’s even an article from Mircrosoft. Unfortunately they say, oh just ignore these errors or apply a filter to make them go away :slight_smile:
Event ID 10016 is logged in Windows - Windows Client | Microsoft Docs

Are you also seeing these entries when a disconnect happens? I wonder if they are related, or just show up as a result of the disconnection?

Add me to this list.

I have a 9900k, MSI 3090 Suprim X, and a Vive Pro and the game plays at 10 fps.

I really don’t understand how this is happening. Every other VR flight sim that I have works MUCH better than this.

1 Like

For sure, MSFS in VR should be fluid with a 3090, the issue may be with the nvidia drivers. I have a 2080Ti/i9-9900k/Index and it is playable in VR but it took me several hours to find the right settings, performance was very poor at the beginning.

I had to enable hyperthreading, revert to the driver 457.30, use SS 220 in Steam VR and 70 TAA in MSFS.

The result is stunning, MSFS in vr blows every other flight simulator out of the water.
Well done Asobo and I hope they keep optimizing VR , it needs more performance

2 Likes