14 FPS not moving on the runway

I can’t seem to reliably get this game to anything close to 30 FPS on a single 1080p monitor, and I have a Valve Index on the way! 14fps on a 1080p monitor will likely be like 4fps in VR. Loading screen jumps between 300 and 700 fps

As you can see, using MSI Afterburner, I’m nowhere near bottlenecked on anything. Screen shot taken while sitting still at the runway, not moving the controls at all.

Running a clean install of Windows 10 Pro on an I7-4790k, 16gb RAM, RTX-3070, game installed on SSD drive, running a single 1080P screen. Vsync is off, viewed the “how to” performance guide and turned down items that were listed as CPU taxing just in case that was an issue. Was originally at 12 fps, that jumped me to 14.

In comparison, I installed No Man’s Sky and run 120-150 FPS with every video setting at Max and moving around.

I keep getting the “upgrade your CPU” answer, but when you take your sports car to the track and only push the engine to 40% before you can’t get anymore power, that’s not an “upgrade your engine” issue. That’s a calibration, configuration, not enough oxygen to the engine, or something else going on. I’ve seen people run games at much higher FPS than this with the same CPU and their CPU is running at 85-90%. Why can’t I get past 40% with this game only?

Use the search option in the top right of the screen, search for ‘main thread’, and look at any of the dozens of topics that will show up with a lot of explanations of how this sim works under the hood.

1 Like

Which still is probably the correct one. The CPU is bottlenecking the GPU. Your analogy of the car is totally not relevant over here, since we’re talking about 2 different ‘engines’ (CPU and GPU): One for the system calculations and one for the graphics.

  1. Load a flight
  2. Press Esc
  3. Enable Options -> General -> Developers -> Developer mode and return to in-game.
  4. Move your mouse to the top of the screen. A menu will appear
  5. Select Options -> Display FPS

And tell us what you see

your GPU looks a little HOT.,could be why fr low.

133 F is 56 C. Not that hot.

oh sorry ,right your right its not bad at all.
eyes are a little off today

I’ll do that in a bit. Playing No Man’s Sky.

Can you get a screenshot of the FPS counter in dev mode and share that when you have this issue?

I do see you’re using almost 13 GB of RAM on MSFS, maybe your system is swapping and therefore very slow?

Limited by Rdr Thread. Don’t know what that is.


clear out your community folder (renaming it is the easiest temporary solution) and check if it’s still the same.

Not sure what that community folder did by renaming it, but big increase. The FPS still concerns me as to what it will be when running my new VR Setup.

I’m ok with 40 FPS, assuming that since all of the graphic rendering is done by the GPU, the addition of the VR will just tax the GPU harder.

mods and liveries (especially outdated ones) can cause all sorts of issues.

Regarding VR: it’s going to be really hard on your system. Most VR headsets will need 3 to 4 times the resolution you’re currently running on.

Regarding your setup:
a 3070 is complete overkill for 1080P, that’s why you’re not seeing much utilization of it. It will do a lot better on the resolutions required for VR.
You’re currently limited by the main thread (single threaded CPU performance), as is to be expected with an almost 7 year old CPU. For a pleasant experience on VR you’re probably going to have to do an upgrade there.
Quick way to get an idea of the performance you can expect is to bump up the render slider to 200%. The sim will then run on double the resolution, and downscale it to 1080P.

I suggest looking into the Ryzen 5 5600X, coupled with a basic B550 motherboard, and 16 or 32GB of fast RAM (3600MHz suggested, budget permitting, 3200MHz minimum). It’s pretty much the performance sweetspot for the sim (and other games) currently. Getting more cores/threads will be a waste for gaming / simming workloads.

p.s. Since your current issue seems resolved by getting rid of the mods, you can mark my previous post as the Solution by ticking the little grey checkmark under that post.


Well I am glad we were able to get some answers to your problem.

That’s odd as it was a clean install of the OS and the game. Have only had it for a few days and hadn’t even looked into mods for it.

Thank you to everyone who helped me figure out what was going on. I didn’t expect 150fps, but 12-15 seemed a bit under par for it ;). Appreciate all the help!

I stepped up the settings like you suggested and still got about same frame rate. Now it just jumps between main thread and GPU constantly for which the bottle neck is :wink:

that’s a pretty good place to be in all fairness, means neither component is significantly bottlenecking the other with your current settings.
If it’s enough for you for an enjoyable VR experience will be up to you. It’s just that with your current CPU dropping graphics settings will not bring you any more FPS, if you upgrade the CPU dropping the graphics settings will bring more FPS (and thus more options to tune your setup).

I was reading more on it and it sounds like even with the best rig possible, if you keep your settings on high, you are maxing your your CPU and GPU at 50-60fps. Part of it is being blamed on it using the old DX11 rather than 12, and part is because the primary bottleneck of the game is single core based, so the higher your processing speed on the core level, the better results you will get. It’s believed that when they upgrade to using DX12 which supposedly is on the shelf, it will open up the game to much more system resources.

While running the updated settings as you suggested, my GPU was running 90+% almost the entire time.

Don’t expect too much of DirectX12. The devs have already stated that it will give some more visual eyecandy, and maybe a slight performance increase.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.