3rd Party Application Toolbars Scaling Broken?

FYI there is a fix for VSR; but before I release it, I need to know from Asobo/MS whether this is going to be addressed, or whether this is a permanent “feature”


This item has been reproduced and turned into an official bug report internally. This topic is now updated with the #bug-logged tag. From here, Asobo prioritizes the bug, works on a fix, and slates it for a future update.


thank you for the update

1 Like

Good to know this is on the Developers radar now. Hopefully the fix will be quickly forthcoming. I too am having the problem with all third-party toolbar apps. All fonts and UI’s in general are now very very small as compared to just an update ago. The default Asobo toolbar apps don’t seem to experience the issue with the tiny fonts (i.e. ATC, VFR Map, Fuel, etc.), but all my third-party apps most certainly do. Those with font size options in their settings can be improved to a degree, but there are a few without such options that are now almost unusable. Hopefully the solution is an easy “reversal” of a small piece of errant code that got changed or corrupted.

Thx pls fix it before SU12 will be ready to go officially.

Thank you very much for taking care. This is a big relief for me. :heart:

“slates or for a future update” The big question here is When?

There’s regression bugs from SU5 & 7 that are still not fixed, how long is this bug going to take to fix? During this beta period? Or do we have to wait another 5+ Sim Updates/1+years?

It’s one thing having a regression bug logged, but seems to be another as to when they actually get fixed.


From a freeware developer perspective, we develop software for the MSFS platform and the community for no financial gain.

However, if Asobo don’t fix this significant issue by the release of SU12, then many developers including myself will question why we should continue to support the platform.


VR bug fixes and improvements don’t seem to be on any sort of priority list. Its sad. They hyped VR coming to MSFS and then they went silent about it.

1 Like

Same here, for instance Navigrap toolbar and certain Sky4sim pages

Honestly, I am getting a bit nervous given SU12 Release is only a few days ahead and this hasn’t been fixed yet. This is a regression introduced with the SU12 beta with a heavy impact on VR user experience.


Yes, I am having to rush out a fix in order to cover for MS/Asobo’s regression bug . Far from impressed .

Can we please have an update please on the estimated date this significant bug will be fixed?


How has Asobo not even acknowledged this? If this makes it into release, that’s shameful. Especially given the fact something similar has happened before and we had to wait months for a fix.

Again, VR users being ignored. I’m at least okay with things staying the “same”, but regressions like this are unacceptable.


Any status report? Should we expect SU12 breaking VR?


Considering nothing has been announced regarding a new update SU12 beta, I would say this bug will be around for some time. This is frustrating on the consumer side. This bug was introduced in SU12 beta and as such should be resolved before SU12 is released.

1 Like

We know that few bugs arrived with official SU, Asobo has very poor VR team, few bugs from more than year wasnt solved till now like ATC issues or settings of 2d windows from top toolbar (dont remembering). I hope they fixed it for official SU12.

So clearly this isn’t going to be fixed for some time…very annoying.

Hopefully the dev’s of Sky4Sim and the Simbrief panel are able to provide updates to make things better in the mean time. I know Navigraph have already provided some instruction on making it better.

I am lucky enough as a developer to have built something designed specifically for VR in mind; so was able to pick this up, test and develop a workaround (as yet unreleased) as I had a VR setup. I have spoken to a few devs who are completely unaware of this issue.

However, it obviously cannot be guaranteed that all developers have VR, and secondly are able to fix the issue. This is because many apps use iframe access to 3rd party sites where they do not have control over the content in terms of font sizing etc.

I am therefore requesting the moderators confirm whether this is going to be fixed by the release date. Otherwise this is going to create an issue that could have easily been avoided, lets hope MS/Asobo do the right thing.


Anyone with the update installed yet able to confirm?

is there an SU12 beta update out today? If so I will test