747 Autopilot Problem - Could be Me

Hi All,

New here, original Flight Sim player and thrilled its back after so long. I have just started getting into it so sometimes its hard for me to understand if something is a bug or if its me doing something wrong.

The main issue I am having is with autopilot and I know there have been plenty of posts saying its bugged but there’s also plenty of videos on YouTube showing it working perfectly.

I have just used to fly from New York to Toronto and all was fine, I got to 38k feet, it followed all the Nav points perfectly , but then as I was approaching Toronto I couldn’t turn it off. It wouldn’t disengage and then went out of control and spiralled to the ground. It just wouldn’t let me intervene it just kept descending even when I asked it to climb.

I had got it from 38 feet down to 22k as requested by the tower, then the tower told me to go to 3k which it did fine, but then kept descending and I realised I couldn’t disengage.

Is that me? Or a bug. Is there something I should do before trying to disengage Autopilot? This was with the 747 , but similar has happened with the Cessna 172

Autopilot is broken doesn’t work with this last patch, its just like everything else it’s a Broken Game. might as well wait about 2yrs from now then it might all be fixed. :thinking:

Are you turning off the ap by clicking the ap button on screen? Try using the Z key to toggle autopilot

Thanks SenseiLeNoir I will try that, always nice to get a helpful reply instead of “Microsoft Bashing”

The game is incredible

I just tried to do a full flight on the 747 yesterday, from Singapore to Bangkok. Had several issues with the AP:

  • While climbing in the AP, the aircraft suddenly went into a descent and I was just able to catch it before the disaster.
  • the AP sometimes does not go out when you click in the cockpit. But with the Z key, it work all the time.
  • When cruising at 35,000 the AP suddenly went out of control and spiralled to the ground out of nowhere. from then on it no longer wanted to follow the flight plan, every time I switched on the AP it immediately went out of control and spiralled to the ground. Then I switched off the L-NAV and continued flying with the course function.
    In the end I was able to land in Bangkok without crashing. But I think that there are unfortunately still various bugs in the AP of the 747, and also in the 787. I hope that they are fix it soon.
1 Like

One thing I did find once when it spiralled on me is that the altimeter reading had changed, I got a message from ATC saying “altimeter 29.92” or something similar and hadn’t taken much notice. But when I looked the reading I had when I set off wasn’t that. I pressed “b” and all seemed fine again until I tried to turn it off. I will try the “z” key next time.


I managed to get control of Autopilot to a point this time by using “z” . however I couldn’t get it to stop with the auto throttle. I managed to get down with a terrible landing because of overspeed but even on the ground it was applying throttle to try and go 200 knots which was the last speed I had set. I unticked the SPD buttton, tried disengaging autothrottle but nothing worked. As soon as the brakes were off it was off trying to get to full speed again.

At least I know its definitely a bug now, not just me doing things wrong!

The crazy thing about MSFS, is that it seems to be very much rig set up dependent.
Things work for some, and don’t for others.
Some workarounds for the same problem work for some, and not others.
The A/P problem is one that seems to affect a lot of users.
You really have to research threads on the topic, try what others have found, and take it from there.
The problem has been reported to ASOBO, but as you can probably tell, they do have a lot on their plates right now.
It will get resolved at some point I’m sure, when is the bigger question.

For those who experience the bug using rotary sw hardware to increase decrease speed heading and altitude have to use fsuip to prevent toggle switch bug. If not then the increase is 10 kjots 10 degree and 1000 feet only.