A310 Honeycomb Bravo rotary knobs only affects Vertical Speed

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

2 tags are required: One for platform, and one for aircraft.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.


Which aircraft are you reporting an issue about? (Please also add the proper tag for it)

IniBuilds A310

Which aircraft version are you experiencing this issue on? (You can find this listed in the Content Manager under the Aircraft Name)


Brief description of the issue:

On the Honeycomb Bravo, when I turn the right AP rotary knob, it always changes the vertical speed, whatever the position of the mode selector (left). I can’t change IAS, HDG or ALT…
(Only with the A310, no issue with A320 or PMDG737, with the same hardware profile.)

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Launch a flight with the A310 and try the AP knobs on the Honeycomb Bravo.

PC specs and/or peripheral set up if relevant:

Honeycomb Bravo

Build Version # when you first started experiencing this issue:

Since SU12

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

We’ve moved your topic into the General Discussion & Community Support category.

The Bug Reporting category is for posting suspected or confirmed bugs that other users are able to reproduce. Using the template is required in order to provide valuable information, feedback, and replication steps to our test team.

If you are not sure if your issue is a bug or need further input from the community, please use the Community Support category. If the community can replicate your issue, first search the Bug Reporting category to see if there’s an existing topic. If it already exists, contribute to that report. Duplicate bug reports will be closed.

If you believe it is a new report, then create a new bug topic using the provided topic template.

All issues caused by or involving third-party addons/mods should be reported to the third-party developer. Assure that no addons/mods are used when reporting issues in Bug Reports.

Am I the only one with this issue ?
Do you guys have the honeycomb PA working perfectly with the A310 ?
If yes, what should I try to resolve the problem ?

I have no idea if you’ve seen this, but watch this vid all the way through, even though some of it applies to 4 engine aircraft.
There may be something in there that may help:

Hi, thanks for your answer.
My settings are good, all others aircraft work perfectly well with the honeycomb PA, the A310 is the only one to have the problem I described.
It sounds like it is not looking for my settings but obey to an other law: every modes affect Vertical Speed…

Regarding your setup, e.g. for autopilot airspeed, do you confirm that you see:

Because for me the Inibuild A310 is one of the rarest airliners that work almost out of the box with the Honeycomb bravo.

Can you show us a screenshot of your assignations to see if we can spot any mistake? Only the one to modify autopilot reference values please.

Hi, thanks for your answer.
Yes, for exemple for the altitude selector I have JOYSTICK BOUTON 21 with ON PRESS action.
I tried to delete and reinstall the A310, same issue. (with or without the enhanced pack)
Tried to reinstall honeycomb drivers, same issue.
Tried with and without FSUIPC, same issue.

Tried with an other aircraft: all the PA functionalities works perfectly fine…

In the Controls Options menu, select your controller from the top menu, and on the left, click on “Search by Input” and use a button in the controller that will cause this.

Are any other commands displayed?

Do the commands work OK if you just use the mouse to change the cockpit controls?

Good idea, I checked no other commands are linked to these inputs, but there are not.
PA commands works well with the mouse (so I can fly anyway).
I hope the SU14 will make it works again (it works well before SU12 for me). So frustrating !

1 Like

First to be sure, we’re speaking about the free Inibuild included A310, right?

If so, I think I see. Do NOT use the altitude bug select to interact with the FCU. Delete that one.

But instead assign ones that look like: INCREASE AUTOPILOTE ALT and DECREASE AUTOPILOTE ALT (I don’t remember the names exactly). Then for each of these one do: ON PRESS, scan input and select ALT on your Bravo and turn the knob left or right depending if it’s increase or decrease.

To select ALT (or any other) while scanning input you have to be on the position (i.e. a selection) of one which is NEXT to the one you want. Then:

  • select it while scanning (turn button ON).
  • Turn the rotary knob in the desired direction.
  • Select it back to its PREVIOUS position (turn the button OFF). This simulate on ON/OFF button to release the scanning. Remember you’re doing an ON PRESS.

You should then have JOYSTICK BUTTON 17 + JOYSTICK BUTTON 13 with ON PRESS as action for the desired input. As you have to do it twice for each Bravo control, it’s a total of 10 items to set up.


Thank you very very much ! This was the solution (for the IniBuilds A310 yes) ! Didn’t think to set it this way but now it looks obvious :wink:
Thanks again !
Cheers !