A320 rudder not working since SU10

Ever since SU10, I cannot control my aircraft. As the title says, the rudder isn’t working at all on the A320 and when attempting the landing challenge, the aircraft controls are inverted despite my settings not being changed.

Very very weird.

Do you have any periphals set up? Like the Thrustmaster A320 joy stick?

Works fine for me using an Xbox controller on PC.

1 Like

None at all. I’m simply using my Xbox controller. Literally nothing has changed regarding set up. I had an hour on the sim yesterday, no drama. I downloaded the update and everything is uncontrollable.

I’m currently downloading the updates in the content manager and then will see if it is limited to that aircraft or all of them.

1 Like

I’ve got the same issue as well but it’s every aircraft with uncontrollable rudder. Using Xbox controller. Turning auto-rudder off and on has no effect.

1 Like

I’ve never had this issue. Hmmm. You cannot move your rudders at all? What are the buttons bound to?

I have noticed that my roll controls have been inverted. And my rudder controls have not centered on the aircraft. The rudder seems to stick until you move it in the other direction. System: Xbox Series X

Are any of you Xbox users using peripherals other than the Xbox controller?

I did not see this behavior during the entirety of the beta, but I use the Thrustmaster Boeing yoke, TPR pedals and/or the Hotas One.

I don’t use the Xbox controller for flight, but do use it for camera manipulation.

I am using an Xbox controller.

Had same issue and determined it was the weather. Turn live weather off and set for clear skies. Issue went away for me. Hope this helps, if not worth what you paid for it. :rofl:

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No
Have you disabled/removed all your mods and addons?

No mods, only content from maketplace.

Brief description of the issue:

I’m using using xcloud and xbox one controller. After the SU 10 update strange things happened to controling the aircraft. On xbox/xbox controller you are using the left and right trigger buttons to control the rudder. And it used to be before su 10, when you release the trigger the rudder centers. After the su10, the rudder stay in the last position when you release th trigger. This makes it very hard or impossibe to control the aircraft on the ground. Happen with multiple aircraft, possible all.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Xcloud and xbox one controller

Build Version # when you first started experiencing this issue:

SU10 on 21st september 2022

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Not sure what OP is.

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hi I am having the same issue on my Xbox series X. The rudder stays in a position until you move it out of that position. Hoping Microsoft fixes it.

I have now got the problem fixed but I have no idea how. I just rebooted the sim and everything was back to normal. No more inverted controls or issues with the rudder. Very weird but glad the Xbox got back to normal.

1 Like

I found answers to my problems and others problems described in this thread.

  1. Inverted flight controls, ailerons was due to reverse axis check box was not ticked for som reason. Ticking it of in control options fixed that.

  2. sticking rudder was due to for some reason the trigger button was suddenly assigned to the control options rudder right/left (yaw right/left). The fix was clearing those assignments and asigning the triggers to the option rudder axis right/left and leaving the reverse axis boxes ticked.

Hope this can help others on xbox and with xbox controllers.

Have a nice day.

4 Likes

Posted this earlier, but this seems the more relevant thread.
Just tried this and now for some reason my cursor is gone and neither of the sticks on my controller appear to do anything. I’m also unable to even use the d-pad to navigate the menus, so I’ve got no way to access the controls menu to change anything. The other buttons seem to work though.
My controller’s firmware is up to date and the GamePass app has been updated and seems to still recognize the controller.
I’m also using XCloud so there’s no work around since I still can’t use a KB/mouse.
Forgive me for this likely self-inflicted gunshot wound, but if anyone has any ideas, it would be greatly appreciated.

I had exactly the same problem.

you have to press start button on the microsoft flight sim app → Game and Addons → manage cloud storage → delete all stored cloud data

you have to setup your general flight sim options again, but all my downloaded content stayed in the content manager.

fixed cursor for me. hope it helps you

1 Like

Thank you for the advice. Yeah I ended up just doing what that guide suggested by deleting all of my cloud-saved data for MSFS via my physical XBox, which included ALL logbook/bush flight/activities progress. That seemed to work, and lucky for me that none of those features actually worked all that well anyway.
For example, my logbook only had roughly 25-30% of the flight time that it should have had. So no biggie there.
Upon retarting, the only real pain in the empennage though was having to re-enter my controller bindings/sensitivities.
However, not only did my controller work again, but all of the WUs and 3rd party content were still installed.

Hi everyone,
I have the same issue but I am playing with Xbox Cloud. Is there any way to solve this? Everything was OK before the SU10.

You have to follow the instructions above :+1:
I’m on Xcloud too.

Or are you on PC/Tablet or Phone?
then I cant give you any advice, because I only use it on my Xbox one…

Indeed I am also on xcloud, but I cannot find the option to delete all the saves (which is also something I would not want since it would delete all the progress for the bush filghts).
Is it only possible if you have a phisical xbox?