A320nx fbw - RNAV does not work

I am trying an RNAV approach in the same way as 320 sim pilot. Same rwy, Star etc.
I even get alt* at 3000ft. But i can not activate the approach Button. I even got a Green rectangle and something like v/dev on the Monitor. But the Button does not work for this kind of glideslope.
As i have not seen anything like a frequency to enter etc. I do not know why it doesnot work. I am Sure in the past it worked.

Which version are you flying, Stable or Developer?.

Developer and last Update.

Suggest you go onto the Discord site and flag it up as a possible bug

You’re expecting to auto land an RNAV approach on a runway that don’t have an ILS frequency?

I believe the APPR button was deliberately disabled on RNAV approach because they’re working on the LNAV/VNAV functionality.

It’s not a bug, it’s an unreleased feature at the moment.

In the meantime, use the FPA/TRK function to descend on an angle when you pass the appropriate waypoints in the RNAV approach.

No, I don’t expect an ILS-Approach. I know you can’t autoland via RNAV but there is some kind of glideslope which is used via GPS. QNH etc. also actual. I’d turn off the autopilot to land.

That could it be because I’m sure I did this about few month ago with no problems. Thanks!

Yeah, I also remember you can press the APPR button before, but frankly… it doesn’t do anything other than showing FINAL APP on the FMA, but it doesn’t behave the way it’s suppose to. Most of the time for me using APPR on a RNAV approach just made the aircraft level off and not descending on the profile at all made me missed my approach to go around. So I can understand why they just disabled it straightaway while they’re working on the proper FINAL APP mode.

Looking at the RNAV chats, and determine the FPA and when to engage the FPA descent mode, is much more reliable.

Ah yes, barometric vertical guidance.

Good to know they are still enhancing TRK/FPA managed mode capabilities on the NX mod.

Yeah and it is no problem as I know that I am not to dumb to use it but it is not implemented anymore. So I will use the bird and trk.

Autopilot / Fly-By-Wire - FlyByWire Simulations Guides

On the development version you have custom FBW, AP and ATHR system. Unfortunately I’ve found no easy way to “activate” RNAV for testing and do those approaches easily that’s the main reason it’s not implemented yet.

LNAV and VNAV is being worked on right now and I think will ease this then it can be implemented.

1 Like

Any idea of this was fixed ? I tried two nights in a row , same RNAV approach …button still not working. I’m on the dev level and it is now Jan 2022 !
Anywho …I tried hard to learn a RNAV but I can’t tell if I’m doing it wrong or that button truly doesn’t work ?

Yes, it’s Jan 2022…and now?

This hasn’t been fixed yet. The team is working hard on the lateral navigation. Parallel work on the vertical navigation has started as well but it just takes time. The guidance is already in the AP but the calculation of the path is to be done…

Just a bit more patience and it will come!

Been using managed nav mode for the lateral guidance for RNAV approach, and I use the FPA TRK to adjust my descent to keep within the VDEV indicator. Never had a problem.

As Neo4316 states, perfectly good workaround for now is to use lateral guidance for RNAV approach and then switch to TRK/FPA just before the FAF (final approach fix). Firstly though, make sure you’re fully confgured for landing (gear down and flaps as required) before you reach the FAF. Then, about 1 minute before reaching the FAF, switch to TRK/FPA mode and select the recommended glideslope angle from the relevant runway approach chart. Activate TRK/FPA mode at the FAF - the plane will then start to descend at the angle you’ve specified. Then as you descend just monitor your actual altitude vs the recommended altitude at each mile indicator from the runway touchdown zone shown on the approach chart (you might have to manually adjust the TRK/FPA angle up or down during descent to match the chart altitudes, but not by much). Once you are at approx. 500ft AGL, turn off the autopilot and manually adjust the rate of descent to land in the touchdown zone. I’ve been using this approach with both DEV and EXP versions of the FBW (always the very latest versions) f\or the last 6 months or so, to land at many different airports and it works absolutely fine in all cases.