A32NX FBW Custom Autopilot

So I’m still having some issues with the new custom AP in the new custom/experimental version of the A32NX FBW mod. Idk if I’m doing something wrong or if it’s just that the new AP is still buggy and a work in progress. Here’s a rundown of some issues I’ve been experiencing on my recent flights (including my current, live flight).

So for example I’ll use the flight I’m currently flying (PHOG/Kahului - KPDX/Portland):

Upon setting the aircraft up pre-takeoff, I set my airspeed, HDG/NAV, and altitude into the top panel. For this flight, I set my airspeed to Mach 0.80. I then engaged NAV mode and confirmed it in the FMA, and then set the altitude to FL310 for cruise.

I set up my throttle FLX setting to 52 degrees for takeoff. With every the big set and ready to go, I takeoff and set my thrust to FLX power. Everything is still good.

After takeoff is where I’m having issues though. When I get the flashing LVR CLB induction, I reduce to CLB power and then for some odd reason it switches out of NAV mode and into HDG mode. I couldn’t get it to switch back into NAV mode on the panel. So I continue to climb and decide I’m just going to climb all the way up to cruise and then figure it out. So when I approach FL310, I play around with the power and somehow I got it to go back into NAV mode. So I then engaged the AP and AT. It stayed in NAV mode like it should thankfully, but then after clicking down on selected mode it decided to keep increasing speed past Mach 0.80 (Thus began over speeding) and it kept climbing past FL310. After a few minutes of once again playing around, somehow it finally decided to stay at FL310 and Mach 0.80 and as of now, it’s flying like it should.

So after all of this, why am I experiencing these issues? Is it something I’m doing wrong or is the AP still a little buggy? Like I said, I experienced these issues on my flight yesterday as well, but all of my test flights seemed to be fine.

Why does it keep switching out of NAV mode after takeoff after it’s been engaged (and then it won’t switch back) and why is it blowing past my set altitude and cruise speed when I have it in selected mode (clicked down)?

Sorry for the long post, but I obviously needed to go into some detail here.

I don’t think you should set the airspeed to 0.8 mach from the gate. Just keep it on managed airspeed and make both airspeed and heading as (—). You can switch to mach 0.80 when you reached your cruising phase. But not before. Keep everything at managed mode until then.

2 Likes

I definitely feel like I need to do some more test flights to get a feel and make sure I’ve got my procedures down correctly. I probably haven’t done enough test flights yet to make sure everything is okay.

But I’ll definitely start doing that. I even thought that might be my issue. I’ll start setting it during climb and see if that makes things better.

How about the altitude issue though? Any idea why it would continue climbing past my selected altitude instead of leveling off? I’ve watched all of your recent uploads flying the new custom build and yours doesn’t have this issue. It must be something I’m doing wrong.

Even setting it during climb is a bad idea. The airbus climb thrust takes into account the airspeed which relates the amount of thrust and rate of climb. If you set it to a selected airspeed at 0.8 mach even during the climbing phase. The aircraft will start to target the selected airspeed prematurely. On low altitude 0.8 mach is impossible to achieve due to the thicker air. And since it’s on selected mode, the aircraft will try to reach it while climbing, which will overspeed it and causes a lot of issues. In other words, don’t set it during climb. Let the airbus climb using the managed mode. It will automatically set 250 knots below 10,000 ft. Then it’ll automatically switches up to the climb airspeed (usually around 285 knots) above it. The higher you go, the faster your true airspeed is but the lower your indicated airspeed. The mach will keep on increasing as you climb.

Once you get to cruising phase, you should be at around 0.78 mach. Only then, you can switch to selected airspeed and speed it up to 0.80 mach. Not before. If you want to change to selected airspeed below, use the IAS knots mode, don’t use Mach. Because mach is relative to the altitude and air density, IAS knots mode is not.

Whenever I change altitude, I also climb and descent in managed mode, I press the top side of the altitude knob which should turn on the dot under LVL/CH. This means the climb and descent will be using the optimal calculated rate set up in the MCDU.

2 Likes

A better way to achieve a cruise speed of mach 0.80 is to set cost index very high. Since this is a sim and fuel costs nothing, use 99.

Well, vertical mode does usually not influence lateral mode (the opposite is the case).

Most important for NAV are the following two simulation variables:

  • GPS IS ACTIVE FLIGHT PLAN
  • GPS WP CROSS TRK

The first must be true and the second must be within 10 NM, otherwise it looses NAV.

So basically I think it’s a problem of the default flight plan manager. Until we implement a custom LNAV system those things can happen and it’s hard to explain honestly.

I don’t think Cost index is fully implemented yet. I always fly using cost index of 100. And managed mode cruising is always on 0.78

I only use the default world map for my flight plan manager. I don’t know if that’s related.

Ah I did not know that about cost index. And yes, the default flight plan manager is working fine (such as it is). However I am updating the default nav database with Navigraph data.

I just had flashing LVR CLB for the whole flight, dont have a clue what it is, maybe something to do with the new calabration featue on the skypad

Hmm, it might help to learn to fly the Airbus…

1 Like

by your reply, I can tell you dont have a clue what an airbus is. Cheers

1 Like

I don’t know what that’s supposed to mean. I’m not a real pilot. The airbus in the sim is not a real airbus. But I know what an airbus is.

It means your thrust lever is at the wrong position. You have to move the thrust lever into the CLB detent.

I suggest you watch some videos from 320 sim pilot on YouTube. He makes great tutorials about flying the A320 in MSFS. And they’re pretty easy to follow.

3 Likes

So in other words, you don’t use SimBrief? I also only use the world map feature, but I don’t think that is really related here.

Idk who you’re replying to here, but if it’s to me, I’m literally trying to learn. That’s the point of my OP if you actually read it.

Can’t learn without asking and failing…

1 Like

Neo gave some good tutorial video sources for learning to fly the airbus.

1 Like

Yeah like I said, I need to take some time to learn the new system and perform some more test/practice flights. Next time, I’ll try not setting the speed to Mach 0.80 during climb and see if that helps.

While we’re talking speeds here, so I know the 250 under 10,000 feet rule and I always stick to that. However, above 10,000 feet, what speed should I increase to up to climb? Also, when you say managed speed mode, that would be by clicking up on the speed knob correct? And then it should stay dashed (- - -). Also, I do understand the airspeed increasing with altitude.

This all makes sense to me, I just need to practice it and watch videos to make sure I’m not doing something wrong.

Yes, all that is correct. Managed speed is the way to go. With the Airbus, you can let the plane decide the optimal climb rate above 10k. With other planes you usually have to look up performance tables or vertical profiles for “best” climb rate (best fuel efficiency/best climb speed/best airspeed/many different “bests”).

1 Like

Gotcha. As far as descending though, is it best to use selected or managed speed for that phase? Or will the aircraft know what speeds to be at for descent (like the reverse for takeoff and climb)?

Again, the airbus is highly automated. Managed speed on the descent. Other aircraft you generally have to decide for yourself but it is less critical then climbing. You want to balance not overstressing the aircraft but also not going too slow and increasing travel time.

I usually fly the airbus like real world pilots and never take the aircraft out of managed speed/heading until almost ready to land. And then only if ATC specifically instructs.