A32NX mcdu 'DIR' Function and random waypoint jumps

Dear sim experts / fbw team,
When i try to use DIR for Direct-to a waypoint, the AP navigates to the waypoint as intended, but once reached, it does not follow next waypoint in list and diverts ‘randomly’ to a different waypoint. In one instance, the AP skipped directly to runway destination, ignoring all the fix waypoints to it, while at downwind. I had to disengage AP. Not even a single direct-to leg, has gone well for me.

In another instance, during descend I tried to change the approach transition, then I changed my mind and returned to F-plan using *Erase. There was no change in waypoint list and all looked good as before. But the AP randomly diverted the plane to a different waypoint that was already crossed.

I have never flown a vanilla A320, so I don’t know if this issues exists there too.

If its not a bug, kindly let me know where I am going wrong.


I have had the same issue as well.

You are doing nothing wrong.
It is a problem in the default autopilot that causes this.
There actually are several posts here on it.

If you go to the A320 mods site, and browse through the Issues, and the Discussion headings, there is a lot more info there on it as well.


yeah. I was in their discord a few weeks ago, they are working on this as well as re-writing the entire fly by wire system. Said it’s a problem with the default MSFS and the only fix is to replace the entire flight planning logic within the plane.

1 Like

Yeah, today I had similar problem.
Flied LYBE to EHAM. Loading SID was no problem, whole route also, when I was close to EHAM I choose STAR, after plane take almost 90° bank to the right, doing circles. I disabled AP, nothing happen, tried to engage manual hdg mode, no changde, last I tried DIR, after it CTD.

Beside from A320…
Right now this sim is only flyable as VFR and general aviation, because non of the big birds work.
This looks like more like beta version than full version ready for release. Also what I find missing, we had that in FSX, is airport info, even we are far away from it, that is ILS freqs, weather situation at airport. In this new FS, I can only know weather situation from ATIS, but what abou APs who doesn’t have ATIS or I am too far from AP and I need to choose STAR, but I can’t know which one to chose because I don’t know which runway I will land.

That’s pretty well my take as well.
I hope I have this correct, so this is just my summation.

The first step was to write the complete program that creates and connects the various control surfaces, etc., to that particular surface’s controller.
That is what is known as the “fly by wire”.
I believe that is getting quite well along in completion, to the point where they can devote most of their focus towards work on the autopilot, which, as you may have noticed by the chart on their site, involves making all the various autopilot function’s coding that “connects” to that new “fly by wire” system.

Happened to me too. After the last update today I got also no updates in the flight plan. Always the same distance to the arrival airport. Also sometimes the speed is not shown correctly and jumps wild between 40 and 60 even if you fly 140 or want ever.

Hi mate!

Have you had any solutions about this? I’ve got same problem.

Don’t know if switching to developer or stable version is better to avoid this DIR problem.

I appreciate your help.

This issue has been fixed in the latest Sim Update. I am able to Dir-to selected waypoint and continue from there without any issues.

Hi there,
It’s not fixed for me… but not specifically from a DIR to. It jumps directly to destination RNW after a proper SID and first WP… then ignore all others and go straight to destination runway.
Sometimes also, simply return to previous wp, and run in right circles…
Any clue ?

Hard to understand from your description. But it’s probable that there is something wrong with your procedure. If you can document exactly what you are doing in a reproduceable way, you can submit it as a bug report to the FBW github. But be very detailed and thorough. It’s possible you found a flaw in the mod.