Adding new UK POI in Flight Plan Breaks G3000 Flight Plan

If I select one of the new POIs as a waypoint when creating a flight plan it is not added to the flight plan in the TBM 930 G3000 and there is no magenta line on the MFD or PFD CDI:

The above was a flight plan departing EGHH arriving EGMD with the following POIs
Spinnaker Tower
Brighton Palace Pier

If navaids are added and old POIs are used everything is fine:

The above was a flight plan departing EGHH arriving EGMD with the following POIs and navaids:
Brighton Palace Pier

I also experienced the PFD and MFD freezing when selecting a POI to fly to in the broken flight plan and a CTD.

The same happens in the C172 G1000

Did you try it with the various mods for the Garmin units found on, or are you using those?

No I haven’t installed any mods, trying to keep the install as clean as possible.

It looks to me as though the new UK POIs have not been included in the Garmin database.

Thanks for taking the time to reply.


with the last patch is broken the flight plan…If you add a POI between two airports of departure and arrival the vfr map and the garmin shows only the last segment…I submitted a request to zendesk
i made some test …It seems to be correlatoed to the POI ok UK USA and Japan…the regions of world update…In italy for example it works

The last screen shot is in Italy…The first two are in Uk and also In usa i have the same problem

1 Like

Hi. Has the issue of invisible flight path on vfr map been resolved? I just did a major japan flight stream based on a flight plan and many parts of the path were not showing. The flight plan included quite a few POIs. Went back to previous flight plans, including UK, and lots of them were not showing on the vfr map either. I’m working thru this now.

Having similar issues with flight plans that have points of interest as waypoints. I think of them as invisible. If auto pilot is working properly the aircraft will still follow the flight plan (at least for me it was). This includes flight plans for UK and Japan with POIs as waypoints.

Possible solution: I found that adding an airport as your first waypoint after departure brought back the entire flight plan path even with multiple POIs as waypoints afterward. Tested this a couple of times and it seems to work.

It’s a known bug that POIs with longer than six character names will cause Flight Plan legs to disappear or be intermittent.

It’s not true the the poi with more than six characters create conflicts…It’s another bug…
This bug prevent to add a poi as a waypoint…This is an example of poi in Italy major of six characters that doesn’t create problems

The bug appear in the world update regions…The segment unitl the poi is not showed …I already posted some photos up here…

1 Like

The “possible solution” did not work in my UK flight plan. The flight path kept disappearing and reappearing. It may have something to with POI to POI in flight plan. The flight plan itself remained valid and the AP followed the route no matter how many POIs were consecutive. This is a flight plan that previously worked fine during a live flight stream with loads of sim pilots.

I have been doing my testing in the TBM 930.

To confirm I would have to create several flight plans that go;

  1. airport poi airport poi airport poi airport.
  2. airport poi poi airport poi poi airport poi poi airport.
  3. airport poi poi poi airport poi poi poi airport poi poi airport.

before the patch it worked correctly